17.1.10 fresh install only boots using usb media detect efi

asus laptop i7-3630QM 6gb samsung evo 500gb ssd zapped with gdisk. install 17.1.10 xfce from usb, remove usb and reboot gets asus setup screen. boot with usb and choose detect efi and it boots fine. have tried everything i can find with search and still the same. willing to try again if some1 can point me 2 a link on how to fix this that works, but now i have returned to xubuntu.

Personally i don't think you tried everything :slight_smile:

See this one first.. Hopefully your Asus if simpler to fix. And it is not the Lenovo that has sold its soul to the Devil.

If your Asus needs special uefi settings, see the link for Asus at the bottom of first post.

Sounds like you installed the boot loader to the USB device instead of your local disk.

There is no link that will tell you how to fix that - you simply have to install the boot loader to the correct device.

Listen to @gohlip. :slight_smile:

His system is uefi. Unless he chose an $esp mount point in usb, that won't happen.
And to fix a bios-legacy 'mbr' to sda, it's quite simple. When booted
sudo grub-install /dev/sda
sudo grub-install /dev/sdb, if sdb is the primary drive as detected by the bios.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by