19 February 2019 system update: issues which I encountered

Hi people, new user here.
I had Manjaro 18.0.2, and today I received the big update to 18.0.3.
I noticed that there is already a thread about:
[Testing Update] 2019-02-14 - Kernels, Systemd, Browsers, Calamares, Firmware, Plasma5, KDE Framework

Sorry: I made confusion; this one is the right discussion:

I wish to give a reply to the poll of such discussion (Yes there was an issue. I was able to resolve it myself) but I cannot even reply to such thread.
Well, would be nice if an admin could merge this topic to such discussion, since I'd like to contribute with my user experience:

In the middle of the update process, the screen went black (but still turned on, like the whole computer); since I am almost a noob with Linux, i didn't know what to do: I waited for about 10 minutes then I forced the shutdown of the laptop by using the power button; at the next boot the update process was restored from what was left, and i received the error error: could not open file /var/lib/pacman/local/dnsmasq-2.80-3/desc: No such file or directory (I use dnsmasq to block ads), which I solved by running

sudo pacman -Rdd dnsmasq
sudo pacman -S dnsmasq --overwrite '*'

Then the system update was completed.

Apart this problem, the system seems fine (feel also smooth than before!); I didn't noticed other errors or issues, or at least seems. Can someone suggest me how to properly check if the update went fine?

If i run sudo pacman -Syu i get

:: Synchronizing package databases...
 core is up to date                 0,0   B  0,00B/s 00:00 [-------------------------------]   0%
 extra is up to date                0,0   B  0,00B/s 00:00 [-------------------------------]   0%
 community is up to date            0,0   B  0,00B/s 00:00 [-------------------------------]   0%
 multilib is up to date             0,0   B  0,00B/s 00:00 [-------------------------------]   0%
:: Starting full system upgrade...
 there is nothing to do

The result of lsb_release -rdis

|Description:|Manjaro Linux|
|Release:|18.0.3|

`uname -a`
Linux Probook 4.20.10-1-MANJARO #1 SMP PREEMPT Fri Feb 15 21:46:13 UTC 2019 x86_64 GNU/Linux

Cheers.

2 Likes

My sistem is down. I've installed an update and it crashed all my Manjaro system.
The screen shows a message announcing that many services aren't working, services such as network manager, and many others.
I don't want to lose my data.
I've dual boot with Manjaro Gnome and Windows 10. I am a principiant with Linux and I don't know what's the process to access to my personal files in Manjaro.
The last instance is format Manjaro partition, but I'd like that someone of you may help me.

Would you like help?

I'm sorry for your system failure, however I think that the best way to save your data, while the system is not bootable, could be to boot from Manjaro's live usb (or DVD), to access and get files from your partition (which should be ext4 - I think that Windows 10 is unable to recognize such file system, or at least WIndows 7 is unable).

There is a guide to use TTY. See the tutorial here.

With this guide, if you have a usb, you ll be able to use the live version of manjaro and access your files.

kaiwen, have you seen the other posted topics about the problem with libidn2? I had the same issue, so I booted a live USB stick, then linked libidn2.so.4 to point to libidn.so.0.3.5, and that got my system able to boot with networking. From there, I was able to restart the package manager and complete the upgrade.

I just realized that the right discussion for my issue is this one below, since I am on the stable branch of Manjaro, and I receive the update on the 19 February 2019 instead of 14 February 2019:

But I cannot, still, insert a reply in such discussion.

Manjaro/KDE

i had a very similar issue as the OP - did the upgrade via Pamac and Pamac just disappeared - i waited probably 10-20 min. and nothing happened

pacman log indicates the update quit with [ALPM] upgraded qt5-svg (5.12.0-1 -> 5.12.1-1)

the full log...

[2019-02-20 05:39] [PAMAC] synchronizing package lists
[2019-02-20 05:39] [ALPM] transaction started
[2019-02-20 05:39] [ALPM] upgraded archlinux-keyring (20190123-1 -> 20190123-2)
[2019-02-20 05:39] [ALPM-SCRIPTLET] ==> Appending keys from archlinux.gpg...
[2019-02-20 05:39] [ALPM-SCRIPTLET] ==> Locally signing trusted keys in keyring...
[2019-02-20 05:39] [ALPM-SCRIPTLET]   -> Locally signing key D8AFDDA07A5B6EDFA7D8CCDAD6D055F927843F1C...
[2019-02-20 05:39] [ALPM-SCRIPTLET]   -> Locally signing key DDB867B92AA789C165EEFA799B729B06A680C281...
[2019-02-20 05:39] [ALPM-SCRIPTLET]   -> Locally signing key 684148BB25B49E986A4944C55184252D824B18E8...
[2019-02-20 05:39] [ALPM-SCRIPTLET]   -> Locally signing key 91FFE0700E80619CEB73235CA88E23E377514E00...
[2019-02-20 05:39] [ALPM-SCRIPTLET]   -> Locally signing key 0E8B644079F599DFC1DDC3973348882F6AC6A4C2...
[2019-02-20 05:39] [ALPM-SCRIPTLET]   -> Locally signing key AB19265E5D7D20687D303246BA1DFB64FFF979E7...
[2019-02-20 05:39] [ALPM-SCRIPTLET] ==> Importing owner trust values...
[2019-02-20 05:39] [ALPM-SCRIPTLET] ==> Disabling revoked keys in keyring...
[2019-02-20 05:39] [ALPM-SCRIPTLET]   -> Disabling key 8F76BEEA0289F9E1D3E229C05F946DED983D4366...
[2019-02-20 05:39] [ALPM-SCRIPTLET]   -> Disabling key 63F395DE2D6398BBE458F281F2DBB4931985A992...
[2019-02-20 05:39] [ALPM-SCRIPTLET]   -> Disabling key 50F33E2E5B0C3D900424ABE89BDCF497A4BBCC7F...
[2019-02-20 05:39] [ALPM-SCRIPTLET]   -> Disabling key 27FFC4769E19F096D41D9265A04F9397CDFD6BB0...
[2019-02-20 05:39] [ALPM-SCRIPTLET]   -> Disabling key 39F880E50E49A4D11341E8F939E4F17F295AFBF4...
[2019-02-20 05:39] [ALPM-SCRIPTLET]   -> Disabling key 8840BD07FC24CB7CE394A07CCF7037A4F27FB7DA...
[2019-02-20 05:39] [ALPM-SCRIPTLET]   -> Disabling key 5559BC1A32B8F76B3FCCD9555FA5E5544F010D48...
[2019-02-20 05:39] [ALPM-SCRIPTLET]   -> Disabling key 0B20CA1931F5DA3A70D0F8D2EA6836E1AB441196...
[2019-02-20 05:39] [ALPM-SCRIPTLET]   -> Disabling key 07DFD3A0BC213FA12EDC217559B3122E2FA915EC...
[2019-02-20 05:39] [ALPM-SCRIPTLET]   -> Disabling key 4FCF887689C41B09506BE8D5F3E1D5C5D30DB0AD...
[2019-02-20 05:39] [ALPM-SCRIPTLET]   -> Disabling key 5A2257D19FF7E1E0E415968CE62F853100F0D0F0...
[2019-02-20 05:39] [ALPM-SCRIPTLET]   -> Disabling key 7FA647CD89891DEDC060287BB9113D1ED21E1A55...
[2019-02-20 05:39] [ALPM-SCRIPTLET]   -> Disabling key BC1FBE4D2826A0B51E47ED62E2539214C6C11350...
[2019-02-20 05:39] [ALPM-SCRIPTLET]   -> Disabling key 4A8B17E20B88ACA61860009B5CED81B7C2E5C0D2...
[2019-02-20 05:39] [ALPM-SCRIPTLET]   -> Disabling key 5696C003B0854206450C8E5BE613C09CB4440678...
[2019-02-20 05:39] [ALPM-SCRIPTLET]   -> Disabling key 8CF934E339CAD8ABF342E822E711306E3C4F88BC...
[2019-02-20 05:39] [ALPM-SCRIPTLET]   -> Disabling key F5A361A3A13554B85E57DDDAAF7EF7873CFD4BB6...
[2019-02-20 05:39] [ALPM-SCRIPTLET]   -> Disabling key 5E7585ADFF106BFFBBA319DC654B877A0864983E...
[2019-02-20 05:39] [ALPM-SCRIPTLET]   -> Disabling key 65EEFE022108E2B708CBFCF7F9E712E59AF5F22A...
[2019-02-20 05:39] [ALPM-SCRIPTLET]   -> Disabling key 40440DC037C05620984379A6761FAD69BA06C6A9...
[2019-02-20 05:39] [ALPM-SCRIPTLET]   -> Disabling key 34C5D94FE7E7913E86DC427E7FB1A3800C84C0A5...
[2019-02-20 05:39] [ALPM-SCRIPTLET]   -> Disabling key 81D7F8241DB38BC759C80FCE3A726C6170E80477...
[2019-02-20 05:39] [ALPM-SCRIPTLET]   -> Disabling key E7210A59715F6940CF9A4E36A001876699AD6E84...
[2019-02-20 05:39] [ALPM-SCRIPTLET]   -> Disabling key 5357F3B111688D88C1D88119FCF2CB179205AC90...
[2019-02-20 05:39] [ALPM-SCRIPTLET]   -> Disabling key FB871F0131FEA4FB5A9192B4C8880A6406361833...
[2019-02-20 05:39] [ALPM-SCRIPTLET]   -> Disabling key 66BD74A036D522F51DD70A3C7F2A16726521E06D...
[2019-02-20 05:39] [ALPM-SCRIPTLET]   -> Disabling key B1F2C889CB2CCB2ADA36D963097D629E437520BD...
[2019-02-20 05:39] [ALPM-SCRIPTLET]   -> Disabling key 9515D8A8EAB88E49BB65EDBCE6B456CAF15447D5...
[2019-02-20 05:39] [ALPM-SCRIPTLET]   -> Disabling key 40776A5221EF5AD468A4906D42A1DB15EC133BAD...
[2019-02-20 05:39] [ALPM-SCRIPTLET]   -> Disabling key D4DE5ABDE2A7287644EAC7E36D1A9E70E19DAA50...
[2019-02-20 05:39] [ALPM-SCRIPTLET]   -> Disabling key 44D4A033AC140143927397D47EFD567D4C7EA887...
[2019-02-20 05:39] [ALPM-SCRIPTLET] ==> Updating trust database...
[2019-02-20 05:39] [ALPM-SCRIPTLET] gpg: next trustdb check due at 2019-05-10
[2019-02-20 05:39] [ALPM] transaction completed
[2019-02-20 05:39] [ALPM] running 'systemd-update.hook'...
[2019-02-20 05:45] [ALPM] running 'firefox-pre.hook'...
[2019-02-20 05:45] [ALPM] transaction started
[2019-02-20 05:45] [ALPM] removed geoclue2 (2.5.2-2)
[2019-02-20 05:45] [ALPM] removed libsystemd (239.303+really+239.6-1)
[2019-02-20 05:45] [ALPM] upgraded libjpeg-turbo (2.0.1-1 -> 2.0.2-1)
[2019-02-20 05:45] [ALPM] upgraded iana-etc (20181219-1 -> 20190125-1)
[2019-02-20 05:45] [ALPM] upgraded shared-mime-info (1.10-1 -> 1.12-1)
[2019-02-20 05:45] [ALPM] upgraded sqlite (3.26.0-2 -> 3.27.1-1)
[2019-02-20 05:45] [ALPM] upgraded libxau (1.0.8-3 -> 1.0.9-1)
[2019-02-20 05:45] [ALPM] upgraded pixman (0.36.0-1 -> 0.38.0-2)
[2019-02-20 05:45] [ALPM] upgraded libsasl (2.1.26-16 -> 2.1.27-1)
[2019-02-20 05:45] [ALPM] upgraded audit (2.8.4-2 -> 2.8.4-3)
[2019-02-20 05:45] [ALPM] upgraded libidn2 (2.1.0-1 -> 2.1.1-2)
[2019-02-20 05:45] [ALPM] upgraded libgpg-error (1.34-1 -> 1.35-1)
[2019-02-20 05:45] [ALPM] installed systemd-libs (241.159-1)
[2019-02-20 05:45] [ALPM] upgraded cryptsetup (2.0.6-1 -> 2.1.0-1)
[2019-02-20 05:45] [ALPM] upgraded kmod (25-1 -> 26-2)
[2019-02-20 05:45] [ALPM] upgraded pambase (20171006-1 -> 20190105.1-1)
[2019-02-20 05:45] [ALPM] upgraded systemd (239.303+really+239.6-1 -> 241.159-1)
[2019-02-20 05:45] [ALPM] upgraded xf86-input-libinput (0.28.1-1 -> 0.28.2-1)
[2019-02-20 05:45] [ALPM] upgraded harfbuzz (2.3.0-1 -> 2.3.1-2)
[2019-02-20 05:45] [ALPM] upgraded xkeyboard-config (2.25-1 -> 2.26-2)
[2019-02-20 05:45] [ALPM] upgraded hwinfo (21.58-1 -> 21.59-1)
[2019-02-20 05:45] [ALPM] upgraded libpsl (0.20.2-3 -> 0.20.2-5)
[2019-02-20 05:45] [ALPM] upgraded libnghttp2 (1.35.1-1 -> 1.36.0-1)
[2019-02-20 05:45] [ALPM] upgraded ca-certificates-mozilla (3.41-1 -> 3.42.1-1)
[2019-02-20 05:45] [ALPM] upgraded curl (7.63.0-4 -> 7.64.0-7)
[2019-02-20 05:45] [ALPM] upgraded gnutls (3.6.5-4 -> 3.6.6-3)
[2019-02-20 05:45] [ALPM] upgraded libassuan (2.5.2-1 -> 2.5.3-1)
[2019-02-20 05:45] [ALPM] upgraded gnupg (2.2.12-2 -> 2.2.13-1)
[2019-02-20 05:45] [ALPM] upgraded mesa (18.3.2-1 -> 18.3.3-2)
[2019-02-20 05:45] [ALPM] upgraded libxkbcommon (0.8.2-1 -> 0.8.3-1)
[2019-02-20 05:45] [ALPM] upgraded libxkbcommon-x11 (0.8.2-1 -> 0.8.3-1)
[2019-02-20 05:45] [ALPM] upgraded qt5-base (5.12.0-3.0 -> 5.12.1-2.1)
[2019-02-20 05:45] [ALPM] upgraded btrfs-progs (4.19.1-1 -> 4.20.1-2)
[2019-02-20 05:45] [ALPM] upgraded ndctl (63-1 -> 64.1-1)
[2019-02-20 05:45] [ALPM] upgraded mpfr (4.0.1-1 -> 4.0.2-1)
[2019-02-20 05:45] [ALPM] upgraded nss (3.41-1 -> 3.42.1-1)
[2019-02-20 05:45] [ALPM] upgraded solid (5.54.0-1 -> 5.55.0-1)
[2019-02-20 05:45] [ALPM] upgraded kcoreaddons (5.54.0-1 -> 5.55.0-1)
[2019-02-20 05:45] [ALPM] upgraded kwidgetsaddons (5.54.0-1 -> 5.55.0-1)
[2019-02-20 05:45] [ALPM] upgraded qt5-x11extras (5.12.0-1 -> 5.12.1-1)
[2019-02-20 05:45] [ALPM] upgraded kjobwidgets (5.54.0-1 -> 5.55.0-1)
[2019-02-20 05:45] [ALPM] upgraded kdbusaddons (5.54.0-1 -> 5.55.0-1)
[2019-02-20 05:45] [ALPM] upgraded kconfig (5.54.0-1 -> 5.55.0-1)
[2019-02-20 05:45] [ALPM] upgraded kwindowsystem (5.54.0-1 -> 5.55.0-1)
[2019-02-20 05:45] [ALPM] upgraded kcrash (5.54.0-1 -> 5.55.0-1)
[2019-02-20 05:45] [ALPM] upgraded kglobalaccel (5.54.0-1 -> 5.55.0-1)
[2019-02-20 05:45] [ALPM] upgraded kcompletion (5.54.0-1 -> 5.55.0-1)
[2019-02-20 05:45] [ALPM] upgraded qt5-declarative (5.12.0-1 -> 5.12.1-1)
[2019-02-20 05:45] [ALPM] upgraded ki18n (5.54.0-1 -> 5.55.0-1)
[2019-02-20 05:45] [ALPM] upgraded kservice (5.54.0-1 -> 5.55.0-1)
[2019-02-20 05:45] [ALPM] upgraded qt5-svg (5.12.0-1 -> 5.12.1-1)

after waiting i re-opened Pamac to check for updates and it appeared none of the updates completed since all were still listed in Pamac, however i couldn't attempt the update again due to a message that it was waiting for another instance to close - when i checked running processes, there was no pacman or Pamac process running

i went to restart from the start menu and both the restart and reboot icons were gone, so i rebooted from terminal - after boot i saw an error that the window manager had crashed several times and it prompted me to select another window manager, which i didn't have, but i was able to work to eventually fix the problem

each time i tried to use Pamac to complete the update i was presented with errors about missing files in one of the /var/lib/pacman/local/ packages ( could not open file /var/lib/pacman/local/kauth )- i found a solution which involved copying the missing 'desc' and 'files' files from another package and eventually got the system up and running again, but i have no idea whether everything is ok

i adapted commands the OP gave to reinstall 'kauth' package...

sudo pacman -Rdd kauth
sudo pacman -S kauth --overwrite '*'

just

sudo touch /var/lib/pacman/local/dnsmasq-2.80-3/desc

and hereu go ~

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by