5GHz Wifi not working at all.

Hi, i'm new to this forum, but I have been using Linux for a little while. Most of my experience has come from debian Linux, but I decided to switch to Manjaro on my Late 2011 Macbook Pro 13". Yes, I have a Macbook and run Linux, but I got mine used at a good price. Anyway, i'm having an issue where manjaro only sees 2.4 GHz Wi-Fi on my networks tab. This laptop does support 5GHz wifi, so i'm not sure why its not showing up. Part of me speculates its maybe a driver issue, but again, I don't know for sure, and I couldn't find good documentation on Broadcom drivers for older macbooks. All I have seen thus far is drivers for the newer macbooks with AC Wi-Fi.

Hi there,
this might be helpful

Im not sure what model Broadcom card is in my macbook, but I do know its a Late 2011 A1278 13" model. other then that, its running standard KDE manjaro linux, and has the latest stable build.

Run the inxi command in the link and share it .. then we will both know.

It could also be your router settings try resetting your router to the factory default. You should also test lowering the chanel and bandwidth to 40 or below.

1 Like

Its not my router, as it cant see my neighbors 5ghz wifi, and also my phone's hotspot (which is also 5ghz). plus this has worked before with PopOS

Here is what came up with the inxi comandScreenshot from 2020-05-10 14-16-13

inxi comman noted in the post 'how to provide good information' .. it isnt just 'inxi'.

I'll get back to you in a week or so when I have a little more time (with some more suggestions which you can again ignore).


Please don't post pics of terminal outputs on technical support threads. I don't currently have a computer or internet service and pics are not easily readable on a cell phone. Please conform to accepted forum practices and post terminal outputs correctly. You can use USB Android phone tethering for a temporary connection to post outputs in the proper manner.

Please re-read the linked thread on how to post information correctly to receive assistence.

A more useful output to post would be:

inxi -Fxxxz

My apologies for ignoring this for so long, i've just been too busy between my construction work, windows server issues (i know i should use Linux, give me a break) and other stuff, that i just dealt with 2G WiFi for now.

I apologize for ignoring posts, it was not my intention.

I look forward to keeping up with this more frequently now that i'm getting some free time to address this.

as for the inxi command, i did it properly and here is the result:

[joshua@joshua-macbookpro81 ~]$ inxi -n
Network:   Device-1: Broadcom and subsidiaries NetXtreme BCM57765 Gigabit Ethernet PCIe driver: tg3 
           IF: enp2s0f0 state: down mac: 3c:07:54:68:75:4b 
           Device-2: Broadcom and subsidiaries BCM4331 802.11a/b/g/n driver: bcma-pci-bridge 
           IF-ID-1: wlp3s0b1 state: up mac: 68:a8:6d:18:7d:36 

as for your router suggestion, i didn't ignore it, i just didn't bother to explain that i have a complicated network setup with a PfSense router and 5 Ubiquiti AP's each broadcasting the same SSID on separate bands, some not on DFS so its definitely not a compatibility issue. i have rebooted each AP in the past as a sanity check, and tried changing bands to see if its just my computer only scanning certain bands (have seen this issue before). all my other devices, new and old, pick up the 5G WiFi just fine.

i keep checking daily and nobody has responded for the past 12 days.


well it took you 25 days to respond with (the wrong) inxi .. it follows you should accept at least another 2 weeks before complaining about volunteers not bending over backwards for you.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by