60 second poweroff and reboot delay


when I reboot or poweroff my system it hangs for about a minute before finally shutting down.
Dring that time, I see a black screen and I can type characters. It's not a shell though, it just displays the things I type. For keys like DEL it outputs some control sequences like ^[[4~.
I can switch to another virtual Terminal with ctr+alt+f2, but this only displays _ in the upper left corner, I can't login or anything.

This is how it looks like:

To provide only the relevant journal output, I executed the following:

echo 'PREBOOTFLAG' | systemd-cat && reboot

You can see the journal from that point on here: https://pastebin.com/u6yU0Z8s
The journal is only two more seconds long, but in reality the system took about another minute to finally shutdown / reboot.

I tried acpi=force reboot=acpi as kernel options, but that didn't change anything.

What could be the problem? Can I provide more info that may help with the analysis?

Any hints are greatly appreciated!

I'm running this Manjaro version:

$ cat /etc/lsb-release  

Thank you!

Maybe ;)

How to provide good information in your posts

Please post output from terminal

$ inxi -Fxxxza --no-host

Is your /home/ope/Data an external HDD ?
Do you have udev.log_priority=3 audit=0 entries in GRUB_CMDLINE_LINUX_DEFAULT line in ect/default/grub ?


Thank you both for your efforts! :slight_smile:

Sorry, I missed that :grimacing: - this is the output of $ inxi -Fxxxza --no-host

/home/ope/Data is an internal HDD (sdd) which is mounted from this fstab line:

UUID=41C463FE74F77D5C  /home/ope/Data ntfs-3g defaults,auto,nouser,uid=ope,rw,umask=077 0 0

These are the inxi lines for that drive:

ID-4: /dev/sdd vendor: Seagate model: ST1000DM003-9YN162 size: 931.51 GiB block size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> rev: CC4B scheme: MBR

W.r.t the kernel parameters - these are the first three loglines of my current boot:

-- Logs begin at Sat 2019-09-14 15:49:38 CEST, end at Tue 2019-10-01 22:31:22 CEST. --
Sep 29 23:42:01 deskman kernel: Linux version 5.2.11-1-MANJARO (builduser@lancaster) (gcc version 9.1.0 (GCC)) #1 SMP PREEMPT Thu Aug 29 07:41:24 UTC 2019
Sep 29 23:42:01 deskman kernel: Command line: BOOT_IMAGE=/boot/vmlinuz-5.2-x86_64 root=UUID=d5d8118d-f48e-41e4-b46a-92c8d13b778d rw quiet acpi=off apparmor=1 security=apparmor udev.log_priority=3

..so it seems that udev.log_priority=3 is indeed set but audit=0 is not

sudo nano /etc/default/grub

and add audit=0

Use </>

System:    Kernel: 5.2.11-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.1.0
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.2-x86_64 root=UUID=d5d8118d-f48e-41e4-b46a-92c8d13b778d rw quiet apparmor=1
           security=apparmor udev.log_priority=3
           Desktop: KDE Plasma 5.16.4 tk: Qt 5.13.0 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux
Machine:   Type: Desktop System: Gigabyte product: Z390 AORUS PRO WIFI v: N/A serial: <filter>
           Mobo: Gigabyte model: Z390 AORUS PRO WIFI-CF v: x.x serial: <filter> UEFI: American Megatrends v: F10
           date: 06/05/2019
CPU:       Topology: 6-Core model: Intel Core i5-9600K bits: 64 type: MCP arch: Kaby Lake family: 6 model-id: 9E (158)
           stepping: C (12) microcode: AE L2 cache: 9216 KiB
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 44364
           Speed: 800 MHz min/max: 800/4600 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 801 5: 800 6: 800
           Vulnerabilities: Type: l1tf status: Not affected
           Type: mds mitigation: Clear CPU buffers; SMT disabled
           Type: meltdown status: Not affected
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: disabled, RSB filling
Graphics:  Device-1: NVIDIA GM204 [GeForce GTX 970] vendor: eVga.com. driver: nvidia v: 418.88 bus ID: 01:00.0
           chip ID: 10de:13c2
           Display: x11 server: X.Org 1.20.5 driver: nvidia compositor: kwin_x11 resolution: 2560x1440~60Hz
           OpenGL: renderer: GeForce GTX 970/PCIe/SSE2 v: 4.6.0 NVIDIA 418.88 direct render: Yes
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Gigabyte driver: snd_hda_intel v: kernel bus ID: 00:1f.3
           chip ID: 8086:a348
           Device-2: NVIDIA GM204 High Definition Audio vendor: eVga.com. driver: snd_hda_intel v: kernel bus ID: 01:00.1
           chip ID: 10de:0fbb
           Device-3: SteelSeries ApS type: USB driver: hid-generic,snd-usb-audio,usbhid bus ID: 1-5:3 chip ID: 1038:12ad
           Device-4: Logitech H600 [Wireless Headset] type: USB driver: hid-generic,snd-usb-audio,usbhid bus ID: 1-11.4:8
           chip ID: 046d:0a29 serial: <filter>
           Sound Server: ALSA v: k5.2.11-1-MANJARO
Network:   Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi v: kernel bus ID: 00:14.3 chip ID: 8086:a370
           IF: wlo1 state: down mac: <filter>
           Device-2: Intel Ethernet I219-V vendor: Gigabyte driver: e1000e v: 3.2.6-k port: efa0 bus ID: 00:1f.6
           chip ID: 8086:15bc
           IF: eno2 state: up speed: 1000 Mbps duplex: full mac: <filter>
           IF-ID-1: docker0 state: down mac: <filter>
Drives:    Local Storage: total: 1.71 TiB used: 466.42 GiB (26.7%)
           ID-1: /dev/sda vendor: Samsung model: SSD 860 EVO 500GB size: 465.76 GiB block size: physical: 512 B logical: 512 B
           speed: 6.0 Gb/s serial: <filter> rev: 3B6Q scheme: GPT
           ID-2: /dev/sdb vendor: OCZ model: VERTEX2 size: 111.79 GiB block size: physical: 512 B logical: 512 B
           speed: 3.0 Gb/s serial: <filter> rev: 1.35 scheme: MBR
           ID-3: /dev/sdc vendor: Transcend model: TS256GSSD370 size: 238.47 GiB block size: physical: 512 B logical: 512 B
           speed: 6.0 Gb/s serial: <filter> rev: 4B scheme: GPT
           ID-4: /dev/sdd vendor: Seagate model: ST1000DM003-9YN162 size: 931.51 GiB block size: physical: 4096 B
           logical: 512 B speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> rev: CC4B scheme: MBR
Partition: ID-1: / raw size: 64.64 GiB size: 63.13 GiB (97.65%) used: 24.07 GiB (38.1%) fs: ext4 dev: /dev/sda6
Sensors:   System Temperatures: cpu: 42.0 C mobo: N/A gpu: nvidia temp: 63 C
           Fan Speeds (RPM): N/A gpu: nvidia fan: 7%
Info:      Processes: 240 Uptime: 2m Memory: 31.35 GiB used: 1.44 GiB (4.6%) Init: systemd v: 242 Compilers: gcc: 9.1.0
           Shell: zsh v: 5.7.1 running in: konsole inxi: 3.0.36
1 Like

Any particular reason for that?
Personally i'll go with:
UUID=41C463FE74F77D5C /home/ope/Data ntfs-3g uid=userid,gid=groupid 0 0
With that you grant to yourself all the possible permissions and you are the owner (since you are the only one using that machine i suppose)
Also take a look at the scheduler

because you have SSD + Rotational HDD
Also, you can safely remove the tlp package since you are on a Desktop PC.


wow, thanks again, I'm still processing.

I updated the kernel param, so now it boots with

$ cat /proc/cmdline
BOOT_IMAGE=/boot/vmlinuz-5.2-x86_64 root=UUID=d5d8118d-f48e-41e4-b46a-92c8d13b778d rw quiet apparmor=1 security=apparmor udev.log_priority=3 audit=0

But unfortunately, I'm not sure what you mean with the second part "Use </> " - can you please ellaborate?

no, no particular reason :man_facepalming: I'll update the fstab.
Do you think the scheduler may be related to the issue, or is this simply an optimization I should do for my SSD ?

Use the </> button above the post entry box when pasting terminal output so it's formatted properly.
You can edit your post (pencil) :slight_smile:

mhhh, so you do not need pastbin anymore :slight_smile:

1 Like

okay, cool, I'll use that exclusively then :slight_smile: I thought it may be preferred to post long output externally, but I agree that it's easier to have everything in one place.

1 Like

Has the bug been fixed?

(Sometimes, if kernel update or ..???. I have also long shutdown, sometimes about timeshift, btrfs cleaning or something else. But next shutdown was quick.)

Then please mark the mail that led to the solution.

I can't keep up with the translations :wink:
But it should be @bogdancovaciu :slight_smile:

not yet, unfortunately. I will try the scheduler thing suggested by @bogdancovaciu next and see if this helps. I read it as a general suggestion, though, no necessarily a fix.

1 Like

yay, this solved the problem for me! Thanks a lot, @bogdancovaciu !

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by