A start job is running for dhcpcd on enp2s0f0

Every time I start up my computer I get this message before it loads into my log in screen. Is it a problem or is it okay and I just have to live with it?
[A start job is running for dhcpcd on enp2s0f0.]

From terminal:
systemctl list-unit-files | grep enabled
if you see in that list this or similar:

dhcpcd@.service                             enabled  
NetworkManager.service                      enabled 
# or is like this
dhcpcd.service                             enabled  
NetworkManager.service                      enabled 

You have to stop one. Personally i would say to stop and disable the dhcpcd@ / dhcpcd
sudo systemctl disable dhcpcd --now
and let NetworkManager.service to take care of the connections.

1 Like

If it's not already running then:

sudo systemctl enable NetworkManager-wait-online.service	

Okay, I disabled it and it just removed it. Is okay that it's removed? Will I need it ever?

Reboot and check the connection if is working. I use that only in special cases when i don't have network from TTY ...

So after rebooting the message still came up. What should I do now?

Please share all the output of:
systemctl list-unit-files | grep enabled

/ >>> systemctl list-unit-files | grep enabled                   
org.cups.cupsd.path                        enabled        
autovt@.service                            enabled        
avahi-daemon.service                       enabled        
bluetooth.service                          enabled        
dbus-org.bluez.service                     enabled        
dbus-org.freedesktop.Avahi.service         enabled        
dbus-org.freedesktop.nm-dispatcher.service enabled        
dbus-org.freedesktop.timesync1.service     enabled        
display-manager.service                    enabled        
getty@.service                             enabled        
httpd.service                              enabled        
lightdm.service                            enabled        
mariadb.service                            enabled        
mysqld.service                             enabled        
NetworkManager-dispatcher.service          enabled        
NetworkManager-wait-online.service         enabled        
NetworkManager.service                     enabled        
org.cups.cupsd.service                     enabled        
preload.service                            enabled        
systemd-remount-fs.service                 enabled-runtime
systemd-timesyncd.service                  enabled        
tlp-sleep.service                          enabled        
tlp.service                                enabled        
avahi-daemon.socket                        enabled        
org.cups.cupsd.socket                      enabled        
remote-fs.target                           enabled        
pamac-cleancache.timer                     enabled        
pamac-mirrorlist.timer                     enabled    

On my end all i have related to network:

NetworkManager-dispatcher.service           enabled        
NetworkManager.service                      enabled

But the dispatcher becomes unloaded once the network is up.
I never used the wait-online service.
Did you created your connection trough the UI or from some commands and you have been guided to use the dhcpcd.service at that point ?

I don't believe so, unless it was something I did when I was first setting up manjaro

Looking trough this
https://bbs.archlinux.org/viewtopic.php?id=213363
and this one
https://bbs.archlinux.org/viewtopic.php?id=226160
seems to mention what i proposed, but i'll have to read other references they point too.

might be a clue in reference to enp2s0f0 ...

I'm sorry, what is it that you proposed?

systemctl status dhcpcd.service                                                                                              [3]
● dhcpcd.service - dhcpcd on all interfaces
   Loaded: loaded (/usr/lib/systemd/system/dhcpcd.service; disabled; vendor preset: disabled)
   Active: inactive (dead)

Apr 29 00:02:41 manjaro dhcpcd[18919]: sending signal TERM to pid 12407
Apr 29 00:02:41 manjaro dhcpcd[18919]: waiting for pid 12407 to exit
Apr 29 00:02:41 manjaro dhcpcd[18919]: sending signal TERM to pid 12407
Apr 29 00:02:41 manjaro dhcpcd[18919]: waiting for pid 12407 to exit
Apr 29 00:02:41 manjaro dhcpcd[12407]: received SIGTERM, stopping
Apr 29 00:02:41 manjaro dhcpcd[12407]: enp3s0: removing interface
Apr 29 00:02:41 manjaro dhcpcd[12407]: wlp1s0: removing interface
Apr 29 00:02:41 manjaro dhcpcd[12407]: dhcpcd exited
Apr 29 00:02:41 manjaro systemd[1]: dhcpcd.service: Succeeded.
Apr 29 00:02:41 manjaro systemd[1]: Stopped dhcpcd on all interfaces.

To disable the dhcpcd service

Oh yeah, so I did do that and I did the reboot right after like you said and I still ran into the problem

Because somewhere you have the enp2s0f0 connection, while the status shows

Meaning you have a static profile or something, maybe a fallback profile and it removes those connections to use its profile. At least that is what i understand.
https://wiki.archlinux.org/index.php/Dhcpcd

It might have been best if you mentioned your related posts:

If you are not using your LAN connection then perhaps delete its profile from within Network Managers connections.

Disabling the NIC in your bios might be another idea if your bios has this feature.

It is also possible prevent your NIC from loading by blacklisting its module in /etc/modules-load.d/modules.conf

2 Likes

I deleted the LAN profile that I wasn't using. I rebooted and nothing worked. I then went into BIOS and tried too find NIC, but it doesn't look like I have that option either

So how do I go about looking for other profiles and removing those?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by