A start job is running for LiveMedia MHWD Script

did you verify the downloads? Could just be a bad run of luck on downloads.

Each of the Manjaro iso's I tried to install has been verified as to their corresponding md5sum numbers. A bad run of incomplete downloads I'll give you that, maybe? But when it has gone past half a dozen tries with no luck. I'd call that one Hela of a bad run.

I guess there is no way to disable the 'MHWD" and enable it once the newer Manjaro has been installed.?

I assume you have an AMD graphics card. Either try an older release, or force the ISO to boot up with xdriver=vesa as the current release enables the AMDGPU driver some cards have issues with.

The HP Pavillion has an "AMD Radeon HD 8240 Graphics." How can I compel and or force the ISO to boot up with 'xdriver=vesa'?

add xdriver=mesa at boot in boot options

Anyway. I have the same problem and this doesn't solve it. After adding xdriver=vesa or xdriver=radeon I get past this issue but then my screen just goes black. Going to console there is not much happening, just bunch of systemd-journal messages. Setting kernel in debug level I get system reboot at this stage.

This reminded me that I should not be lazy. After 10 years of using only arch I was going to install arch on my other computer, but I was lazy and thought: "hey why not try manjaro instead".

People, don't be lazy, or you will end up getting ubuntu experience instead. I almost forgot how this was a normal thing with all these fancy distributions "back in the day".

Kudos to all your work and good luck anyway.

It's a little annoying to install a modern linux distro with such problems. but just dor the records, anybody who has this issue during booting Manjaro live, I found a workaround.

it seems you have Nvidia and intel graphics on your system. if so, do as follows:

1.from boot menu press "E" on the keyboard on the first boot item in the list.
2. add this to the end of the line: xdriver=mesa
3. press Enter to boot to the Manjaro environment
4. install the manjaro (do not get mad if your laptop fan starts working hard)
5. reboot after installation complete.
6. if you were able to boot into installed manjaro, ok then, everything is working. but if you were not, follow steps forward:
7. in the grub menu, press "E" on the Manjaro boot line. navigate to the kernel line (starting with Linux...)
8. remove these two options: quiet splash, and add a simple 3 to the line. just 3
9. press F10 and boot
10. now you are in the console, login with root user
11. you must remove nouveau drivers, and install nvidia driver. if you don't gaming, you could just install intel drivers*
12. run this command to uninstall nouveau: mhwd -r pci video-hybrid-intel-nouveau-bumblebee
13. now you need internet, the most simple is you tether internet connection from your smartphone with usb cable
14. after synchronizing pacman, now install the desired driver:
15. mhwd -i pci video-hybrid-intel-nvidia-bumblebee or mhwd -i pci video-intel

  • you can find the true drivers by this command: mhwd -i -d

Adding xdriver=mesa or vesa didn't solve the issue. I have GTX 960m and can't install Arch, Fedora, Ubuntu or anything! Most of the issues are related to the graphics. But let's focus on Manjaro for now.

I tried removing nouveau.modeset and radeon.modeset with no luck.
nomodset made the manjaro to come up okay but 4k is not supported in this state. Changing the resolution made stuff a little bigger but there is no scaling. Also fan went crazy!

My laptop also has a GTX 960M with Optimus, same situation as yours, but I noticed that with nouveau.modeset=0 it got through the script, only to hang at "Waiting for Plymouth boot screen" or similar. Tried the 16.10.3 and 16.08 KDE install images, same result on both. Those two boot up on another laptop with a 740M GPU, also with Optimus, so it's not completely broken. The laptop with the 960M is a MSI GP62 6QF, with an i7-6700HQ CPU, while the one with the 740M is an ASUS A46CB-WX024D with an i5-3317U CPU.

Update: I've just tried Antergos Linux on the problematic laptop, it too refused to boot without any changes to the kernel command line, but it did successfully use the Intel GPU and get to the GUI by using nouveau.modeset=0. It too got held up at a start job for dri card0 something with nouveau.modeset=0 if I remember correctly, however it had a timeout of 1m 30s, while the LiveMedia MHWD script had none, so Antergos just went through, albeit with the discrete GPU turned on the whole time. It wasn't perfect though, bumblebee and/or bbswitch seems to have a bit of trouble initializing the particular setup of the laptop, so for the kernel command line it needed acpi_osi=! acpi_osi="Windows 2009" added (from here: https://github.com/Bumblebee-Project/Bumblebee/issues/764#issuecomment-234494238 ), but then it worked just fine. Adding those options to the kernel command line also worked on live mode for both Manjaro and Antergos.

I don't think nouveau supports an nvidia gpu as recent as the GTX 960M.

I think you have to install the proprietary nvidia bumblebee hybrid driver to enable Optimus.

sudo mhwd -r pci video-hybrid-intel-nouveau-bumblebee
sudo mhwd -i pci video-hybrid-intel-nvidia-bumblebee

I have an MSI GE72 2QE and bumblebee would not work with nouveau (unsupported chipset error), but works fine with nvidia proprietary hybrid.

$ inxi -G
Graphics:  Card-1: Intel 4th Gen Core Processor Integrated Graphics Controller
           Card-2: NVIDIA GM204M [GeForce GTX 965M]
           Display Server: X.Org 1.19.1 driver: intel Resolution: 1920x1080@60.01hz
           GLX Renderer: Mesa DRI Intel Haswell Mobile GLX Version: 3.0 Mesa 13.0.3

The nouveau page states that only Pascal series support is problematic, so it should at least be able to use the Intel GPU to get to the desktop, which it didn't on mine without adding the acpi_osi parts. Anyway, the issue with my laptop seems to be due to its combination of a Skylake CPU, Maxwell GPU and an AMI firmware, so yours shouldn't be affected. By the way, the Arch wiki mentions that Bumblebee with nouveau is no longer supported.

Did you try bumblebee with the nvidia hybrid driver?

Having same issues installing XFCE Edition (17.0) from disc on a 10 year old Pavdv9000 w/ old Geforce Go 7000. I had originally installed with an older 32 bit ver and non-free drivers w/ no hitch, (trial run) and decided to load the newer 17.0 x64 base. Yes this is a really old centrino duo lappy but since it has a discrete .5gig Gpu memory its still worth using imo.

Rerunning install w/ free base drivers, and working so far, guess I'll have the job of finding/installing proper old nvidia drivers at some point.

Unfortunately the script just drops out at the point of actually installing files, so the new 17ver is a no go.

Had the same issue on a desktop PC (ASUS P8Z68-V/Gen3, i5 2500K and GTX 1070) installing KDE edition (17.0) on UEFI and GPT. Had to use E button at the bootloader and set all .modeset settings to 0 (noveau, i915 and radeon). After that I could normally boot into live DVD and install Manjaro.

The solution to get it to boot is to change the arg that says driver=free to driver=intel. From there all the rest the guides are solid.

Same issue with XFCE 17.0.1 on Zenbook Pro ux501vw ( i7-6700HQ w Intel HD 530 + Nvidia GTX 960M). Toggling driver=free/nonfree/intel or messing with modeset or with xdriver=mesa/vesa only didn't work. A combination of steps that helped:

  1. Added cmdline args: acpi_osi=! acpi_osi="Windows 2009" xdriver=vesa

I believe the acpi command line option prevented the LiveMedai MHWD script from hanging, and the xdriver=vesa caused xserver to fail initializing (in other cases xserver would just hang).

  1. At that point I could log into a terminal, attached a network dongle and installed video-hybrid-intel-nouveau-bumblebee:

sudo mhwd -a pci free 0300

  1. Restarted xserver:

systemctl restart graphical.target

This allowed me to start the graphical installer. However, at 78% "Running mhwdcfg option" the installer hangs (even the mouse pointer freezes). I've retried the whole process using video-hybrid-intel-nvidia-bumblebee before giving up.

Analogically to [1], commenting out mhwd commands related to video configuration helped to complete the installation.

[1] Calamares install fails

Have been trying to install Manjero Xfce 17.0.1 Stable but the installation always stops after this line appears several times:

A start job is running for LiveMedia MHWD Script….

I’ve installed many different Linux OSs (am fairly familiar with Linux but a long way from expert – Arch is way beyond me), have a reasonable idea of what I’m doing, and followed the instructions at UEFI - Install Guide. Outside this Guide, I’m reluctant to try any of the possible solutions posted here and elsewhere as they might not be relevant to my particular situation and I don’t want to mess up my current OS (Xubuntu 17.04) if Manjaro isn’t going to install.

Xubuntu has been functioning well for about a year but suddenly stopped recognizing one of my sound cards. I've been unable to fix the problem and am hoping that installing another distro might do it. Am interested in trying Manjaro as a replacement for Xubuntu (i.e. not a dual boot).

It appears that graphics drivers are connected with the installation problem. Here's some information that might be useful in helping to solve the inability to install.

$ inxi -G
Graphics:  Card-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller
           Card-2: NVIDIA GF119 [GeForce GT 610]
           Display Server: X.Org 1.19.3 drivers: modesetting,nvidia (unloaded: fbdev,vesa,nouveau)
           Resolution: 1920x1080@60.00hz
           GLX Renderer: GeForce GT 610/PCIe/SSE2
           GLX Version: 4.5.0 NVIDIA 375.39

Settings > Hardware > Additional Drivers > NVIDIA Corporation: GF119 [GeForce GT 610]
	This device is using the recommended driver.
	· Using NVIDIA binary driver - version 375.39 from nvidia-375 (proprietary, tested)

Would greatly appreciate some assistance.

You can probably avoid this issue with the solution I detailed here with my own investigations.

Basically disable the MHWD script from running with this boot parameter systemd.mask=mhwd-live.service, this is done the same way you'd change driver params or type nomodeset as described above in this thread.

X will handle it's driver detection/configuration instead of Manjaro, which in my experience it has done a better job of. Hopefully that gets a bootable Manjaro OS for you :slight_smile:

I can confirm. But I had to remove a bit more.

So, in short,

  1. Install majaro live usb
  2. In grub activate propietary drivers
  3. Edit the kernel parameters in grub and add the systemd.mask=mhwd-live.service and boot.
  4. Once in the live image, before installig you have to edit with sudo the following file: sudo nano /usr/lib/calamares/modules/mhwdcfg/main.py

def run(self):
for b in self.bus:
for id in self.identifier['net']:
self.configure(b, id)
for id in self.identifier['video']:
self.configure(b, id)
return None

def run(self):
return None

5.Proceed with the installation and it will be sucesful, although I still have to configure the drivers on the new intallation from which I am posting this right now.

I am running calamares(the Manjaro installer) from the terminal with sudo calamares. And the error that calamares was giving on the terminal was, that message got me to the link @wictor is posting:
Running "chroot" ("/tmp/calamares-root-ewculjtx", "mhwd" ,"-a", "pci" , "03xx", "--pmconfig" , "/opt/pacman/conf")

O well, idk how to .md format.
Anyways good luck everybody, remember, this nonsense can be fixed by not buying nvidia next time.

1 Like

OK, simple fix, I'm running Manjaro 18 KDE.

In boot menu,
1.highlight the driver menu (don't enter, just highlight)
2.Press e
3.it will say somewhere "driver=free" alter this to say "driver=mesa"
4.press f10
5.boot manjaro

I just did this and it worked for me

Forum kindly sponsored by