About Removing GRUB bootloader on Dual Boot

What is the correct or best way to remove a Linux Distro's GRUB Menu, that is dual booting with Windows 10?

My story was that I installed Linux Mint last year, my first ever Linux Distro, but I didn't like it because it was so unstable on my laptop. So I tried removing it by following some YouTube tutorials about formatting the correct partitions and rebuilding the MBR using some applications (AOMEI Partition Assistant Standard Edition, EasyBCD, etc.) and I was able to wipe Linux Mint from my laptop, except its GRUB bootloader. I think rebuilding the MBR through those applications didn't work so I just booted into my BIOS and set Windows 10 as the first boot option and never bothered with the Linux Mint GRUB bootloader ever since.
After a while, I decided to install Deepin OS on my laptop and I have been using it for a month. Then today, I tried to remove the Linux Mint GRUB bootloader that was left untouched, because it's a nuisance to see it on the Boot Menu of my BIOS since it has no more use.

I followed this video tutorial (1:45). https://youtu.be/ZTMCKOx5Jz0
From the efi directory, I successfully deleted "ubuntu", which should be the Linux Mint GRUB bootloader. I didn't format any Deepin OS partition because I only wanted to remove the Linux Mint GRUB.

Then I tried booting into Deepin OS but it was not the Deepin OS GRUB Menu that showed up, it was the ubuntu GRUB Menu that I just deleted, that showed up and I can't boot into Deepin OS. I made sure on my BIOS Boot Menu that Deepin OS was set as the first boot option, yet the unexpected happened.

I planned on switching to Manjaro+KDE anyway, so I'll be formatting Deepin OS and its GRUB bootloader, after somebody points me on the right direction to the correct or best way to remove them. Thanks.

Also, can I theme the GRUB Menu in Manjaro+KDE?

From within an installation, check your menu entries

efibootmgr -v


efibootmgr --help

on how to delete an entry.
Deleting a folder in the EFI partition does not remove the previous entries from BIOS.

1 Like

OP is using EasyBCD to boot up grub menu.
Not using grub to boot up.
Not looking at your you-tube link (please... one or two sentences from you on how you do it would be less torturous for us trying to help) but besides removing ubuntu directory (did he?) from $esp partition, he should remove firmware entry with 'efibootmgr -b xxxx -B'.

And he (gender neutral) needs to get deepin's path correct in easybcd, he's still pointing to ubuntu's path.
If he still wants to use easybcd, perhaps @calvous or @dorma can help better.

And if he wants to use grub (better, of course) instead, he should say so, explicitly.

1 Like

Actually I'm not using EasyBCD anymore neither am I using it to boot into GRUB menu. I just used it last year to rebuild the MBR, I guess that would mean restoring the default Master Boot Record, so that I could completely remove Linux Mint and its GRUB menu. But Linux Mint's ubuntu GRUB Menu was still there until now.

So instead I did a different method. I just used Command Prompt (Admin) in Windows 10, typed "diskpart", searched and mounted the partition for System by reassigning it to letter "x", went to the directory of "efi" and deleted the "ubuntu" inside it.

I am trying to boot into Deepin OS using GRUB but it is using the "ubuntu" GRUB Menu for Linux Mint that I have already deleted, instead of Deepin's own GRUB Menu. So it confused me as to why that happened. Maybe there was a directory or path complication and they somehow swapped places? When I look at my Boot Menu on my BIOS, I see that the name is "deepin" and not ubuntu.

efibootmgr, this is a linux command yes? Is there a Windows 10 way for this since I'd like to remove the possible entries that could complicate my GRUB problem before I install any Linux distro. As of the moment, I couldn't boot into my Deepin OS and I plan to format it later and replace it with Manjaro KDE.

This could be the solution for my problem.

Use this.
Read completely first post and do the 2 [Additional UEFI commands].
When done (it boots to manjaro), come back here and we'll wipe out the Deepin entry and directories. Provide following (when done) so we can write the commands for you.

ls /boot/efi
ls /boot/efi/EFI/
1 Like

My old machine has no UEFI, so know little about that.
In plain BIOS way, after format the linux partition and writing MBR, you have nothing left, just boot into windows.

For install new linux with UEFI, search forum for installation threads maybe help.

1 Like

I see that those methods are specifically focused to fix Manjaro's GRUB? But I have not yet installed Manjaro in my laptop so the paths on those commands probably doesn't exist yet on my system.

So what I would do instead is to format Deepin OS partitions and remove "deepin" from efi using Windows 10 Command Prompt, then install Manjaro KDE.

After that I could provide you the results of the following commands inside Manjaro KDE

ls /boot/efi
ls /boot/efi/EFI/

Is that still ok?

I was following a guide before by only formatting the Linux partitions and rebuilding the MBR, but the GRUB was still there when I restarted.

So maybe that method about rebuilding MBR only works with computers running BIOS mode?

As stated:

Use the win10 diskmanager to delete the linux partition so it is shown as free space. Then start an admin powershell and check for the windos bootmanager in place:

$ bcdedit

one of the first line must show "\EFI\Microsoft\Boot\bootmgfw.efi"
Reboot and check in BIOS if the ubuntu bootmanager is gone. If not, you must boot the ubuntu live stick. Open terminal and type


This shows you a simple boot order with names. If ubuntu shows up there, you must delete it with its bootnumber (without the boot upfront) like:

sudo efibootmgr -b 000n -B

where 'n' is the digit shown before ubuntu.
Shutdown and boot into BIOS again to check.

Not really to Manjaro and not to fix, but to show the status of the bootloader part in your system.
You can use these commands from a Live ISO, a Manjaro installer (you plan to install anyways) can do.
After posting the results, we may give you advice to restore your restorable boot options (if any).

this for example.

1 Like

I just want to delete the unneeded one which is "ubuntu".

I couldn't install Manjaro KDE as of now, but I will try to do your suggestions from this post later.

Here is the result:

~$ efibootmgr
BootCurrent: 0002
Timeout: 1 seconds
BootOrder: 0002,0000
Boot0000* Windows Boot Manager
Boot0002* deepin
~$ ls /boot/efi
~$ ls /boot/efi/EFI
Boot  deepin  Microsoft  ubuntu

Boot0001* is missing or hidden. I want to make "deepin" as Boot0001* and also delete "ubuntu".

sudo rm -Rf /boot/efi/EFI/ubuntu

See the earlier link mentioned somewhere and do the 2 [UEFI additional commands]
It may not be 0001 though.

ps: waiting for petsam to reply. He's taking a long time. So I'll beat him to it first. :stuck_out_tongue_winking_eye:

Not exactly.. xyproblem
If Deepin is working, then you need to make it default

sudo rm -r /boot/efi/EFI/ubuntu
ls /boot/efi/EFI/deepin/*.efi

Boot to WinOS and run terminal as Admin

bcdedit /set {bootmgr} path \EFI\deepin\<from-previous-output>.efi

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by