About the Printing category

Having issues with printing? Use this category.

1 Like

image

Why have I been tagged in this post - never been anywhere near it :smiley:

problem-installing-thermal-printer

I have a usb HOIN HOP-H58 thermal printer that I have not succeeded in installing. The sysinfo:

Kernel: 4.14.74-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 -- Desktop: KDE Plasma 5.13.5 Distro: Manjaro Linux

..and a POS system that I wish to use the printer with. The system recognises the printer as "Local>>unknown"

I have tried installing generic drivers and even the ppd from printer's manufacturer website: http://hoinprinter.com/en/download and nothing works

The setup58.sh installation file provided under the manufacturer's Linux Driver installs with the following output:

$ sudo ./setup58.sh 
[sudo] password for adsfs: 
POS Electronics Co..Ltd 
---------------------------------------

Models included:
                 POS-80-Series
                 POS-58-Series


gzip: stdin: unexpected end of file
tar: Child returned status 1
tar: Error is not recoverable: exiting now
Searching for ServerRoot, ServerBin, and DataDir tags in /etc/cups/cupsd.conf

ServerBin tag not present in cupsd.conf - using default

DataDir tag not present in cupsd.conf - using default

ServerRoot = 
ServerBin  = 
DataDir    = 

Copying rastertopos58 filter to /usr/lib/cups/filter
chmod: cannot access './bin/rastertopos58': No such file or directory
cp: cannot stat './bin/rastertopos58': No such file or directory

Copying model ppd files to /usr/share/cups/model/pos
cp: cannot stat 'ppd/*.ppd': No such file or directory

Add the POS-58-Series printer
lpadmin: Unable to open PPD "/usr/share/cups/model/pos/pos58.ppd": Unable to open PPD file on line 0.
lpadmin: Unable to open PPD file "/usr/share/cups/model/pos/pos58.ppd" - No such file or directory

Restarting CUPS
Could not restart CUPS

Install Complete
Go to http://localhost:631, or http://127.0.0.1:631 to manage your printer please!


Nothing works even after trying to configure from localhost:631

https://github.com/IntegersOfK/Hoin-POS-58-80 seems to have a probable solution but this could be outdated and never worked for my printer

  • The printer ill never print even a testpage and this is shown under 'status' in the printing preferences for the printer (POS-58-Series): File "/usr/lib/cups/filter/rasteropos58" not available: No such file or Directory. This problem persists even after copying rasteropos58 Directory to this path

I also tried this driver without success: https: //github. com/mike42/escpos-php. Or I missed some steps

Pls assist

Forum kindly sponsored by