Acer Nitro 5 won't boot into Manjaro

So,

I've spent a couple of days searching around, but have run into a lot of dead-ends and wondering if someone might point me in the right direction. I've successfully used Manjaro for a couple of years now on an Lenovo Thinkpad, and loved the experience overall. But, the time came to retire that laptop, it was old, long in the tooth, and slow.

Got a new laptop (Acer Nitro 5 with AMD 4600h CPU and Nvidia GeForce GTX graphics), Kubuntu will boot, but only in the safegraphics (nomodeset) option, however I've tried a number of ways to get the Manjaro boot USB I made to boot without any luck. I know the USB is good because I can boot the thinkpad with it just fine. While I dabble in Linux, I'm definitely not a power user.

Did you set nonfree option when you boot the usb?

image

Yes, tried that, also tried adding nomodeset to the boot parameters, and was trying some of the tips from the AMD Ryzen: Problems and Fixes post... I've not yet delved into trying Manjaro Architect, because that'll probably need the weekend :slight_smile:

So oddly, I tried again and now it's working, at least far enough that it seems to be installing so... We'll see

I'm thinking about getting the same laptop.

Were you able to complete the install? Were there any additional issues?

Thanks.

Check my recent posts about a different Acer Nitro 5 and ... think again.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by