acpi reports high temperature (60-70C) on idle (Ryzen 7 4800H)

Hello,

I'm a bit concerned about this. I think that the temperature reported by acpi -t is way to high for the load, which is just some browser tabs, nothing else. I'm with Manjaro 20.0.2 and 5.6.15 kernel.

I'm regularly checking acpi -t and it usually outputs values between 60-70, sometimes higher. There are also outliers of 50-55, but I've never seen it below that. The temperature at home shouldn't be greater than 22. I don't really think 60C is reasonable under for such a load load and a fresh room temperature. I've also noticed that the temperature may vary in +/- 10C just within a second, so I'm not even sure about how reliable these numbers are. But still too high always.

I've tried to install sensors-lm but it just doesn't detect the sensors. In any case, this is the output of sensors:

amdgpu-pci-0500
Adapter: PCI adapter
vddgfx:           N/A
vddnb:            N/A
edge:         +45.0°C  (crit =  +0.0°C, hyst =  +0.0°C)

acpitz-acpi-0
Adapter: ACPI interface
temp1:        +63.0°C  (crit = +115.0°C)

BAT1-acpi-0
Adapter: ACPI interface
in0:           4.00 V
curr1:         0.00 A

nvme-pci-0400
Adapter: PCI adapter
Composite:    +35.9°C  (low  = -20.1°C, high = +84.8°C)
                       (crit = +89.8°C)

And inxi -Fxxxcz:

System:    Host: TUF-506IU Kernel: 5.6.15-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 Desktop: KDE Plasma 5.18.5
           tk: Qt 5.14.2 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux
Machine:   Type: Laptop System: ASUSTeK product: TUF Gaming FA506IU_FA506IU v: 1.0 serial: <filter>
           Mobo: ASUSTeK model: FA506IU v: 1.0 serial: <filter> UEFI: American Megatrends v: FA506IU.302 date: 03/04/2020
Battery:   ID-1: BAT1 charge: 45.7 Wh condition: 47.4/48.1 Wh (99%) volts: 4.0/11.7 model: ASUS A32-K55 type: Li-ion
           serial: <filter> status: Unknown
CPU:       Topology: 8-Core model: AMD Ryzen 7 4800H with Radeon Graphics bits: 64 type: MT MCP arch: Zen rev: 1
           L2 cache: 4096 KiB
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 92666
           Speed: 3363 MHz min/max: 1400/2900 MHz boost: enabled Core speeds (MHz): 1: 3670 2: 3833 3: 1397 4: 1397 5: 1397
           6: 1397 7: 1397 8: 1397 9: 1887 10: 1838 11: 1810 12: 3173 13: 1822 14: 1905 15: 1397 16: 1397
Graphics:  Device-1: NVIDIA TU116M [GeForce GTX 1660 Ti Mobile] vendor: ASUSTeK driver: nvidia v: 440.82 bus ID: 01:00.0
           chip ID: 10de:2191
           Device-2: Advanced Micro Devices [AMD/ATI] Renoir vendor: ASUSTeK driver: amdgpu v: kernel bus ID: 05:00.0
           chip ID: 1002:1636
           Display: x11 server: X.Org 1.20.8 driver: amdgpu,nvidia compositor: kwin_x11
           resolution: 1920x1080~144Hz, 2560x1440~60Hz
           OpenGL: renderer: AMD RENOIR (DRM 3.36.0 5.6.15-1-MANJARO LLVM 10.0.0) v: 4.6 Mesa 20.0.7 direct render: Yes
Audio:     Device-1: NVIDIA TU116 High Definition Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel bus ID: 01:00.1
           chip ID: 10de:1aeb
           Device-2: Advanced Micro Devices [AMD/ATI] vendor: ASUSTeK driver: snd_hda_intel v: kernel bus ID: 05:00.1
           chip ID: 1002:1637
           Device-3: Advanced Micro Devices [AMD] Raven/Raven2/FireFlight/Renoir Audio Processor driver: N/A bus ID: 05:00.5
           chip ID: 1022:15e2
           Device-4: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel
           bus ID: 05:00.6 chip ID: 1022:15e3
           Sound Server: ALSA v: k5.6.15-1-MANJARO
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK driver: r8169 v: kernel port: e000
           bus ID: 02:00.0 chip ID: 10ec:8168
           IF: enp2s0 state: down mac: <filter>
           Device-2: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter vendor: AzureWave driver: rtw_pci v: N/A
           port: d000 bus ID: 03:00.0 chip ID: 10ec:c822
           IF: wlp3s0 state: up mac: <filter>
           IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A
Drives:    Local Storage: total: 476.94 GiB used: 25.18 GiB (5.3%)
           ID-1: /dev/nvme0n1 vendor: Kingston model: OM8PCP3512F-AB size: 476.94 GiB speed: 31.6 Gb/s lanes: 4
           serial: <filter> rev: ECFK52.3 scheme: GPT
Partition: ID-1: / size: 58.81 GiB used: 23.08 GiB (39.2%) fs: ext4 dev: /dev/nvme0n1p5
           ID-2: /home size: 98.63 GiB used: 2.10 GiB (2.1%) fs: ext4 dev: /dev/nvme0n1p7
           ID-3: swap-1 size: 3.22 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/nvme0n1p8
Sensors:   Message: No sensors data was found. Is sensors configured?
Info:      Processes: 350 Uptime: 40m Memory: 7.20 GiB used: 3.53 GiB (49.0%) Init: systemd v: 245 Compilers: gcc: 10.1.0
           Shell: zsh v: 5.8 running in: server inxi: 3.0.37

tlp is up and running and the fans do work, I can hear them occasionally.

I also have to say that, when touching it, the feeling I have is that it's (quite much) cooler than another Lenovo I have that reports a constants temperature of 50-53 for each of its 6 cores. But these numbers are pissing me off, to be honest.

I don't have a zen cpu but a quick search on aur showed a zen specific monitor and kernel module:
zenmonitor

I can't say if this will work for you but it's at least worth reading and may point you in the right direction. Sorry I couldn't help further. Good luck.

1 Like

Or try linux-5.7.0, which has additional AMD support. Manjaro supports multiple kernels from the advanced grub menu. Normally I wouldn't recommend an early release of a new kernel series, but when the hardware is so new, it merits an exception. The hardware is new enough that you might need to wait for 5.8 or even 5.9 for better native temperature sensing. Keep reading the forums (not just here). Often, workarounds will be posted as users discover them (kernel arguments, .conf edits, ...)

1 Like

Will have a look later, you already helped a lot, thank you!

I didn't know that the 5.7 was finally released; I've been checking it regularly but refrained to install the rc, as the last time I was messing with the kernel I broke the thing. Then I'll also check if the patch for the brightness control was already introduced. I'll make sure that I have a timeshift backup before upgrading. Thank you!

Let us know how you get on.

Btw, how can I install the 5.7 kernel? I've already run sudo pacman-mirrors -f && sudo pacman -Syy but the latest kernel I can see in both the GUI and pacman with pacman -Ss linux57 is still the rc7 version.

What is the temp reported in your BIOS? Also note that BIOS temps are usually higher than in the OS due to power saving features in the kernel.

If your BIOS is also abnormally high, it could be that the CPU is not correctly configured.

I lived with a 2700X running at 60c for over a year before I realized that I needed to run an ASUS configuration utility built into the BIOS. Now it runs at about 40c (I live in a hot climate).

1 Like

From a fresh boot, it was marking 30-35C and the fans running at ~2300rpm. I've made a little stress test with a ML project that made acpi report 90C, then immediately reboot into the BIOS (5-10s since the script finished) and the temperature was 40C with the fans still running at 3500rpm. So I guess that acpi is basically wrong. That was a great idea for testing, thanks. And as said in the OP, never with the feeling of actual hotness in the laptop.

I still need to test the utility posted above, will update with results.

Sounds like the sensors need to be offset. A similar thing happened when the 2XXX series was released. All reported temps were 20c hotter than actual. It took a few months for those fixes to make it into the kernel.

2 Likes

You can use Manjaro Settings Manager or the KDE Settings Manager. Be sure to reboot and select it after post.

Yeah that's what I meant with that I wasn't seeing it in the GUI. The latest one I'm seeing is the 5.7rc7, experimental.

Ah, sorry, it's still in testing.

[Testing Update] 2020-06-03, to find out more. linux57 5.7.0 is supported.

If you want to try changing to the testing branch follow the steps here
Manjaro Wiki - Switching Branches

Alternatively, it shouldn't be too long before it's all released in stable.

Kernel.org released 5.7.0 on Sunday (5/31). It takes time to be checked by the Manjaro devs and the Manjaro testing community before it is pushed to the stable branch. I have seen some 5.7-rc wifi issues reported in other threads, so it might take a few 5.7 maintenance releases before that is all worked out. In any case, it looks like the kernel is reporting temperatures that are too high for these new AMD processors.

Tried it, and it's just showing the core frequencies. I've opened an issue. I'll keep this thread updated.

1 Like

I had trouble with my temps, because the cooling-paste was very poor from the manufacturer. It was horrible and after cleaning and replacing it my average temps went down from 70°C to 45°C. The build-quality of a lot laptops is very often poor.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by