Adding ANY printer through GNOME settings GUI does not work?

Hi,

I did the search on this topic and found some people that could not add individual printers to their systems. I think I have something different:

Running Manjaro GNOME 20.0.3 I cannot add any new printer through the GNOME settings application.

I remember this was totally possible when I first tried out Manjaro (in the 19.x generation) - and of course it worked in all Ubuntu-based distributions I used before.

Right now I could add my main printer via CUPS (it is a Brother model for which I have to search & build AUR-provided drivers anyway) but I cannot add the CUPS PDF-printer or any other printer from the "add a printer" dialog.

Is this a known problem? (If so, how/where do I report it as a Manjaro-Newb)
Or is it something in my profile (I also tried a completely new user created on Manjaro GNOME, same effect as my main user)? And yes, using the same dialog in Ubuntu-based distros still works as of today ;-).

Thanks for your assistance!
SuAlfons

Hi,
That's the way to do it.

Install the package cups-pdf and you will be able to print to pdf file ...

1 Like

Hmm...so it's a wanted behaviour to have the GNOME printer GUI but have it non-working?

This makes no (obvious) sense and is totally against my strong desire of having only things that work.
You can't even blame GNOME for it since the configuration GUI works fine in every other distribution I tried before. Also it worked in Manjaro 19.x IIRC.

PDF work OOB - in any print dialog choose print to file - supply file name - done.

Arch based distros need cups.d enabled 1st.

I know. The issue is about having a GNOME printer dialog that cannot be used whlie it can in other distros. And adding printers through cups-configuration (while it can be done) I had to search on how to do it.
Using Gnome, having the printer GUI and not having it working is a usability desaster. Because...people that used GNOME on other distros are used to the dialog not only listing the printers but actually doing something.
See me - a Manjaro newb, I thought this might be an error. How should I know that is by design?

EDIT: Sorry for this rant, it's nothing personal against you :frowning:

When I enable cups.d, then the printers become manageable through the GNOME printer GUI?

How do I do that and why is it not done for me in a standard installation on an otherwise very fine coordinated GNOME session on Manjaro which even has a GUI to swicheroo between a bunch of extensions mimicking different DE layouts.

EDIT: Oh, it really does come alive when you enable it...and how to do it is in the WIKI. I stand corrected.

That sounds not a good way to talk to somebody trying to help you.
Because Manjaro is based on arch Many users don't use printers and cups is then bloat so its not enabled, if you were to read the manjaro wiki you could of saved time and learned for your self

Sorry, I did not want to discredit your all replies and helpfulness!

I'm German and that means, we talk plain and cannot stand things that don't work when present.

So your German, I'm British and that means we don't take shyte from others so now that is sorted out.

A couple of years ago user complained but so it was removed again, I don't even think its a good GUI interface to start of with I use system-config-printer. a much better interface and its a GUI.
And yes Gnome has been my daily driver,
If you want to use bluetooth it needs enableing then should be good to go so now you know.

Yeah, thank you for not taking it personal.

I really was not meant to target a person anyway - I could not imagine the thing not working not being an error. Probably my error, but something that went wrong.

I learned from you:

  • It's in the WIKI
  • The built-in GNOME dialog is defunct per design b/c the whole printing stuff is bloat to non-printing users
  • Better use system-config-printer anyway

The Gnome GUI has improved over the last couple of years

Adds enables cups when you use it it just does what it says on the box.
Good luck. :+1:

1 Like

I think we are having the classical language barrier - where trying to use the correct words results in words which are over excagerating the topic at hand.

I dropped Gnome a couple of years ago in favor of a Openbox window manager environment.

Gnome has all the necessities default installed and enabled.

The list of services which is default enabled:

enable_systemd=('bluetooth' 'ModemManager' 'NetworkManager' 'org.cups.cupsd' 'tlp' 'avahi-demon' 'haveged' 'ufw' 'apparmor' 'snapd.apparmor' 'snapd' 'fstrim.timer')

First screenshot from a default gnome live ISO with classical layout enabled

20200727-062147_1223x687_screenshot

After powering up the in-house access point and reloading the printer settings in gnome-control-center the printer attached to the wireless was found as well

Second screenshot from a default gnome live ISO with classical layout enabled

20200727-062709_1226x687_screenshot

Because Qt based and GTK based system uses different apps for managing printer this package is not installed and because gnome-control-center provides the printer installation interface.

The 'old-school' printer config applet can be installed - or you can use the cups webui at https://localhost:631

sudo pacman -Syu system-config-printer

then launch the app or look it up in the menu Print Settings

system-config-printer
  • Unlock using the :lock: in upper right corner.
  • If cups is not running the app will ask to enable and start cups.

If unlocking don't start the service - then enable and start it - I don't think it is necessary as the official editions comes with cups enabled.

systemctl enable --now org.cups.cupsd

Go from there ...

And as I mentioned earlier - printing to pdf (to file) work without cups - if I remember correct.

A last note on printer discovery - if the printer is a networked printer - just expand Network printer - do not click on Search Network Printer unless you know it is a part of a Windows AD requiring credentials to connect.

@Ste74
You may want to check if the system-config-printer package is providing functionality which is lacking from gnome-control-center. I any case - it appears not to be needed as setting up printers work OOB.

Just got caught up in browsing the Gnome experience - congratulation @Manjaro-Team - this is the best Gnome experience I have seen since I was a Gnome user.

:100: :+1:

3 Likes

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by