After crash Network interfaces are DOWN and will not come back up

Hi,

I have run into a serous issue and I don't know how to move forward on this.

Any help or guidance would be great appreciated.

Summary

Device: Dell Inspiron 3000
Environment: KDE + LUKS full disk encryption
Kernel: 5.4.44-1
Machine Purpose: Web development
Problem: All network interfaces are DOWN and they not coming back up
Preceding Events: Crash (suspect overheating) + USB Recovery + FSCK

Details

I recently had a system crash, that I do not know the cause of. I suspect over heating so I left the machine to cool down and then tried to boot into it.

After typing in the LUKS encryption pass code, it froze on the Dell logo and did not go any further.

So I booted from a Manjaro-Architect USB unlocked the encrypted disk and a fsck check on both boot and root encrypted partition. A dirty bit was cleared from the boot partition.

Note that Manjaro-Architect was able to access my ethernet using DHCP as per normal and sync repositories and update keys.

After this I was able to boot into KDE but there is was no networking of any kind.

Network manager is active and running.

What have I tried

  1. Rebooting
  2. systemctl status NetworkManager
  3. modprob to load and unload drivers
  4. ip link set UP on each device

inxi -n output

Network:   Device-1: Realtek RTL810xE PCI Express Fast  Ethernet driver: r8169
           IF: enp2s0 state: down mac: x:x:x:x:x:x
           Device-2: Qualocomm Atheros QCA9377 802.11ac Wireless Network Adapter driver: ath10k_pci
           IF: wlp3s0 state: down mac: x:x:x:x:x:x

Thank you.

So for anybody else that stumbles onto this post with a similar issue the following is how I troubleshooted & solved it.


1. Checked logs for NetworkManager service for the last boot only

journalctl -u NetworkManager -b

2. Found log stating its disabled

manager: Networking is disabled by state file

3. Internet search results

The following link showed where it was and possibly how fix:
https://bugzilla.redhat.com/show_bug.cgi?id=589108

/var/lib/NetworkManager/NetworkManager.state

4. Tried updating the state file & restart service

sudo nano /var/lib/NetworkManager/NetworkManager.state
sudo systemctl restart NetworkManager

This did not work.

5. Tried deleting the state file & restart service

sudo rm /var/lib/NetworkManager/NetworkManager.state
sudo systemctl restart NetworkManager

This did not work.

6. Found and used nmcli to turn on service

sudo nmcli n on

Everything is working again.

Good luck to anybody else that runs into this same bazaar issue.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by