After customizing panel, Manjaro won't boot any more

I recently installed Manjaro on a secondary hard drive along with my Windows 10. I had the dual booting working fine and was able to switch back and forth between Windows 10 and Manjaro with no issues.

This was working great for about a week or so until I decided to customize my Manjaro Panel.

First I moved the panel to my other monitor. Then I started messing around by adding and removing different widgets. For example, added CPU monitor to check it out. Removed CPU monitor. Added dictionary, removed dictionary. Changed icons. Changed size of panel and moved to side of screen instead of bottom. You get the idea.... Just basic customization stuff. Then I went into the main "Start" button area and deleted the preset Favorites. At this point I searched for and tried to open an application. I think it was Settings manager or something along those lines. It didn't open... I clicked on something else just for kicks. Also didn't open.... I was like "ok...." so I decided to restart Manjaro to see if it would fix why things weren't opening.

Well.... it started going through the normal loading but instead of opening up the login screen like normal, now it's just a black screen.

It seems like I may have screwed something up when I was adding/removing a bunch of things from the panel but I don't know how to fix this. Any help would be greatly appreciated.

As a side note this was my first Linux installation so you'll have to be very clear in the steps I should take to try to resolve. Thanks.

Some questions:

XFCE or KDE, or what?
How did you restart? Power switch, or normal shutdown?
Can you read this while you are booting? Or is this your only available computer?

It's XFCE. I was able to go to the logoff menu and just click restart and it shut down normally until the black screen. Yeah, I have an extra computer so I can read this and try stuff.

Well just because you have a black screen does not mean linux is not running.

Press Ctrl-Alt-F2 and you should see a login prompt.
enter login name
hit enter
enter password
hit enter

You should be at a screen where you can work in text mode.

You can switch to the system console with Ctrl-Alt-F1.
Maybe there are messages there to tell you what's wrong.

If you get that far,
Post back what you see (not word for word of course)

After it crashed the first time I went into BIOS and switched to boot from my Windows. Now I went and switched back to boot from the Manjaro drive. It looks like the Grub works okay up to that point - it shows 3 options as usual - the Manjaro boot option, and Advanced options Manjaro boot, and my Windows 10 boot.

Previously, when I would select the Manjaro boot option it would get to a screen that said something like loading System 232 and then I think it would go straight to the login screen.

Just now when I tried again, I see that same loading System 232 screen and then some other text comes up but it's too fast for me to read, and then I get the black screen.

At that point I tried Ctrl-Alt-F2 but I don't get a terminal. Tried several times but still just a black screen.

I restarted again and back at the Grub screen I'm able to press c to get a Grub command line. Also when I select the Manjaro with advanced options it shows me 2 choices:

  1. Manjaro Linux (Kernel: 4.9.16-1-MANJARO x64)
  2. Manjaro Linux (Kernel: 4.9.16-1-MANJARO x64 - fallback initramfs)

I tried selecting the fallback initramfs option and I still get the same black screen and Ctrl-Alt-F2 does not work there either.

Any chance you were running an update during all this? These issues sound like what a number of people are reporting currently because of failed updates.

Actually I did see that I had some updates and clicked to view them right before I was doing all this modifying. I think I just x'd out of the update window without actually starting to install them though. But if I had actually clicked to install and then someone cancelled it.... that might cause this?

Yes, I think so. Most major problems people have reported are when the latest update was interrupted for some reason.

1 Like

Wow, okay. So since I haven't been able to get to a terminal, is there any other way to try to reinstall the updates? Or am I gonna have to just start with a fresh install?

I would try booting live iso, chrooting to your installation with

  manjaro-chroot -a

Then update the system with

  pacman -Syu

Fix any problems with the update until it succeeds.

Then run

   mkinitcpio -P 

Then reboot to your normal system.

If that doesn't work, rollback in the chroot the update that caused the issue and retry.


edit: follow @Chrysostomus steps, they are a little simpler than the guide I linked to

When logging to tty fail (some got in after trying 15-20 times and trying F3 or F4..) then next step is to use Live Manjaro media and boot from it and chroot into your system (chroot = change root)

Then once you are chrooted into your broken system, you can run system update from there.


So once I boot to live USB will I need to mount the file system as in the guide that AlManja posted or can I directly run the "manjaro-chroot -a" command?

I edit my post advising to just follow @Chrysostomus steps since they are simpler. Guide is based on older tool and there are few extra steps involved.

As far as I understand:

manjaro-chroot -a

automates mounting & chrooting for you as long as you are not using btrfs file system - if you are not sure, then you don't use it... (but I have yet to try this automated way myself) :slight_smile:

Ah sorry, I missed that edit. Thanks for clarifying. I'm at work now but I'll try this out later tonight when I get home.

Good luck and I hope it works for you!

Chrooting is very powerful tool, and with it you should practically be able to always get back in if system is not too damaged. Well depends of someone knowledge. But definitely keep this 'chrooting' in your tool box :slight_smile:

Thanks! Will do!

If you can get here, just select option #1, but there will also be a command line area where you can enter other text.
Just enter a 3 (a single digit 3) at the end of that line, and it will boot to a terminal without trying to load your graphical environment. You will see a login prompt.

If that works there's no reason to do the chroot step at all.

You will have to then finish the update that apparently got half started, with pacman commands.
pacman -Sy manjaro-keyring
pacman -S manjaro-system
pacman -S lib32-mesa
pacman -Syu mhwd

Another Alternative: Since you were just doing preliminary configurations on a new install, and have essentially nothing invested in this install, you might want to download 17.0.1 which is newer and includes all the troublesome patches and re-install:

Ok guys... I tried @Chrysostomus 's solution initially and it kept asking me which installation to mount but it wouldn't let me mount it. After that I tried going through the guide posted by @AlManja and after mounting it myself I was able to chroot into my old installation! I just did a quick ls check to make sure I was in the right place and I was able to see my files and whatnot.

So then I tried using sudo pacman -Syu and it said core, extra, community and multilib was up to date. Then asked me to replace manjaro documentation. I said yes. Then asked me to replace pacman mirror list, I said yes. Then listed about 65 packages to install. I said Yes to proceed with installation. I now am getting the following error:

error: could not open file: /etc/mtab: No such file or directory
error: could not determine filesystem mount points
error: failed to commit transaction (unexpected error)
Errors occurred, no packages were upgraded.

And that's where I'm stuck at now...

I'm sorry to hear this. Beginner myself I have nothing else to offer. Hopefully someone else may have some idea soon what to do next

Here is original post about chrooting, maybe try this?

Forum kindly sponsored by