After fresh installation of Manjaro XFCE Windows 10 doesn't open

There is nothing wrong at manjaro.
Problem is at Windows.
Fix in at Windows, its boot
After fixing it, you may have to do update-grub at manjaro, that's all you need to do at manjaro,
You may not even need to do update-grub , but just do it.

PS: I cannot help with fixing windows. Don't know, not sure, haven't done.

1 Like

The problem is when I select to repair windows and fails and say continue again with windows10 it comes back to manjaro GRUB instead of continue to enter inside windows, maybe it's related to the 2 /boot/efi?

is it the boot also if opens and says repairs fail or it's the system itself

maybe if I uninstall in some way manjaro GRUB i can continue with Windows

That might break all OSes, so you may loose Manjaro as well.
Try to select Windows from UEFI, or change boot order making Windows 1st. If it also fails, there is no other advice from Linux. You have to ask Windows resources.
You may need to install Windows again...

1 Like

it doesn't work. Do you know where to ask about Winsows resource?

Also from Manjaro I cannot find the location to recover data in WIndows

Windows is in /dev/nvme0n1p3 but there is no such a file/directory

Did you use Thunar?
There should be some (un)mounted partitions at the left pane..

1 Like

Correct. That's because when the system fails to boot, it goes to the next efibootmgr entry which is Manjaro.

. Though you can test your hypothesis by resetting Manjaro /boot/efi to the same as windows.

That happens while attempting to boot and repair windows. That would be at windows. Not likely to be system and definitely not Manjaro.

That's windows OS itself (like linux root /). Its efi file is in /dev/nvme0n1p1 not /dev/nvme0n1p3.
So the (efi) file is not found in /dev/nvme0n1p3.
Reminder - the file found in /dev/nvme0n1p1 fails to boot windows.

1 Like

I've tried with the LIVE USB to take windows files but I can't do because when I select from Thunar the "OS" it doesn't open and its color is gray and not black (GUI Thunar)
I think because it is unmounted so I've tried with gnome-disks to mount windows OS but I cannot do also in this case.

where to find the OS system? because /dev/nvme0n1p1 and /dev/nvme0n1p3 are single files and not the operative system in which I can enter usually with the LIVE USB and copy all directories and files( also there is no in /run/media/ since it is not mounted.

I also wondering if there is also something left because from GPARTED as you can see in my first post (picture or the code above) there is written Size 196.81 GiB and used --- (or maybe it doesn't tell how much is used because it's not mounted or 2 /boot/efi)?
However thanks guys for all your effort

if I can take both manjaro and win10 in one /boot/efi maybe the problem can be solved? there is some guide if you know for the code to make it

Yes indeed there is the unmounted partition which is OS that is referring to Win10 and for this reason in live I also cannot enter in it and recover the files if there are

I've also tried to add in grub.cfg where there is the entry of" Win10 option 30 "and not in custom.cfg as the post 5 suggest in this link, adding only the command ntldr /bootmgr
but when I started again and entered in Win10 said that ntldr isn't found or recognize as command

maybe here is not on /sda the entry I have to make but on /dev?

That is only for bios-legacy systems. Yours is uefi.

I had typed "No. Though you can test....."
The "No." was somehow missing.
But I seriously doubt it is the 2 /boot/efi though nvme disks can be picky.
In 'normal' disks, it is a definite "No Way!!"

But if you want to try that out.

  1. Boot into Manjaro
  2. unmount /boot/efi
  3. Change fstab to the windows $esp
  4. Remount changed $esp as /boot/efi
  5. Do "sudo grub-install"
    Do "sudo update-grub"

But warning... if you try this out, and it fails or you have done the commands wrongly, your Manjaro that you can boot now will not boot again. Think carefully. I have serious doubts it is the case. And I repeat that it will not be the case with 'normal' disks and I am unsure about nvme disk (because I do not have nmve disk) though I hear nvme can have its own 'peculiarities'.

ps: it's late here and Im logging off soon.

[EDIT] - I repeat I think it is your Windows boot that is kaput.
And it is easier to fix windows boot (though I do not know how - fixmbr, fixboot?) than to reset Manjaro's $esp partition.

ps: I have multiple $esp's in my ssd's.

1 Like


While I am doubtful that having 2 $esp (in nvme) is the source of your problem, there have been cases where $esp must be in nvme partitions and not in other devices, though I was informed (elsewhere) that some had successfully put a separate $esp in another disk (in an Intel NUC system). Note your separate $esp are on the same nvme disk. And where Manjaro is put on a separate $esp in other non-nvme disk, resetting the $esp back to nvme works, like a quick search here. shows.

Right, the main reason for this post is to assuage you that should you try out resetting Manjaro to the same $esp as Windows and it was messed up, I can assure you you can get back your Manjaro by "Simple First Try" here.

Secondly, if windows still cannot boot up after resetting Manjaro's $esp and you have to resort to reinstalling Windows boot (as was first suggested), your Manjaro boot will be destroyed by windows reinstalling its boot (by reason of being in the same $esp). However, to get back Manjaro, the same link [Simple First Try] will also work to restore Manjaro.

So you can try resetting Manjaro $esp if you choose to. No (big) worries.
Good luck.


I suggest you recover your windows 10 by "recovery key" if you did not delete the recovery file system. normally each of computer comes with windows preinstalled will have recovery mode. if you can recover, you can start over again to install manjaro again.
I did install Bodhi Linux with windows 10 by legal bios, not efi bios. i am not sure where you are wrong. Only take a careful look at your computer boot process maybe find problem.
Right now i am running manjaro with windows 7, no problem at all.
I guess you must touch windows boot file when you install manjaro, possiblly you delete some or one of critical partition for windows booting, that makes you can boot windows.
Try recovery mode.

1 Like

Hello everyone, thank you always for your effort. I-m working on the problem, I tried to mount the /dev/nvme0n1P from 1 to 7 partitions I can mount everyone and see what is inside (the 1 is for Boot) except for the 3(that is the OS)

The output of the command mount /dev/nvme0n1p3,
this suggests the partitions is corrupted? The problem isn't WIndows Bootloader but the partition, I've to try to fix the partition in order to open it and recover the data (most concern of recover the data than have the OS working, maybe use EasyRE windows or Linux commands/software_?

HINTS: Either the volume is a RAID/LDM but it wasn't setup yet,
  or it was not setup correctly (e.g. by not using mdadm --build ...),
  or a wrong device is tried to be mounted,
  or the partition table is corrupt (partition is smaller than NTFS),
  or the NTFS boot sector is corrupt (NTFS size is not valid).
Failed to mount '/dev/nvme0n1p3': Invalid argument
The device '/dev/nvme0n1p3' doesn't seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?  ```

I can see the file of the recovery mounting the nvme files from Linux, recovery key means you have to extract those files? However I cannot see from prompt commands of Windows when I select it for the option after the reparation fails. I think the prompt is only virtual (it says X:> instead of C:>, there are no certain commands, cannot switch in C because it is only virtual prompt, I tried)

It seems pure luck to find an answer here, since this is a difficult Windows situation/problem.

I think you should have more luck in web search, or a Windows specific support forum.

Hi @fenerevar i would like give you my advice

You should not have 2 partitions with boot/efi like this 2 :
/dev/nvme0n1p1----> here would be bootlader efi of windows 10 what one look is broke
/dev/nvm0n1p4---> Did you select for your self a own partition for install boot/efi from Manjaro?? If you did it.. it is should be wrong because the boot/efi from manjaro if you use calamares should install his efi firmware into the /dev/nvme0n1p1 yeah in the same place with windows there is enough space for more what only windows (calamares would have detect automatic but maybe you fix it for yourself... I dont know or just it got wrong can happen too).

You should do ( it is only my opinion)
1- Repair boot/efi windows 10 ---> look here
2-Check you can run windows 10 ( you don't should have access to manjaro still)
3-Delete partion /dev/nvme0n1p8 with bootlader of manjaro (format this one)
4-Reinstall grub (use live cd -manjaro) and should detect automatic windows 10 bootlader and install manjaro bootlader in same place some windows /dev/nvme0n1p1.
5-Now should you have acces to windows 10 and manjaro.

It is all what i can help you :slight_smile:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by