After install Manjaro only boots into grub rescue

I need some help. I tried fixing this on my own and am getting nowhere. I tried reinstalling and I re-formatted the disk through the install screen of the live USB. I am attempting to install with encryption and, the encrypted filesystem is accessible using the live version from the USB stick.

Here is the error before it puts me into grub rescue:

Output from various commands that might help someone smarter than me:

[manjaro@manjaro fred]$ lsblk -f
NAME                                  FSTYPE      LABEL    UUID                                 FSAVAIL FSUSE% MOUNTPOINT
loop0                                 squashfs                                                        0   100% /run/miso/sfs/livefs
loop1                                 squashfs                                                        0   100% /run/miso/sfs/mhwdfs
loop2                                 squashfs                                                        0   100% /run/miso/sfs/desktopfs
loop3                                 squashfs                                                        0   100% /run/miso/sfs/rootfs
├─sda1                                vfat        EFI      67E3-17ED                                           
├─sda2                                apfs                 0b45da22-1aac-4786-9b66-73a482947c97                
└─sda3                                apfs                 170001d1-fe24-4e03-b4a1-3855ed7e7ca3                
├─sdb1                                vfat        EFI      67E3-17ED                                           
└─sdb2                                apfs                 ca1c352f-e8a1-47fd-bdbb-d5d8fd471b45                
├─sdc1                                vfat                 1907-09EA                             299.2M     0% /mnt
├─sdc2                                crypto_LUKS          9c3c4f42-56eb-4382-811b-1f605b9ea03c                
│ └─luks-9c3c4f42-56eb-4382-811b-1f605b9ea03c
│                                     ext4                 4623d668-f485-4851-95e5-e33a7f1fe502    2.5T     0% /run/media/manjaro/4623d668-f485-4851-95e5-e33a7f1fe502
└─sdc3                                crypto_LUKS          8ddac8fa-dfbc-42b9-b9c6-85ab18cc29a7                
├─sdd1                                vfat        EFI      67E3-17ED                                           
├─sde1                                vfat                 020E-CBC3                                           
├─sde2                                vfat        BOOT     7ED0-CD84                                           
└─sde3                                crypto_LUKS          994a67a6-9e68-43ba-a1b7-3bf87c81c6d8                
sdf                                   iso9660     MJRO1802 2019-01-03-18-10-47-00                     0   100% /run/miso/bootmnt
├─sdf1                                iso9660     MJRO1802 2019-01-03-18-10-47-00                              

[manjaro@manjaro fred]$ inxi -SMDPI
System:    Host: manjaro Kernel: 4.19.13-1-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.14.4 Distro: Manjaro Linux 
Machine:   Type: Desktop System: Gigabyte product: N/A v: N/A serial: <root required> 
           Mobo: Gigabyte model: Z77X-UD5H v: x.x serial: <root required> UEFI: American Megatrends v: F15q date: 01/07/2013 
Drives:    Local Storage: total: 14.13 TiB used: 7.01 GiB (0.0%) 
           ID-1: /dev/sda vendor: Seagate model: ST4000DM004-2CV104 size: 3.64 TiB 
           ID-2: /dev/sdb vendor: A-Data model: SU800 size: 476.94 GiB 
           ID-3: /dev/sdc vendor: Seagate model: ST3000DM001-1ER166 size: 2.73 TiB 
           ID-4: /dev/sdd vendor: Seagate model: ST4000DM004-2CV104 size: 3.64 TiB 
           ID-5: /dev/sde vendor: Seagate model: ST4000VX000-2AG166 size: 3.64 TiB 
           ID-6: /dev/sdf type: USB model: Flash USB Disk size: 14.84 GiB 
Partition: ID-1: / size: 23.53 GiB used: 503.9 MiB (2.1%) fs: overlay source: ERR-102 
Info:      Processes: 243 Uptime: 39m Memory: 31.37 GiB used: 1.89 GiB (6.0%) Shell: bash inxi: 3.0.28

sudo fdisk -l

[just pasting /dev/sdc output since that is where Manjaro is]

Disk /dev/sdc: 2.7 TiB, 3000592982016 bytes, 5860533168 sectors
Disk model: ST3000DM001-1ER1
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: 10695609-3985-46AC-B374-59D987D08D99

Device          Start        End    Sectors  Size Type
/dev/sdc1        4096     618495     614400  300M EFI System
/dev/sdc2      618496 5788150280 5787531785  2.7T Linux filesystem
/dev/sdc3  5788150281 5860528064   72377784 34.5G Linux filesystem

Partition 3 does not start on physical sector boundary.

GPT PMBR size mismatch (4294967294 != 7814037167) will be corrected by write.

Any assistance would be greatly appreciated.

Use search function upper right

grub rescue
grub rescue
Sortieren nach
letzter Beitrag
After install Manjaro only boots into grub rescue
Newbie Corner
10min - ...stall with encryption and, the encrypted filesystem is accessible using the live version from the USB stick. Here is the error before it puts me into grub rescue: photo_2019-02-02_21-27-52.jpg photo_2019-02-02_21-27-52 photo_2019-02-02_21-27-52.jpg 1280×960 58.5 KB Output from various commands that migh...
Another “can’t boot after clean install” post
Newbie Corner
1d - haffnasty: How can I boot without a GUI? IIRC from GRUB menu you can press “e” to edit boot entry. Then navigate to the line that begins with “linux” and add/remove kernel parameters. Then press F10 to boo...
Error: no such cryptodisk found - HELP
Newbie Corner
2d - ...very time I boot up the machine is see: error: no such cryptodisk found error disk `cryptouuid/..................` not found. Entering rescue mode... grub rescue > _ How can I fix this, and revert back to original windows10 only state? I already tried going thru lenovo recovery factory reset windows 10,...
Grub corrupt
Newbie Corner grub
4d - On 01/24/2019 I accepted updates by Open Packet Manager. After shutdown and power up I got error: symbol ‘grub_key_is_interrupt’ not found. Entering rescue mode… grub rescue I tried Restore the GRU...
Latest update broke my system: Can’t get into TTY
Newbie Corner
7d - ...n update to my 4.19.14 also broke my bootup, for the same systemd flaw. I followed all the many suggestions here and links, nothing would get me to a GrUB selection screen. The best I got with this was a grub_rescue > prompt. I am a hobbyist and not a coder, so I was nearly reduced to a reinstallation a...
Grub rescue - no such device - unknown filesystem after install
Technical Issues and Assistance
7d - This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.
Dropped into emergency shell without keyboard access due to a failed hibernation
Technical Issues and Assistance grub kde live-media shell
8d - ...h for replying and providing some possible solutions. As I stated later in the post I have already tried to boot into a live USB but it takes me to a GRUB rescue page instead of booting to the installation screen where I would be fine to use these commands as I saw them while researching.

That is exactly why I included the output I did. Those answers did not lead me to figuring out how to fix my situation and they were different issues. I am not upgrading, this is a clean install. I didn't install anything else after Manjaro that broke grub, I don't have Windows installed on any disk.

1 Like

hope it works out, i know nothing of luks except for what ive read here on the forum.

1 Like

Nice, thanks. I can see /boot/grub/grub.cfg but the /etc doesn't exist. I think it is because /etc is in the encrypted portion, so I'm trying to figure out how cryptomount works. So far it appears grub is trying to cryptomount the right partition my attempts to issue grub commands lead to the same result as when I let it boot. I'll keep working on the cryptomount side. I'm wondering if a driver/module is not loaded that is needed. One post mentioned device-mapper. Maybe I'll try to install antergos, see if that installls encrypted and what is different.

i know the encrypt hook is needed in /etc/mkinitcpio.conf so check that its there and if not add it to the HOOKS=(
sudo mkinitcpio -P
sudo update-grub

of course this would need to be done from chroot i believe

Not sure if this helps, but this happened to me the first time I installed Manjaro.
It turned out that I flubbed typing in the password when I set up the disk encryption.

If nothing else has helped, and you don't have any data you need to get off the disk, try installing Manjaro again fresh with a fool-proof password like asdf0987 for the disk encryption, and see if that lets you in.

Basically, you'll see the grub rescue prompt every time you type in the wrong password.

1 Like

Check this tutorial to try chrooting in your encrypted installation. If it fails, you may have the wrong password as already suggested.


you may be able to prevent re-install by figuring out how you mistakenly created the wrong pw.

type your intended password 10-15 times as quickly as possible, see what mistakes you have made, try those mistakes as your password. most human error can be reproduced given the right conditions to replicate the mistake.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by