After install video-nvidia manjaro can't boot

Not yet. Since I know you can handle tty then let's do this experiment.

  1. Rename existing optimus-manager X11 conf and add intel at the end so you could bring it back easily if it went wrong:

sudo mv /etc/X11/xorg.conf.d/10-optimus-manager.conf /etc/X11/xorg.conf.d/10-optimus-manager.conf-intel

  1. Create new, nvidia conf based on mine and hopefully, it will fit:

sudo nano /etc/X11/xorg.conf.d/10-optimus-manager.conf

Section "Module"
	Load "modesetting"
EndSection

Section "Device"
	Identifier "nvidia"
	Driver "nvidia"
	BusID "01:00:0"
	Option "AllowEmptyInitialConfiguration"
	Option "Coolbits" "28"
	Option "DRI" "3"
EndSection
  1. Add this exec /usr/bin/optimus-manager_Xsetup line:

sudo nano /usr/share/sddm/scripts/Xsetup

#!/bin/sh
# Xsetup - run as root before the login dialog appears
exec /usr/bin/optimus-manager_Xsetup

After that is done, log out, log in and check

optimus-manager --print-mode

not work. still in intel. but in new etc/X11/xorg.conf.d/10-optimus-manager.conf
changed

Section "Device"
	Identifier "intel"
	Driver "modesetting"
	BusID "00:02:0"
	Option "DRI" "3"
EndSection

and

#!/bin/sh
# Xsetup - run as root before the login dialog appears

now re-installed and it's same not working. how can back to bumblebee?

Switching method is not bbswitch, if that matters.. (I have no experience with optimus-manager.. yet)

It doesn't matter. It defaults to bbswitch anyway without noveau.

I couldn't on my side but maybe you will have more luck.

  1. Cleanup:

sudo optimus-manager --cleanup

  1. Disable optimus-manager process:
sudo systemctl stop optimus-manager.service
sudo systemctl disable optimus-manager.service
  1. Restore normal confs that you backed up.
sudo mv /etc/X11/xorg.conf.d/90-mhwd.conf.bak /etc/X11/xorg.conf.d/90-mhwd.conf
sudo mv /etc/X11/mhwd.d/intel.conf.bak /etc/X11/mhwd.d/intel.conf
  1. Enable bumblebee:
sudo systemctl start bumblebeed
sudo systemctl enable bumblebeed
  1. Reboot

  2. Check if bumblebee is working correctly by running these commands:

sudo systemctl status bumblebeed

If it's active and shows now errors do this:

primusrun glxgears

It should open a window with spinning cogs and show fps in the terminal. If not, you will see error that may help troubleshooting further.

If this won't work, we can try to uninstall bumbleebe and drivers then install them again to load correct configuration with mhwd. But first, try what I gave above.

1 Like
[fla@fla-pc ~]$ sudo systemctl status bumblebeed
[sudo] password for fla: 
● bumblebeed.service - Bumblebee C Daemon
   Loaded: loaded (/usr/lib/systemd/system/bumblebeed.service; enabled; vendor preset: disabled)
   Active: active (running) since Fri 2018-12-28 07:53:47 +0330; 1min 37s ago
 Main PID: 523 (bumblebeed)
    Tasks: 1 (limit: 4915)
   Memory: 1.5M
   CGroup: /system.slice/bumblebeed.service
           └─523 /usr/bin/bumblebeed --use-syslog

Dec 28 07:53:47 fla-pc systemd[1]: Started Bumblebee C Daemon.
Dec 28 07:53:48 fla-pc bumblebeed[523]: /usr/bin/bumblebeed 3.2.1-2017-02-27-Format:%h$ started
[fla@fla-pc ~]$ primusrun glxgears
primus: fatal: failed to connect to Bumblebee daemon: Permission denied
[fla@fla-pc ~]$

check groups & user & bumblebee
restart

after reboot

[fla@fla-pc ~]$ sudo systemctl status bumblebeed
[sudo] password for fla: 
● bumblebeed.service - Bumblebee C Daemon
   Loaded: loaded (/usr/lib/systemd/system/bumblebeed.service; enabled; vendor preset: disabled)
   Active: active (running) since Fri 2018-12-28 17:40:32 +0330; 2min 25s ago
 Main PID: 519 (bumblebeed)
    Tasks: 1 (limit: 4915)
   Memory: 1.4M
   CGroup: /system.slice/bumblebeed.service
           └─519 /usr/bin/bumblebeed --use-syslog

Dec 28 17:40:32 fla-pc systemd[1]: Started Bumblebee C Daemon.
Dec 28 17:40:33 fla-pc bumblebeed[519]: /usr/bin/bumblebeed 3.2.1-2017-02-27-Format:%h$ started
[fla@fla-pc ~]$ glxinfo | grep
Usage: grep [OPTION]... PATTERN [FILE]...
Try 'grep --help' for more information.
[fla@fla-pc ~]$ glxinfo | grep glx
server glx vendor string: SGI
server glx version string: 1.4
server glx extensions:
client glx vendor string: Mesa Project and SGI
client glx version string: 1.4
client glx extensions:
[fla@fla-pc ~]$ check groups & user & bumblebee
[1] 1552
[2] 1553
bash: check: command not found
bash: user: command not found
bash: bumblebee: command not found
[1]-  Exit 127                check groups
[2]+  Exit 127                user
[fla@fla-pc ~]$ primusrun glxgears
primus: fatal: failed to connect to Bumblebee daemon: Permission denied
[fla@fla-pc ~]$

for permission

groups
users

if bumblebee is missing

gpasswd -a *user* bumblebee

i want try with prime. this is our options?

  • Use PRIME render offload with nouveau and get reduced performance
  • Use PRIME display offload for best performance but with dGPU active at all times

i won't run Nvidia all the times. this Tutorials is for me?

As others said above, add yourself to bumblebee group. You can do it with manjaro settings, go to user accounts, click on the "account type - administrator". It will open new window, mark "show the groups", find bumblebee, mark it and apply.

If that won't help, at this point I would advise to uninstall bumblebee with drivers completely and install it again according to this site:

https://wiki.manjaro.org/index.php/Configure_Graphics_Cards

So:

  1. Deactivate bumblebee:
sudo systemctl stop bumblebeed
sudo systemctl disable bumblebeed
  1. Uninstall drivers:

sudo mhwd -r pci video-hybrid-intel-nvidia-bumblebee

  1. Install drivers again:

sudo mhwd -a pci nonfree 0300

  1. Reboot.

  2. Check if it's working:

mhwd-gpu --check
mhwd-gpu --status
sudo systemctl status bumblebeed
primusrun glxgears

If that won't help, switch manually to PRIME, but that will make drain your battery so much faster... Prime is a good setup for stationary PCs, with laptop it's either bumblebee or switchable graphics.

In worst situation, reinstall system and just do the beginning where you installed bumblebee, before optimus-manager. Or you may try to install Manjaro already with non-free drivers. I do it always by launching non-free live mode. Not sure if there is another decision about drivers. I installed Manjaro quite while ago.

Anyway, when you manage bumblebee working, set nvidia-xrun if you want to use vulkan for full support of Steam Play. Here is my tutorial how to do that:

1 Like

my battery is out. PRIME CPU usage and memory are normal?

Yeah, they should be normal. The main issue is like I said with the bower. Dedicated GPU like nvidia takes more power then Intel GPU.
So in such case, go with Prime setup. Hybrid graphic in Linux as you noticed is major PITA. Sometimes it works flawlessly, sometimes it causes issues and it's hard to set it. Prime setup simply is a setup for one GPU - nvidia so there are no problems with switching graphics.

[fla@fla-pc ~]$ sudo mhwd -r pci video-hybrid-intel-nvidia-bumblebee
> Removing video-hybrid-intel-nvidia-bumblebee...
Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/local/pci/video-hybrid-intel-nvidia-bumblebee/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: optimus-manager: removing linux419-bbswitch breaks dependency 'bbswitch'
Error: pacman failed!
Error: script failed!
[fla@fla-pc ~]$

In this kind of errors, pacman is trying to remove a package but the package is a hard dependency of another and since you didn't specify uninstalling the other, it stops removal in order not to do any damage. IT's just a safety mechanism ensuring you don't uninstall packages that are important for other ones.

This is good behavior because you won't get a chain of removals that break your desktop but sometimes it stops you from doing what you want. Anyway, the simple solution is to uninstall bbswitch yourself.

sudo pacman -Rn linux4XX-bbwsitch

where you replace XX with the appropriate numbers of your installed kernels. If you have more kernels, repeat it for them too. Once you've done it, do again:

sudo mhwd -r pci video-hybrid-intel-nvidia-bumblebee

It should install bbswitch packages again with the drivers. Do the rest of the previously given commands.

Get yourself familar with a pacman:

https://wiki.manjaro.org/index.php?title=Pacman_Tips

Or instead removing anything, you can just reinstall. I'm not sure if reinstall will fix any configs but you can try it before removing anything:

sudo mhwd -f -i pci video-hybrid-intel-nvidia-bumblebee

1 Like

@michaldybczak still on intel (try with new optimus-manager update). none conf file after switch to nvidia /etc/X11/xorg.conf.d/10-optimus-manager.conf

still i don’t have conf file when switching to nvidia.

[fla@fla-pc ~]$ journalctl -u optimus-manager.service
-- Logs begin at Mon 2019-01-07 00:51:14 +0330, end at Thu 2019-01-10 03:57:00 >
Jan 07 01:27:11 fla-pc systemd[1]: Started Optimus Manager Commands Daemon.
Jan 07 01:27:13 fla-pc python[1260]: Optimus Manager (Daemon) version 0.6
Jan 07 01:27:13 fla-pc python[1260]: Awaiting commands
Jan 07 01:28:03 fla-pc python[1260]: Received command : startup_intel
Jan 07 01:28:29 fla-pc systemd[1]: Stopping Optimus Manager Commands Daemon...
Jan 07 01:28:30 fla-pc python[1260]: Process stop requested
Jan 07 01:28:30 fla-pc python[1260]: Closing and removing the socket...
Jan 07 01:28:30 fla-pc python[1260]: Goodbye !
Jan 07 01:28:29 fla-pc systemd[1]: Stopped Optimus Manager Commands Daemon.
-- Reboot --
Jan 07 01:29:01 fla-pc systemd[1]: Started Optimus Manager Commands Daemon.
Jan 07 01:29:09 fla-pc python[514]: Optimus Manager (Daemon) version 0.6
Jan 07 01:29:09 fla-pc python[514]: Awaiting commands
Jan 07 01:31:35 fla-pc python[514]: Received command : nvidia
Jan 07 01:31:35 fla-pc python[514]: Writing requested mode
Jan 07 01:31:35 fla-pc python[514]: Restarting login manager
Jan 07 01:34:06 fla-pc python[514]: Received command : intel
Jan 07 01:34:06 fla-pc python[514]: Writing requested mode
Jan 07 01:34:06 fla-pc python[514]: Restarting login manager
Jan 07 01:35:49 fla-pc python[514]: Received command : startup_nvidia
Jan 07 01:36:00 fla-pc python[514]: Process stop requested
Jan 07 01:36:00 fla-pc python[514]: Closing and removing the socket...

[fla@fla-pc ~]$

dmesg error


[    0.405785] ACPI Error: No handler for Region [EC__] (0000000003874466) [EmbeddedControl] (20180810/evregion-132)
[    0.405788] ACPI Error: Region EmbeddedControl (ID=3) has no handler (20180810/exfldio-265)
[    0.405792] ACPI Error: Method parse/execution failed \_SB.PCI0.LPCB.EC._REG, AE_NOT_EXIST (20180810/psparse-516)
[   18.130591] ACPI BIOS Error (bug): Could not resolve [\_SB.PCI0.GFX0.DD02._BCL], AE_NOT_FOUND (20180810/psargs-330)
[   18.130596] ACPI Error: Method parse/execution failed \_SB.PCI0.PEG0.PEGP.DD02._BCL, AE_NOT_FOUND (20180810/psparse-516)

should i test another kernel version? (i have 4.19.13-1)

I have tried fixing this in on clean installs of manjaro xcfe, and kde. I have requested assistance in the forums. I came to manjaro when OpenSuse Tumbleweed updates started breaking optimus. For a while Manjaro was good. Now, like Suse, maybe the "stable" updates got ambitious. But since this is broken on multiple clean manjaro installs on different wm, and since the hardware is working fine in windows, and the "add yourself to the group," advice has not helped on any recent install.... maybe it's time to try Solus. Thanks Manjaro, it was great for a couple years. :frowning:

optimus-manager is:

Very much pre-release and under rapid development

the same issue but it fixed for him https://github.com/Askannz/optimus-manager/issues/39

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by