After installing in dual boot configuration, computer always boots to Windows

So, I recently reinstalled Windows 10 and then went to install Manjaro on top of that. During the install of Manjaro, I set the 100MB FAT32 partition to mount at /boot/efi/ and to carry the boot and efi flags (without formatting it).

I also created an ext4 partition to mount at '/' and a swap partition, and completed the Manjaro install.

After rebooting, the computer boots directly into Windows 10, not Manjaro. I tried repeating the process a second time and got the same result. I can't think of what could possibly cause this?

this maybe of help... At least a bump. :wink:


check your bios settings for hdd boot order select manjaro there.
make sure secure boot is disabled.

you have to create entry boot EFI


In these kinds of cases defenestration is recommended. :smile:

have you tried booting into manjaro then in terminal sudo update-grub

I'm trying to follow this, but I'm still stumped. When I tried to follow the guide linked to here, a basic requirement is to be able to boot into Manjaro using a guide that they linked to, but that guide makes no such reference as far as I can see.

I don't understand how I'm supposed to boot into Manjaro on the NVMe to be able to execute the commands in this thread.

My biggest immediate challenge is I'm actually not sure how to boot into the Manjaro partition to begin troubleshooting this.

Finally got it!!!

To be able to do the steps in this tutorial, I simply booted to a Manjaro USB and selected the "Detect EFI Bootloaders" options and used this tool to boot into Manjaro.

This is not a good solution. Can you recheck the link given by kmartin above in post 2 and if that cannot solve it, see the section on [Difficult UEFI setups]. First do the [2 addtional uefi commands]. If you need help, provide the info required in the [If problem persists] section. Tell us computer make and model.

You can boot up using your way or the link way. As long as it boots, it doesn't matter. But you should really fix this.

please lauch with USB install
select your boot disk
open a terminal
sudo efibootmgr

@stephane @gohlip

I think you have both misunderstood what I was saying. I used the Live USB to get into Manjaro so that I coukd follow the steps that @gohlip outlined in the post @stephane linked to. Please see that thread for the solution I used.

sudo grub-install
sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi
sudo efibootmgr -c -d /dev/nvme0n1 -p 2 -L "manjaro" -l "\EFI\Manjaro\grubx64.efi

note: I used 2 instead of 1 in the third command because this is the number of my efi partition. please see that thread for more details.

Okay. Now you can boot into Manjaro without using install media?
We thought you need to use “Detect EFI Bootloaders” options to boot into it and that was the solution.
Take care.


Correct. The disconnect I was having in this thread was I couldn't figure out how to get into the installed partition of Manjaro to execute the commands you had given in that thread to install grub. All good now. Thank you so much for your help.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by