After installing Manjaro Kde at start wont recognize grub

I need a laptop for my studies and i fixed my sister's old laptop. I want to install Manjaro Kde on it but after i complete the installation and i do a restart it shows me this errors:

Boot Failed. P1-Samsung SSD 850 EVO 250GB

And on the next screen it show me those errors:

Boot Failed. P4-HL-DT-STDVDRAM GT30N
Boot Failed. FDD

And it like there is nothing bootable on the drive and skips it. I was search if anyone have something like my problem on the web but nothing helped. The only way to boot to the OS is using this code i found from the usb i burned Manjaro on:

grub> search.file /etc/manjaro-release root
grub> configfile /boot/grub/grub.cfg
grub> boot

This problem only happen with Manjaro Linux. I had installed Windows 10, after i installed Ubuntu and now i want to install Manjaro Kde. Can anyone help me (Sorry for my bad English)?

Welcome :slight_smile:
Only Manjaro grub can boot Manjaro and other OS, try changeroot
and install grub (or vanilla-grub).

Thank you for the fast response. I tried the second option but it didnt fixed my problem. The first link doesnt help because the errors are not from the grub but from my bios at the start. Its like there is nothing bootable on my ssd. I had a similar problem when i was trying to boot to my usb when i was trying to install windows. And the problem was that i forgot to change the option GPT to MBR because i have a Bios system not UEFI. When i installed Manjaro i selected the MBR bootloader option.

You need to start from your BIOS settings.
Secure Boot > Off
Disks mode > AHCI

Ahhh! With GPT in MSDOS/Legacy system you need a small unformated partition at the start of the drive. Check (and post) with

sudo parted -l
lsblk -f
1 Like

I have a Legacy system i dont have the option to disable secure boot. How many megabytes this partition need to be? When i create this partition i have to install grub on this partition?

At least 1Mb.

On BIOS Legacy systems you install to the drive, not the partition.
Read more.

1 Like

When creating a BIOS Boot Partition on a GPT system, you should make sure that it is at least 31 KiB in size. (GPT-formatted disks are not usually particularly small, so we recommend that you make it larger than the bare minimum, such as 1 MiB, to allow plenty of room for growth.) You must also make sure that it has the proper partition type.
source: https://www.gnu.org/software/grub/manual/grub/html_node/BIOS-installation.html

Use Gparted to create this partition at the beginning of your disk and flag it as bios_grub.

Edit: @AgentS beat me to it!

1 Like

So in /dev/sda like is selected on mbr option. So is correct the location of my gurb. Is not the location the problem then?

So /dev/sda (the drive) would be the right location for the installation of the grub.

Then is not the location the problem of those errors but something else. I was searching for days but no one else have this kind of problem only 1-2 people that forgot to select uefi option in the bios for dual boot.

Please post the output of

sudo parted -l

and

lsblk -f

asked by @AgentS above.

1 Like

Post

and

inxi -Fxxxza --no-host

Maybe you start with some answers? :wink:

Most of the time (Self Solvers) is a reinstall with correct settings :smiley:

1 Like

I will post them as soon as possible. I will post the in 2 hours because i am in a lecture. Thank you for your response @SGS , @Marte.

Before you add this bios_grub partition, provide from manjaro OS


sudo parted -l
sudo blkid
cat /etc/fstab
efibootmgr -v

Confirm you have windows in your system (You said you "had installed Windows 10, after i installed Ubuntu") and confirm windows is booting okay. If you can boot to windows, use this link and tell us if windows is in uefi or in bios-legacy.

Where's the output of 'parted -l' that was asked of you to provide?
We cannot proceed without knowing the full facts.
And I am asking you to provide more than 'parted -l'.

If your windows is in gpt/uefi and you put in that bios_grub partition, your windows may not boot as it may think it is now in msdos partitioning. And your manjaro trashed as well.

notes: if msdos, use bios-legacy (all people, including experts)
If gpt, use uefi (experts excepted, ordinary people beware of situations like this - I'd suggest experts follow this rule as well, 2TB only exception)

1 Like

For sudo parted -l:

Model: ATA Samsung SSD 850 (scsi)
Disk /dev/sda: 250GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:
Number Start End Size Type File system Flags
1 1049kB 250GB 250GB primary ext4

For lsblk -f:

NAME FSTYPE LABEL UUID FSAVAIL FSUSE% MOUNTPOINT
sda
└─sda1
ext4 9a61111b-1a66-4892-825c-f89780a6c550 209,6G 3% /
sr0

For inxi -Fxxxza --no-host:

System:
Kernel: 5.2.11-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.1.0
parameters: BOOT_IMAGE=/boot/vmlinuz-5.2-x86_64
root=UUID=9a61111b-1a66-4892-825c-f89780a6c550 rw quiet apparmor=1
security=apparmor udev.log_priority=3
Desktop: KDE Plasma 5.16.4 tk: Qt 5.13.0 wm: kwin_x11 dm: SDDM
Distro: Manjaro Linux
Machine:
Type: Laptop System: TOSHIBA product: Satellite L670 v: PSK3EE-00500YG5
serial: Chassis: type: 9 serial:
Mobo: TOSHIBA model: NALAA v: 1.00 serial:
UEFI [Legacy]: TOSHIBA v: 2.30 date: 08/02/11
CPU:
Topology: Dual Core model: Intel Core i5 M 430 bits: 64 type: MT MCP
arch: Nehalem family: 6 model-id: 25 (37) stepping: 2 microcode: 11
L2 cache: 3072 KiB
flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 18096
Speed: 1463 MHz min/max: 1199/2267 MHz boost: enabled
Core speeds (MHz): 1: 1463 2: 1463 3: 1463 4: 1463
Vulnerabilities: Type: l1tf mitigation: PTE Inversion
Type: mds status: Vulnerable: Clear CPU buffers attempted, no
microcode; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
IBRS_FW, STIBP: conditional, RSB filling
Graphics:
Device-1: AMD Madison [Mobility Radeon HD 5650/5750 / 6530M/6550M]
vendor: Toshiba America Info Systems driver: radeon v: kernel
bus ID: 01:00.0 chip ID: 1002:68c1
Display: x11 server: X.Org 1.20.5 driver: radeon FAILED: ati
unloaded: modesetting alternate: fbdev,vesa compositor: kwin_x11
resolution: 1600x900~60Hz
OpenGL:
renderer: AMD REDWOOD (DRM 2.50.0 / 5.2.11-1-MANJARO LLVM 8.0.1)
v: 3.3 Mesa 19.1.5 compat-v: 3.1 direct render: Yes
Audio:
Device-1: Intel 5 Series/3400 Series High Definition Audio
vendor: Toshiba America Info Systems driver: snd_hda_intel v: kernel
bus ID: 00:1b.0 chip ID: 8086:3b56
Device-2: AMD Redwood HDMI Audio [Radeon HD 5000 Series]
vendor: Toshiba America Info Systems driver: snd_hda_intel v: kernel
bus ID: 01:00.1 chip ID: 1002:aa60
Sound Server: ALSA v: k5.2.11-1-MANJARO
Network:
Device-1: Realtek RTL810xE PCI Express Fast Ethernet
vendor: Toshiba America Info Systems driver: r8169 v: kernel port: 3000
bus ID: 02:00.0 chip ID: 10ec:8136
IF: enp2s0 state: down mac:
Device-2: Broadcom and subsidiaries BCM4313 802.11bgn Wireless Network
Adapter
vendor: Askey driver: wl v: kernel port: 3000 bus ID: 07:00.0
chip ID: 14e4:4727
IF: wlp7s0 state: up mac:
Drives:
Local Storage: total: 232.89 GiB used: 7.01 GiB (3.0%)
ID-1: /dev/sda vendor: Samsung model: SSD 850 EVO 250GB
size: 232.89 GiB block size: physical: 512 B logical: 512 B
speed: 3.0 Gb/s serial: rev: 2B6Q scheme: MBR
Partition:
ID-1: / raw size: 232.88 GiB size: 228.23 GiB (98.00%)
used: 7.01 GiB (3.1%) fs: ext4 dev: /dev/sda1
Sensors:
System Temperatures: cpu: 54.0 C mobo: N/A gpu: radeon temp: 55 C
Fan Speeds (RPM): N/A
Info:
Processes: 203 Uptime: 4m Memory: 3.71 GiB used: 980.5 MiB (25.8%)
Init: systemd v: 242 Compilers: gcc: 9.1.0 Shell: bash v: 5.0.9
running in: konsole inxi: 3.0.36

My laptop use bios-legacy. Is separate partition needed for uefi only? Or bios-legacy need separate partition too?

Your disk is msdos, so why are we adding a bios_grub partition?
And are you providing the info?
You want us to tell you waht to do without having the full facts?

Where''s the windows partition?
sudo parted -l
All disks, all partitions, do not omit : do not truncate.
Sheesh... what's with 'parted -l' that people need to hide?

1 Like

I use to have windows but i erase everything from the drive because i want to leave only linux on it. I wouldn't create the extra partition as we discussed with @AgentS and @Marte.

I guess this statement

gave rise to the confusion and thereby the suggestion for adding a bios_grub partition.

Yes but on that statement i tried to explain that the problem i have is similar with my previous problem when i didnt change the option GPT to MBR in rufus. I forgot to say that the options was for rufus and i made this confusion?

1 Like

Forum kindly sponsored by