After installing Manjaro Kde at start wont recognize grub

I use to have windows but i erase everything from the drive because i want to leave only linux on it. I wouldn't create the extra partition as we discussed with @AgentS and @Marte.

I guess this statement

gave rise to the confusion and thereby the suggestion for adding a bios_grub partition.

Yes but on that statement i tried to explain that the problem i have is similar with my previous problem when i didnt change the option GPT to MBR in rufus. I forgot to say that the options was for rufus and i made this confusion?

1 Like

Thanks for the further explanation. It's good that it is cleared out.

Ok, just back again.
Now, can you boot manjaro okay?
It's the only OS.

You don't see grub menu?, is that it?
And you want to see the grub menu?
What's ?
pacman -Q grub

1 Like

I did a clean install the Manjaro Kde. Yes is the only OS. The way to boot to the OS is with your guide here (Using livecd v17.0.1 (and above) as grub to boot OS with broken bootloader) from a liveusb. I enter
-search.file /etc/manjaro-release root
-configfile /boot/grub/grub.cfg
and it boot only with this way

Writing separately, if you have problem where you cannot boot except using the confilgfile method as said in first post, the method in the second link mentioned should work.

Just be careful you check which is the drive. Not the install media drive when you do the grub-install command.

PS: typing from phone, cannot show that second link.

1 Like

Ok, clear.
Check the drive when booted up by
findmnt /

It shows either /dev/sda1 or /dev/sdb1

Then do either
sudo grub-install /dev/sda
OR
sudo grub-install /dev/sdb

Clear? I hope.

No spaces grub-install. And. /dev/sdb
Not /dev/sda1 not /dev/sdb1
Just /dev/sda or / dev/sdb

1 Like

I tried. It says Installing for i386-pc platform. Installation finished. No error reported. But i restart and nothing change. Is still show me these errors. IMG_20190927_182841 IMG_20190927_183029__01

Check out a few things.

  1. Remove install media when booting up.
  2. Check you bios-setup (F2 as mentioned)
    A few things here.
    a. boot set to bios-legacy only. if there is a priority setup instead, make it bios-legacy first.
    b. uhm.. other things peculiar to manufacturer, like security...etc.
  3. If 1. and 2. above are sure, repeat the process (configfile) again.
    Before doing grub-install commands, check at terminal
    test -d /sys/firmware/efi && echo UEFI || echo BIOS
    type this command carefully, print out for us this command
    There's a false negative if command has typo.
    output must show 'BIOS', if it shows 'UEFI' you have done grub-install in uefi.
    Reboot (meaning start up) install media again in bios-legacy, use the
    'grub> echo $grub_platform' to confirm you are in bios-legacy (output only 'pc')
    I remember you said your system cannot have uefi; confirm that with this grub prompt command.

Oh.. If error or other things, PRINT out commands and error messages.
Your interpretation may be uhm.. wrong. (saying as is, not being rude or condescending).

Try again.

Your 2 different screen shots shows 2 different devices booting up.
Are you having another internal disk other than sda?

1 Like

Fine turnaround!:rofl:

With MBR disk (only one) Manjaro would not be on UEFI.
If Samsung in the image is the one only disk, Houston... we have a problem!
Have you checked AHCI in BIOS?
Is the disk 1st in boot order?

Use the force. (in grub-install command).
Check man grub-install.

If it doesn't help, you may need to wipe MBR with dd. @tbg likes this part...

3 Likes

Oh ya, I love nuking sh*t. That way the partition tables can't come back to haunt you if you ever need to attempt a data recovery.

1 Like

He may have booted up in uefi (configfile).
We can boot up a bios-legacy (linux) OS using a uefi grub.

As you know 'grub-install /dev/sdx' must be to the primary drive and primary drive only.
Of course, having just one disk makes that most likely the primary drive.
Unless he has more than than 1 internal drive
(and not booting up with the usb attached - which many bios prioritizes usb boots over disk boots).
It is also possible that while having only one drive, that drive is not set to the primary (master not slave) sata port. That is rare but could happen, especially if the user changes disks as often as he change underwear.

And another possibility is he did not set a new disk partitioning table and a setting boot flag should do the trick.

And its been some time we have this type of 'brainstorming'.
Don't like this Agent S, what have you done to my partner petsam? :joy:

1 Like

Hey, look who's here.
The chairman of the "Red Scare committee to banish Triple Boots and Windows from Linux Computers".

Just like Microsoft trying to banish other OS's from the computers we own.
License my foot. We own the computer. We don't license or rent the computers.
Certainly not from Microsoft.

Behaving like people we admonish is... uhm
. LOL. :laughing:

C'mon @gohlip, I know you spend all your spare time tending to your buddy Bill G's lawns and shrubbery.

He saw the (forgetting) light (stick)!

The user had bad luck AND confused us (unwillingly of course).
We have partial info, so we need to draw out info forcefully. Will he comply? I don't want to try...

I don't know what you imply and I don't know this. You install on a drive.
The Primation is set in BIOS, unless its a 30y old piece. Laptop? 40years.

Magic words!
If during installation there was another drive and used that (installer magic gui) and then removed...
But a new grub-install should have succeeded.
Do you remember the "force" params, or we use dd?


Behave guys! :worried:

I tried everything that you said but nothing helped. The terminal command show me BIOS and the other command pc. Does it matter if i install the OS from the installer or from the Architect? I am trying to install Manjaro Kde 17.1 because i read that someone had a problem with 18 and installed 17 and update to the latest. The second driver is the dvd driver

@marios096

Noted, and understand. If you have confirmed, will be good too if you acknowledge the things we raised.
Like there is only one internal disk and it is connected to the primary sata port (sata0) ...etc...

Add one more command

sudo parted /dev/sda set 1 boot on
2 Likes

Hey! Where's petsam? He won't be asking this. :laughing:
Say you have 3 internal drives. (bios-legacy/msdos situation)
Of course you can set each OS in each drive to their own disk mbr.
But to boot, you will need to go to bios and select that drive to boot.
But if you set all OS's to only the primary drive, you won't need to go to the bios to select drives for booting. And if you select a non-primary drive to set the mbr to, that won't work.
What so strange about this?

So if the OP set mbr not to the primary drive, he will have problem booting.
If you check my past several replies to others, I often tell them to
sudo grub-install /dev/sda
sudo grub-install /dev/sdb
all the way to /dev/sdz if they have many disks and are confused what is the primary drive.

image8960 g10985

1 Like

Forum kindly sponsored by