After suspend my system and especially chrome is laggy or not responding


I got Manjaro 16.10 with kernel 4.4.45-1 and xfce installed on a thinkpad x220.

The system works fast and everything is fine, but as soon i wake up the notebook from suspend, the whole system is laggy and not responding properly.

scrolling is hard and xfce4-applicationsmenu takes long to open. also sometimes chrome is not responding anymore. it is then minimized to the panel bar and i can not open/maximize it.
i tried everything google was asking me to do, but nothing worked for me.
after restarting the system everything is fine again, but i would like to use suspend sometimes :wink:

i also wanted to remove hibernate from my system. how can i do that? is there a terminal command?

please let me know if you have any ideas and tell me if you need more information about hard-/software i am using.


I have the same issue and couldnt find any solution that helps. I use the latest Manjaro with kernel 4.8 on my x220.
I cant close the display lid and if the system is in suspendmode I have to reboot it, so I have to open everything again.


Have either of you tried other kernels ? 4.1 or 4.9 ?

in addition to switching kernels, these are some troubleshooting basics applicable in most cases

then you better undo those changes before getting started :thumbsup: This wiki article, with some links at the bottom, is a good starting point

We will be needing your system specs. Follow this thread

When that happens, open terminal and run the following

dmesg > dmesg.txt
journalctl -b -p 5 > toomuchlog.txt

By default these txt files are create in your $HOME directory. Share their contents within codebox like so


Also check temperature. Follow this article to know how

Check CPU and RAM usage using top, htop or any system-monitor app. Are there any process(es) eating up your resources ?

1 Like

For default (systemd) editions

systemctl hibernate

but there's more to it than just a command.

These are secondary problems, we can handle these later in a separate thread or IRC channel.

1 Like

Thank you for your replz badbodh!

here is my inxi -Fxzc0 output:

System:    Host: HerrDr-TP Kernel: 4.4.45-1-MANJARO x86_64 (64 bit gcc: 6.3.1)
           Desktop: Xfce 4.12.3 (Gtk 2.24.31) Distro: Manjaro Linux
Machine:   Device: laptop System: LENOVO product: 4291QR8 v: ThinkPad X220
           Mobo: LENOVO model: 4291QR8
           UEFI [Legacy]: LENOVO v: 8DET56WW (1.26 ) date: 12/01/2011
Battery    BAT0: charge: 45.5 Wh 96.7% condition: 47.0/78.0 Wh (60%)
           model: LGC 42T4942 status: Discharging
CPU:       Dual core Intel Core i5-2520M (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 9971
           clock speeds: max: 3200 MHz 1: 800 MHz 2: 800 MHz 3: 813 MHz
           4: 809 MHz
Graphics:  Card: Intel 2nd Generation Core Processor Family Integrated Graphics Controller
           bus-ID: 00:02.0
           Display Server: X.Org 1.19.1 driver: intel
           Resolution: 1366x768@60.02hz
           GLX Renderer: Mesa DRI Intel Sandybridge Mobile
           GLX Version: 3.0 Mesa 13.0.3 Direct Rendering: Yes
Audio:     Card Intel 6 Series/C200 Series Family High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.4.45-1-MANJARO
Network:   Card-1: Intel 82579LM Gigabit Network Connection
           driver: e1000e v: 3.2.6-k port: 5080 bus-ID: 00:19.0
           IF: enp0s25 state: down mac: <filter>
           Card-2: Intel Centrino Advanced-N 6205 [Taylor Peak]
           driver: iwlwifi bus-ID: 03:00.0
           IF: wlp3s0 state: up mac: <filter>
Drives:    HDD Total Size: 248.1GB (18.6% used)
           ID-1: /dev/sdb model: OCZ size: 120.0GB
           ID-2: /dev/sda model: M4 size: 128.0GB
Partition: ID-1: / size: 110G used: 36G (35%) fs: ext4 dev: /dev/dm-0
           ID-2: /boot size: 247M used: 136M (59%) fs: ext2 dev: /dev/sda1
           ID-3: swap-1 size: 8.25GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
Sensors:   System Temperatures: cpu: 41.0C mobo: N/A
           Fan Speeds (in rpm): cpu: 1956
Info:      Processes: 206 Uptime: 1 min Memory: 909.3/7871.3MB
           Init: systemd Gcc sys: 6.3.1
           Client: Shell (bash 4.4.111) inxi: 2.3.8

i monitored my device frequently with htop and sensors, but i can't see any problem. ram and cpu, discusage, ... all is low and normal.

i will post dmesg and journalctl as soon i have the problem again :wink:

ty for your help!

since the text files contain more characters than i can upload within a forum post, i have chosen to use pastebin.

here is my dmesg

and my journalctl

great. Easy things first, change kernels as suggested, see what happens. Instructions here

Meanwhile let somebody go through your logs and figure out stuff.

i have updated now to the latest LTS 4.9, but the problem still exists...

looks like you got no hibernate to begin with

[    1.254090] PM: Hibernation image not present or could not be loaded.

As for your lagginess issue, try playing with your swappiness. Cautions and disclaimers applicable.

Some general tips

As you can see they are archwiki links, manjaro is arch-based but not a byte-to-byte copy of arch. So there may be minute differences, or none at all. Always backup your data before playing with fire :grin:

i'm facing some glitches on kernel 4.9 myself. Do try 4.1 or older, or revert back to 4.4 before experimenting

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by