after update, double click on files (dolphin) doesn't work

Hi All

This is not the first time it's happening and I looked for a solution but didn't find one.
After full system update/upgrade, double click on files (dolphin) doesn't work.

For example:
click on mp3 files (dolphin) - VLC doesn't open automatically
click on pdf files (dolphin) - Okular doesn't open automatically
click on docx files (dolphin) - LibreOffice Writer doesn't open automatically
click on text files (dolphin) - I get error message: KDEInit could not launch '/usr/bin/kate'

FYI, All programs works from KDE Application Launcher

So, in order to open a text file, I need to launch kate from KDE Application Launcher
and drag-and-drop my text file to it.
It is really not convenient

Tried to reinstall dolphin - didn't work
Please help

$ inxi -F
Kernel: 4.14.130-1-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.16.2

Right click an mp3/pdf/doc etc....

Properties - see what is set to open each file type and change/move up.

KDE update - a lot of settings where reset, you will need to go in and check them.

I am not in KDE ATM, so can't check where.

Hello,

This may help: [Stable Update] 2019-07-03 - Kernels, Systemd, Pamac 8.0, KDE, XFCE, Browser, QT

Not working.
Even when right click on (for example) PDF file and choose "open with Okular"
Okular doesn't start.
And for mp3 - VLC doesn't open

no issue related to my problem

Hi
Found this issue:

sudo mv /usr/share/applications/mimeinfo.cache /tmp/
mv ~/.config/mimeapps.list /tmp/
reboot

All files can be opened with double-click from dolphin - problem solved!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by