After update minute ago can't enter desktop, system can't find tty

He all and sorry for disturb. Have big problem and need urgent help. Updated my system minute ago and it stuck. My mouse and keyboard are not working, out of power and can't do a thing. This is what I get IMG_20180609_210749

Oh, is good that you edited the post, as i was ready to make a joke :slight_smile:
But here is the solution:

I managed to fix the issue we had with linux49. Fixed package is uploaded to our testing branch.

2 Likes

Tnx a lot... I'll try something to do... But I'm very fresh to Linux and have a lot to learn. Everything worked super after this update and I'm in fear

Tnx a lot… I’ll try something to do… But I’m very fresh to Linux and have a lot to learn. Everything worked super after this update and I’m in fear

Why are you in fear. Greg simply forgot some to port back to an older kernel. Most people who are using Manjaro have multiple kernels installed anyway. And if you break your system, there is always a fix.

I don't know much about commands and fixes. Maybe the easy way for me is to reinstall whole system and start installing all from beginning. Uff it's a lot of work. Lucky me I have dual boot and win 7 to download Manjaro again. Tnx and I'm so sorry to disturb

Hi! Sorry to bother you…I am verz new and fresh to linux. I have tried all written here and I cant do a thing. When I write sudo mount /dev/8333602b-51a3-49d3-9cf3-9bf9af58811f/ mnt and i got this mount: mnt: mount point does not exist.
when I open Home folder on desktop on live USB and click on file system I see a path run/media/manjaro/8333602b-51a3-49d3-9cf3-9bf9af58811f and here I can see my home folder and all files in it.
When I try pacman -U /var/cache/pacman/pkg/linux49-4.9.105-1-x86_64.pkg.tar.xz noting happens…i opened that path and there is no file named linux49-4.9.105-1-x86_64.pkg.tar.xz and I did not cleaned cache in months.
Please help…some guidance… I really want to avoid to reinstall whole manjaro again and games and 32lib and all… :frowning:
When I try to mount my sdb3 partition I get this:
sudo mount /dev/sdb3/mnt
mount: /dev/sdb3/mnt: can't find in /etc/fstab.

mount /dev/8333602b-51a3-49d3-9cf3-9bf9af58811f /mnt

sudo mount /dev/sdb3 /mnt

The target directory is /mnt so write that. Also make sure there is space between what you want to mount and where you want to mount it.

There are two parts to fixing your system.

Firstly (assuming you have only the one kernel) you will need to boot to a live environment and then chroot to your real system. See here: https://archived.forum.manjaro.org/t/cant-login-black-screen-chroot-guide/21166/1 Option 3 is the easiest.

Secondly now that a fixed kernel is in the repository simply run an update as usual
sudo pacman-mirrors -f
sudo pacman -Syyu
And you should be good to reboot.

As an extra precaution installing a second kernel, maybe 4.14LTS gives the option to boot that, either now or in the future, if 4.9 does not work.

Keep calm, you will get back your system. :smile:

1 Like

Something is hapening...I folowed step 3 and its updating...now we wait. :smiley:

It worked..it worked. I can't thank you enough for helping me out. Im so sorry to bother you, all of you, whit this problem. Everithing is back...I realy tought that ill have to reinstall everything. You are a life saver. THANK YOOOUU SO MUUUCH!!!
Can you direct me to where can I learn all of command and they meaning in linux system? I don't want to stuck like this again.
I just install the second kernel and how do I switch?

TNX

2 Likes

You're welcome, but the real work was done by Philm, and Greg, and others. :wink:

I don't know that much about linux myself but what little I have learned comes mainly from:
https://wiki.manjaro.org/index.php/Main_Page
https://wiki.archlinux.org/
Plus reading the Announcements threads (Stable, in your case) and the forum more generally.

Many people recommend reading the manuals for various commands/applications e.g. man pacman-mirrors but personally this sends me to sleep (but don't tell anyone, they will make fun of me :shushing_face:). That is, until I have a problem to solve then they suddenly become useful.

Internet search is also a wonderful thing.

Glad that you have a working system. Enjoy. :smile_cat:

And big tnx go to all of them, Greg, Philm and all other kind people who helped and helping to all of us. I love Manjaro Linux and you all, you are GREAT. Hope to learn much and fast so that I can realy help others...
Cheers and love from Croatia :smiley:

This...this, more than anything, is why I love Linux newcomers. :smiley:

'Keep On Learnin' :smiley:

When you boot up and see Manjaro to log to, there is (lower) something like advanced options or similar, move with arrows there and enter and you will see other kernel(s). Btw, as beginner I suggest you stick with LTS (Long Term Support) versions and not with the latest. Well at least that's what I do, just to be on a safe side :wink:

1 Like

Tnx for the tip :smiley:
I am running LTS 4.9.107-2 (Linux49) but now I see there is two more...LTS real time (Linux 4.14-rt) and 4.14.48-2 recommended (Linux4.14).
Wich one to use or is it all the same?

For normal use 4.14.48-2 is recommended. (Linux414 rather than Linux414-rt, more generally.)

The real time kernel (-rt) is useful for activities such as audio recording that have specialised demands. See here https://wiki.archlinux.org/index.php/Realtime_kernel for a more technical description (that mainly passes well over my head :blush:).

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by