after updating kernel to 5.4-rt-x86_64 the GRUB2 configuration didn't get updated


I need to find what initramfs version I need to run. After editing the GRUB2 menu configuration using its minimal EMacs editor, I got the LINUX /boot/linuz-5.4-rt-x86_64 ... stuff to boot but the RAM-FS can't be found either. I don't see it in the SSD's /boot directory from my Debian platter-drive install either. Please advise.

My system has been updated just this morning 2020-02-17 and all packages are up-to-date otherwise. The warning was that my old kernel was no longer supported and I needed to update to a newer kernel. It worked great until I tried to reboot after switching to my Debian boot which is still recognized properly by GRUB2.

My system specifications are a 2nd generation i7 with 16 Gigs of DDR3.

Going the wrong way.... (edited /boot/linuz(?)-5.4, probably /boot/grub/ (?) etc..)

the easy way:

manjaro settings manager > uninstall kernel 5.4 rt > and installed again

Everything should work just fine.

Note: if you have more kernels ex 5.5 you must select (when booting on grub) the kernel to boot, with

[Esc] > Options > kernel of your choice, like kernel 5.4rt

If something with manjaro-settings-manager didn't go well (don't think so)
you can run

sudo mkinitcpio -p

(for all installed kernels) or

sudo mkinitcpio -p linux54rt

(only for selected kernel)

sudo update-grub and reboot

If you need to edit something for grub you do it by editing /etc/default/grub (as root) and not direct to /boot like you did, and then again

sudo update-grub and reboot

Anyway if you still want to do it you way (?) then your initramfs would be on /boot with name initramfs-5.4rt-x86_64.img
If I understand correctly you have more linux distros, so be careful when update grub in either distro that can see the other distro (meaning that if you are on manjaro and your debian partition is encrypted you must first mount it).
If you still have a problem post more info like result for commands

fdisk -l
cat /etc/default/grub
sudo cat /boot/grub/grub.cfg
ls -l /boot

also post the current state, can you boot to linux (manjaro or debian) or usb-stick or installation-media or you are stuck at grub?

Welcome to Manjaro forum!! (this should be the first :slight_smile: , but i read your post, just before going to bed...)

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by