After upgrading kernel driver (Linux 4.14.81-1 to 4.19.2-1) Freeze or Stuck System

After upgrading kernel driver(Linux 4.14.81-1 to 4.19.2-1) System stucks or freeze for a second in every 10 second gap.

Open Terminal/Konsole




see what happen .

This doesn't provide enough information to help diagnose the issue.

Try a live installer environment and see if the issue persists. If it does, it's hardware-related. If it doesn't, it's something you have changed since installation.


Seriously, that's the sum total of the info you post, then you immediately log off and expect someone is supposed to fix you up. Please give full background information leading up to this issue. Such as, is this a new install, did this happen after a system upgrade, kernel upgrade, etc, etc.

Information on how to post hardware specs and logs on the forum:

inxi -Fxxxz

  Host: akhilesh Kernel: 4.19.2-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 8.2.1 Desktop: N/A wm: xfwm4 dm: LightDM 1.28.0 Distro: Manjaro Linux 
  Type: Laptop System: HP product: HP Notebook v: Type1ProductConfigId 
  serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: HP model: 81EC v: 61.41 serial: <filter> UEFI [Legacy]: Insyde 
  v: F.24 date: 01/05/2017 
  ID-1: BAT1 charge: 12.9 Wh condition: 38.2/41.6 Wh (92%) volts: 14.2/14.6 
  model: Hewlett-Packard PABAS0241231 type: Li-ion serial: <filter> 
  status: Discharging 
  Topology: Dual Core model: Intel Core i5-6200U bits: 64 type: MT MCP 
  arch: Skylake rev: 3 L2 cache: 3072 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19204 
  Speed: 800 MHz min/max: 400/2800 MHz Core speeds (MHz): 1: 800 2: 800 
  3: 801 4: 800 
  Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Hewlett-Packard 
  driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:1916 
  Device-2: AMD Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330 / M430 / R7 
  vendor: Hewlett-Packard driver: radeon v: kernel bus ID: 01:00.0 
  chip ID: 1002:6660 
  Display: x11 server: X.Org 1.20.3 driver: ati,intel,radeon 
  unloaded: modesetting alternate: fbdev,vesa resolution: 1920x1080~60Hz 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 520 (Skylake GT2) 
  v: 4.5 Mesa 18.2.5 compat-v: 3.0 direct render: Yes 
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:9d70 
  Sound Server: ALSA v: k4.19.2-1-MANJARO 
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet 
  vendor: Hewlett-Packard driver: r8169 v: kernel port: 4000 bus ID: 02:00.0 
  chip ID: 10ec:8136 
  IF: enp2s0 state: down mac: <filter> 
  Device-2: Realtek RTL8723BE PCIe Wireless Network Adapter 
  vendor: Hewlett-Packard driver: rtl8723be v: kernel port: 3000 
  bus ID: 03:00.0 chip ID: 10ec:b723 
  IF: wlo1 state: up mac: <filter> 
  Local Storage: total: 931.51 GiB used: 34.80 GiB (3.7%) 
  ID-1: /dev/sda vendor: Toshiba model: MQ01ABD100 size: 931.51 GiB 
  speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: 4C scheme: MBR 
  ID-1: / size: 907.23 GiB used: 34.80 GiB (3.8%) fs: ext4 dev: /dev/sda1 
  ID-2: swap-1 size: 8.80 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda2 
  System Temperatures: cpu: 39.0 C mobo: N/A gpu: radeon temp: 36 C 
  Fan Speeds (RPM): N/A 
  Processes: 185 Uptime: 8m Memory: 7.68 GiB used: 737.8 MiB (9.4%) 
  Init: systemd v: 239 Compilers: gcc: 8.2.1 Shell: bash v: 4.4.23 
  running in: xfce4-terminal inxi: 3.0.27 

sudo journalctl -b0 -p3
return anything?

If so please post output.

Got a Output as

-- Logs begin at Mon 2018-11-12 17:59:19 IST, end at Mon 2018-11-19 15:17:58 IST. --
Nov 19 12:55:37 akhilesh systemd-vconsole-setup[283]: /usr/bin/loadkeys failed with exit status 1.
Nov 19 12:55:40 akhilesh systemd-vconsole-setup[423]: /usr/bin/loadkeys failed with exit status 1.
Nov 19 13:29:17 akhilesh kernel: rtlwifi: AP off, try to reconnect now
Nov 19 15:04:46 akhilesh systemd-coredump[2716]: Process 2587 (Xorg) of user 0 dumped core.
                                                 Stack trace of thread 2587:
                                                 #0  0x00007fd0bd432d7f raise (
                                                 #1  0x00007fd0bd41d672 abort (
                                                 #2  0x000055a2ee185aea OsAbort (Xorg)
                                                 #3  0x000055a2ee17c55f FatalError (Xorg)
                                                 #4  0x000055a2ee18a37e n/a (Xorg)
                                                 #5  0x00007fd0bd432e00 __restore_rt (
                                                 #6  0x00007fd0bd432d7f raise (
                                                 #7  0x00007fd0bd41d672 abort (
                                                 #8  0x00007fd0bd41d548 __assert_fail_base.cold.0 (
                                                 #9  0x00007fd0bd42b396 __assert_fail (
                                                 #10 0x000055a2ee233f29 dixRegisterPrivateKey (Xorg)
                                                 #11 0x00007fd0b330bce9 glamor_init (
                                                 #12 0x00007fd0b8041f6d n/a (
                                                 #13 0x000055a2ee25529d AddGPUScreen (Xorg)
                                                 #14 0x000055a2ee151e5c n/a (Xorg)
                                                 #15 0x000055a2ee1346d6 n/a (Xorg)
                                                 #16 0x000055a2ee1231f9 n/a (Xorg)
                                                 #17 0x000055a2ee1239a3 config_init (Xorg)
                                                 #18 0x000055a2ee16a0f7 InitInput (Xorg)
                                                 #19 0x000055a2ee110734 n/a (Xorg)
                                                 #20 0x00007fd0bd41f223 __libc_start_main (
                                                 #21 0x000055a2ee11130e _start (Xorg)
                                                 Stack trace of thread 2591:
                                                 #0  0x00007fd0bc270afc pthread_cond_wait@@GLIBC_2.3.2 (
                                                 #1  0x00007fd0ba035020 n/a (
                                                 #2  0x00007fd0bc26aa9d start_thread (
                                                 #3  0x00007fd0bd4f6b23 __clone (
                                                 Stack trace of thread 2709:
                                                 #0  0x00007fd0bc270afc pthread_cond_wait@@GLIBC_2.3.2 (
                                                 #1  0x00007fd0b2b85cdc n/a (
                                                 #2  0x00007fd0b2b85a18 n/a (
                                                 #3  0x00007fd0bc26aa9d start_thread (
lines 1-41

Okay, this is above my pay-grade :wink: but I'll speculate that the next piece of information needed by someone who might be able to help is:

cat /var/log/Xorg.0.log | grep EE

But it is possible that they may prefer the whole Xorg.0.log...

Also cleaning up your previous post (delete the first half, before 'lines 1-23') will help them see better. :slightly_smiling_face:

cat /var/log/Xorg.0.log | grep EE
[ 38.642] Current Operating System: Linux akhilesh 4.19.2-1-MANJARO #1 SMP PREEMPT Tue Nov 13 22:35:25 UTC 2018 x86_64
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 39.511] (EE) Failed to load module "fbdev" (module does not exist, 0)
[ 39.511] (EE) Failed to load module "vesa" (module does not exist, 0)
[ 43.189] (II) Initializing extension MIT-SCREEN-SAVER

I switched to previous kernel version again, It works absolutely fine.

I'm having the same issue, but on VirtualBox, not on real machine.
By what I've been reading here, the problems is related to kernel 4.19 which is so UNSTABLE that cannot be considered STABLE.

Kernel 4.19 is still in early development. Unless your hardware is brand new there is no need to run the newest kernel. I experienced issues with suspending on 4.19. Switching back to 4.14 resolved the problem.

Wait a month for the bugs to be worked out on 4.19 then test to see if it's working better with your hardware. The kernel development team usually works the bugs out fairly quickly. There's no need to always be on the latest kernel.

I have the same issue with 4.19 on KDE, works just fine with 4.14.
Looking at kernel Logs I found that issue is something with nouveau driver,

nouveau0000 DRM: base-0: timeout

I'm currently using proprietary Nvidia driver with nomodeset in grub.
That resolved the issue for me, try setting 'nomodeset' in grub might solve the problem.

hmm, so now you are not using the Nvidia driver???
I do not really want to resurrect this thread because I think it is solved with the kernel switch back to 4.14.

I also do not want people randomly trying kernel options via grub unless they know what they do.
On the other hand, using this switch via grub edit at boot would only be for one time so it would not hurt I guess.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by