Airpods headset not working - cannot connect mic

I am trying to change the profile on my airpods and get: Failed to change profile to headset_head_unit I tried the guide on arch docs, but no luck.

00001000-0000-1000-8000-00805f9b34fb ServiceDiscoveryServerServiceClassID
0000110b-0000-1000-8000-00805f9b34fb Audio Sink
0000110c-0000-1000-8000-00805f9b34fb Remote Control Target
0000110e-0000-1000-8000-00805f9b34fb Remote Control
0000111e-0000-1000-8000-00805f9b34fb Handsfree
00001200-0000-1000-8000-00805f9b34fb PnP Information
74ec2172-0bad-4d01-8f77-997b2be0722a Proprietary
bluetooth:v004Cp200Fd4C0F
/org/bluez/hci0
System:    Host: peter-xps157590 Kernel: 5.6.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 Desktop: Xfce 4.14.2 
           tk: Gtk 3.24.20 info: xfce4-panel wm: xfwm4 dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:   Type: Laptop System: Dell product: XPS 15 7590 v: N/A serial: <filter> Chassis: type: 10 serial: <filter> 
           Mobo: Dell model: 0T8KGX v: A00 serial: <filter> UEFI: Dell v: 1.6.0 date: 02/06/2020 
Battery:   ID-1: BAT0 charge: 38.7 Wh condition: 87.2/97.0 Wh (90%) volts: 11.9/11.4 model: LGC-LGC8.33 DELL 5XJ2898 
           type: Li-ion serial: <filter> status: Charging 
CPU:       Topology: 8-Core model: Intel Core i9-9980HK bits: 64 type: MT MCP arch: Kaby Lake rev: D L2 cache: 16.0 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 76816 
           Speed: 4242 MHz min/max: 800/5000 MHz Core speeds (MHz): 1: 4242 2: 2974 3: 3435 4: 2386 5: 3065 6: 2049 7: 1383 
           8: 2926 9: 4226 10: 3630 11: 1564 12: 2594 13: 1710 14: 1601 15: 2293 16: 2803 
Graphics:  Device-1: Intel UHD Graphics 630 vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:3e9b 
           Device-2: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] vendor: Dell driver: N/A bus ID: 01:00.0 
           chip ID: 10de:1f91 
           Display: x11 server: X.Org 1.20.8 driver: modesetting resolution: 2560x1440~60Hz, 3440x1440~60Hz 
           OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 20.0.7 direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Dell driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           chip ID: 8086:a348 
           Sound Server: ALSA v: k5.6.16-1-MANJARO 
Network:   Device-1: Intel Wi-Fi 6 AX200 vendor: Bigfoot Networks driver: iwlwifi v: kernel port: 3000 bus ID: 3b:00.0 
           chip ID: 8086:2723 
           IF: wlp59s0 state: up mac: <filter> 
           IF-ID-1: virbr0 state: down mac: <filter> 
           IF-ID-2: virbr0-nic state: down mac: <filter> 
Drives:    Local Storage: total: 2.75 TiB used: 754.70 GiB (26.8%) 
           ID-1: /dev/nvme0n1 vendor: Micron model: 2200S NVMe 1024GB size: 953.87 GiB speed: 31.6 Gb/s lanes: 4 
           serial: <filter> rev: 22001040 scheme: GPT 
           ID-2: /dev/sda type: USB vendor: Toshiba model: MQ01UBB200 size: 1.82 TiB rotation: 5400 rpm serial: <filter> 
           scheme: GPT 
Partition: ID-1: / size: 937.60 GiB used: 352.81 GiB (37.6%) fs: ext4 dev: /dev/dm-0 
Sensors:   System Temperatures: cpu: 58.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 349 Uptime: 1h 41m Memory: 31.00 GiB used: 4.61 GiB (14.9%) Init: systemd v: 245 Compilers: gcc: 10.1.0 

Try this
https://raymondjdouglas.com/blog/2019/airpods-on-arch/

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by