AirPods Pro max volume too low

I've tried tried following these steps to fix the volume, but with no luck. Most threads I've found online have suggested this answer or similar, but it has no effect on the max volume.

Any tips/pointers would be appreciated!

inxi -Fxzc0
System:    Host: lean-mean-dev-machine Kernel: 5.6.15-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 
           Desktop: Gnome 3.36.2 Distro: Manjaro Linux 
Machine:   Type: Laptop System: Dell product: XPS 15 7590 v: N/A serial: <filter> 
           Mobo: Dell model: 0T8KGX v: A00 serial: <filter> UEFI: Dell v: 1.5.0 date: 12/25/2019 
Battery:   ID-1: BAT0 charge: 84.3 Wh condition: 87.4/97.0 Wh (90%) model: SMP DELL GPM0365 status: Charging 
           Device-1: hidpp_battery_0 model: Logitech G603 Wireless Gaming Mouse charge: 100% (should be ignored) 
           status: Discharging 
CPU:       Topology: 8-Core model: Intel Core i9-9980HK bits: 64 type: MT MCP arch: Kaby Lake rev: D 
           L2 cache: 16.0 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 76816 
           Speed: 800 MHz min/max: 800/5000 MHz Core speeds (MHz): 1: 801 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800 
           8: 800 9: 800 10: 800 11: 800 12: 800 13: 800 14: 800 15: 800 16: 800 
Graphics:  Device-1: Intel UHD Graphics 630 vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 
           Device-2: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] vendor: Dell driver: nvidia v: 440.82 
           bus ID: 01:00.0 
           Display: x11 server: X.org 1.20.8 driver: modesetting,nvidia resolution: <xdpyinfo missing> 
           OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 20.0.7 direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Dell driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           Sound Server: ALSA v: k5.6.15-1-MANJARO 
Network:   Device-1: Intel Wi-Fi 6 AX200 vendor: Bigfoot Networks driver: iwlwifi v: kernel port: 3000 
           bus ID: 3b:00.0 
           IF: wlp59s0 state: up mac: <filter> 
Drives:    Local Storage: total: 953.87 GiB used: 68.59 GiB (7.2%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: PM981a NVMe 1024GB size: 953.87 GiB 
Partition: ID-1: / size: 360.54 GiB used: 67.97 GiB (18.9%) fs: ext4 dev: /dev/nvme0n1p5 
Sensors:   System Temperatures: cpu: 54.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 357 Uptime: 18m Memory: 31.00 GiB used: 2.24 GiB (7.2%) Init: systemd Compilers: gcc: 10.1.0 
           Shell: zsh v: 5.8 inxi: 3.0.37

If you covered all this





There is not much to suggest without the actual hands on those AirPods.

Let us know what else have you tried.

Yeah I've dug through all of those threads and tried everything with no luck. With what I understand so far, the AirPods have a internal volume level, that the iPhone keeps in sync with its software level (Windows seems to do this as well). There's a proposed PR for pulseaudio that seems to fix this issue.

I've tried manually sending D-Bus messages to increase the volume, as described in this StackExchange answer, but it seems to have no effect for me.

Unless there's another option, I think the next step for me is to see if I can apply the PR and re-build pulseaudio on my system. Not entirely sure about the best way to do that, so I'll have to do some more research :grin:

I am still stuck on this issue but it's a quite a bit out of my expertise. Please let me know if you have found a solution. I will still continue to try things out every now and then.

Hello, I am on Ubuntu, but I wanted to suggest this small patch to bluez: https://unix.stackexchange.com/a/562381/390697. It worked for me, and while it is a bit annoying to have to make a script to change the AirPod's volume instead of just having it be V+/V- keys, at least it works!
I have these scripts so i can set the remote airpods volume with ./airvol.sh <0 - 127>, which only work with a patched bluez:
airvol.sh

#!/bin/bash
echo Setting volume to $1
for dev in $(./list_airpods.sh); do dbus-send --print-reply --system --dest=org.bluez "$dev" org.freedesktop.DBus.Properties.Set string:org.bluez.MediaTransport1 string:Volume variant:uint16:$1; done

list_airpods.sh

#!/bin/bash
dbus-send --print-reply --system --dest=org.bluez / org.freedesktop.DBus.ObjectManager.GetManagedObjects | grep -E '/org/bluez/hci./dev_.._.._.._.._.._../fd[0-9]+' -o

The proposed PR linked earlier also links to a patch in bluez that seems to fix this in a much better way: https://marc.info/?l=linux-bluetooth&m=157936152330574&w=2. You might want to try that first before my patch, and also try the pulseaudio PR for volume key support. But just the single-line patch to volume_exists works if you just want to max out the airpods' volume and lower the volume from there with V+/V-.

1 Like

I wasn't able to get the PR I mentioned to work, but your patch + scripts worked for me! Thanks

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by