ALC1220 static on mic

Since finally getting the mic to record anything, I've been unsuccessful at getting rid of the static. It doesn't matter whether I'm using the front or rear mic. The motherboard is a Gigabyte AX370 Gaming 5 and I'm currently running kernel 4.15.0-1. I can hear my voice well enough, but there's enough static to make it annoying. I've tried the suggestions here: https://wiki.archlinux.org/index.php/PulseAudio/Troubleshooting#Static_noise_in_microphone_recording as well as the ones here: https://bbs.archlinux.org/viewtopic.php?id=224103 and I just can't get rid of it.

Have you found a solution to this issue?

I have the same audio chipset on a Gigabyte X470 AORUS GAMING 7 WIFI with the same static issue. I am running Kernel 4.20 and have tried the fixes listed in the Arch Wiki and any forum post I can find on the topic. It seems that many have been having this issue and there has not been a consistent solution. From what I have seen, most forum posts regarding this issue end up dying before the issue is resolved.

Does anyone have any information on this issue or any suggestions on how to resolve it? I enjoy the Manjaro experience but am unable to fully switch from Win10 because of this audio issue.

@cain

I fixed the issue by following this tutorial:

I had to set Sample Rate in Jack to 192000Hz and it fixed all of my issues. Audio is better (IMO) than Windows 10 was.

I am wondering if it would also fix the issue to follow change the PulseAudio sample rate to 192000Hz. Haven't tested it but it seems likely that it would also resolve the issue.

Forum kindly sponsored by