All texts in Qt application became HUGE after 2019-01-16 update

, ,

Hi all,

I've got a problem that all the texts in some Qt applications became huge after the latest stable update. Here's what it looks like for now:


As you can see, the Dolphin file manager's text is much bigger than Chromium's text, where the Chromium's text is considered to be normal for me.

Same issue also happens in VLC and Oklar (but not in KCalc and Chromium, as a comparison):


I've got a ThinkPad x1 carbon gen 6, with a 2K display. I've set the HiDPI scaling factor to 1.5x and it works just fine.

Here's the inxi -Fxz output:

System:    Host: hu-thinkpad Kernel: 5.4.12-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0 Desktop: KDE Plasma 5.17.5 
           Distro: Manjaro Linux 
Machine:   Type: Laptop System: LENOVO product: 20KHCTO1WW v: ThinkPad X1 Carbon 6th serial: <filter> 
           Mobo: LENOVO model: 20KHCTO1WW v: SDK0J40697 WIN serial: <filter> UEFI: LENOVO v: N23ET69W (1.44 ) date: 11/25/2019 
Battery:   ID-1: BAT0 charge: 54.1 Wh condition: 54.2/57.0 Wh (95%) model: LGC 01AV494 status: Unknown 
CPU:       Topology: Quad Core model: Intel Core i7-8550U bits: 64 type: MT MCP arch: Kaby Lake rev: A L2 cache: 8192 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 32012 
           Speed: 800 MHz min/max: 400/4000 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 802 8: 800 
Graphics:  Device-1: Intel UHD Graphics 620 vendor: Lenovo driver: i915 v: kernel bus ID: 00:02.0 
           Display: x11 server: X.Org 1.20.7 driver: intel unloaded: modesetting resolution: 2560x1440~60Hz 
           OpenGL: renderer: Mesa DRI Intel UHD Graphics 620 (Kabylake GT2) v: 4.6 Mesa 19.3.2 direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           Sound Server: ALSA v: k5.4.12-1-MANJARO 
Network:   Device-1: Intel Ethernet I219-V vendor: Lenovo driver: e1000e v: 3.2.6-k port: efa0 bus ID: 00:1f.6 
           IF: enp0s31f6 state: down mac: <filter> 
           Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel port: efa0 bus ID: 02:00.0 
           IF: wlp2s0 state: up mac: <filter> 
           IF-ID-1: docker0 state: down mac: <filter> 
Drives:    Local Storage: total: 700.51 GiB used: 56.46 GiB (8.1%) 
           ID-1: /dev/nvme0n1 vendor: Toshiba model: RC100 size: 223.57 GiB 
           ID-2: /dev/nvme1n1 vendor: Western Digital model: PC SN720 SDAQNTW-512G-1001 size: 476.94 GiB 
Partition: ID-1: / size: 49.06 GiB used: 27.78 GiB (56.6%) fs: ext4 dev: /dev/nvme1n1p6 
           ID-2: /home size: 166.52 GiB used: 25.03 GiB (15.0%) fs: ext4 dev: /dev/nvme1n1p7 
           ID-3: swap-1 size: 16.01 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/nvme1n1p5 
Sensors:   System Temperatures: cpu: 53.0 C mobo: N/A 
           Fan Speeds (RPM): cpu: 0 
Info:      Processes: 260 Uptime: 10m Memory: 15.40 GiB used: 2.16 GiB (14.0%) Init: systemd Compilers: gcc: 9.2.0 
           clang: 9.0.1 Shell: zsh v: 5.7.1 inxi: 3.0.37 

Any suggestions for fixing this problem? Thanks in advance!


Just tried running QT_AUTO_SCREEN_SCALE_FACTOR=1.5 okular or QT_AUTO_SCREEN_SCALE_FACTOR=1 okular but no improvement at all...

But then if I run QT_FONT_DPI=96 okular, problem solved:


I've also set the force font DPI to 144. If I turn it off or force to 96, some other applications (especially GTK applications) font size will be extremely small.


This suggestion worked for me:

1 Like

Thanks for your reply. The issue solved after I added export QT_AUTO_SCREEN_SCALE_FACTOR=0 to ~/.xprofile

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by