All windows borderless and "stuck" after latest update

Hi there everyone!

I'm experiencing a graphical issue since the latest Manjaro KDE update. The issue is as follows:

All of my windows have become borderless (screenshot 1). I'm unable to resize, drag, minimize, close or move them in any way, shape or form. I need to resort to ending processes to close programs.

I can click program icons in the taskbar and open programs. However, right clicking their taskbar icons > close doesn't work -- it's as if they weren't open in the first place (screenshot 2).

Alt+F3 does not trigger border settings. Alt-tab has no output.

The keyboard's output goes to the topmost window, even if I select a "typeable" field in another window. For instance: if I first open Firefox then open the terminal and type anything on it, I can no longer type into Firefox's search bar even if I've selected it with the mouse. All text output goes to terminal until I close it through the menubar.

I've tried creating a new superuser and running a "fresh" KDE through it but the issues persists there -- e.g. windows are still borderless and unmovable despite using default settings.

I've tried changing themes -- to breeze, etc. -- but the issue still persists.

This is the closest instance of the issue I could find in the entire forums (screenshot 2).

It's worth noting I'm currently running KDE on two machines and only one of them has expressed this behavior after the latest update.

I was running KWin when the issue started and tried using lightdm but the issue persisted.

In case it's useful, here's my inxi -Fxxxz output:

  Host: ariadne-pc Kernel: 4.19.80-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 9.2.0 Desktop: KDE Plasma 5.17.1 tk: Qt 5.13.1 dm: LightDM 1.30.0, SDDM 
  Distro: Manjaro Linux 
Machine:
  Type: Desktop Mobo: ASUSTeK model: P8H61-M LX3 R2.0 v: Rev X.0x 
  serial: <filter> BIOS: American Megatrends v: 1004 date: 04/11/2013 
CPU:
  Topology: Dual Core model: Intel Core i3-3240 bits: 64 type: MT MCP 
  arch: Ivy Bridge rev: 9 L2 cache: 3072 KiB 
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 27215 
  Speed: 1600 MHz min/max: 1600/3400 MHz Core speeds (MHz): 1: 1600 2: 1600 
  3: 1600 4: 1600 
Graphics:
  Device-1: NVIDIA GM107 [GeForce GTX 750 Ti] vendor: Gigabyte driver: nvidia 
  v: 430.40 bus ID: 01:00.0 chip ID: 10de:1380 
  Display: x11 server: X.Org 1.20.5 driver: nvidia resolution: 1920x1080~60Hz 
  OpenGL: renderer: GeForce GTX 750 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 430.40 
  direct render: Yes 
Audio:
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio 
  vendor: ASUSTeK driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  chip ID: 8086:1c20 
  Device-2: NVIDIA vendor: Gigabyte driver: snd_hda_intel v: kernel 
  bus ID: 01:00.1 chip ID: 10de:0fbc 
  Sound Server: ALSA v: k4.19.80-1-MANJARO 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASUSTeK P8 series driver: r8168 v: 8.047.04-NAPI port: d000 
  bus ID: 03:00.0 chip ID: 10ec:8168 
  IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 1.36 TiB used: 372.08 GiB (26.6%) 
  ID-1: /dev/sda vendor: Seagate model: ST500DM002-1BD142 size: 465.76 GiB 
  speed: 3.0 Gb/s rotation: 7200 rpm serial: <filter> rev: KC48 scheme: MBR 
  ID-2: /dev/sdb vendor: Western Digital model: WD10EZEX-21WN4A0 
  size: 931.51 GiB speed: 3.0 Gb/s rotation: 7200 rpm serial: <filter> rev: 1A01 
  scheme: MBR 
Partition:
  ID-1: / size: 442.78 GiB used: 372.08 GiB (84.0%) fs: ext4 dev: /dev/sda2 
  ID-2: swap-1 size: 14.90 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda5 
Sensors:
  System Temperatures: cpu: 63.0 C mobo: 27.8 C gpu: nvidia temp: 42 C 
  Fan Speeds (RPM): cpu: 0 gpu: nvidia fan: 35% 
Info:
  Processes: 252 Uptime: 29m Memory: 15.61 GiB used: 2.00 GiB (12.8%) 
  Init: systemd v: 242 Compilers: gcc: 9.2.0 clang: 9.0.0 Shell: bash v: 5.0.11 
  running in: konsole inxi: 3.0.36

And here's a pastebin with my most recent var/log/pacman.log output:

https://pastebin.com/DitucAhP

Screenshots

Screenshot_20191031_160351-min
Screenshot 1: window "stuck" to the top left corner of the screen. No borders, unresizeable.

Screenshot_20191031_161018-min
Screenshot 2: Firefox tray icon acts as if Firefox was closed -- e.g. can't right click on it to close Firefox.


All help is greatly appreciated! Please let me know if I can further explain the issue in any way.
1 Like

Are you using both LightDM and SDDM ? Is kwin installed or do you use a different WM ?
Have you tried to remove the files and folders from ~/.cache in your home directory and reboot the system ?
Are you on some sort of wayland session started from LightDM ?
Also, consider this:

Hi bogdancovaciu, thanks so much for your reply.

I (foolishly) realized SDDM was still enabled, so I ran:

sudo systemctl disable sddm
sudo systemctl enable lightdm

Upon reboot the windows are now properly manageable under LightDM.

I still don't know what the problem was with SDDM and haven't encountered anyone with a similar problem, however.

I think I might need to do a fresh KDE install to get SDDM working again.

To answer you: kwin is installed.

Hi Coraline. I'm having the exact same problem with two different computers running Manjaro KDE.
Both use NVIDIA graphics cards, so I have tried turning compositing off and switching to the Nouveau driver without change.
I'm away from home for a few days, but will try this solution on returning. I haven't made any modifications to the display manager, so have running whatever came in the standard install...
Let me know if yours stays fixed with your change to LightDM

1 Like

Hi! Both happy and sad to see I'm not alone.

I'm able to USE Manjaro KDE with LightDM but the interface is completely different. Make sure to remember any configuration you've applied to SDDM before making the switch, as you'll wipe your .cache files.

I dislike the interface and will attempt to get SDDM working again.

Have you also tried logging into a new user? In my case, it didn't work -- the problem persisted -- but perhaps it could work in your case. Let me know.

Thanks for the commiserations. :slight_smile:
I found a solution...
It turns out that I had installed kwin-lowlatency from AUR at some stage, so all I had to do was install kwin (run in terminal) and this removed kwin-lowlatency and fixed the problem.
Hooray! Hope it works for you...

@mondocello finally got around to tweaking my Manjaro KDE PC and this worked! Thank you so much.

To anyone who stumbles upon this issue, I:

Updated KDE via the usual sudo pacman -Syu; rebooted to ensure nothing else was broken.

Then ran, as mondocello suggested, sudo pacman -S kwin to install kwin; when prompted to substitute "kwin-lowlatency," accept. Reboot.

Since I had substituted sddm with lightdm, I reverted that by running:

sudo systemctl disable lightdm
sudo systemctl enable sddm

Finally, rebooted. All my customization options previously applied to konsole, etc., were kept.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by