Alternative lock screen for KDE

Hi,

I'm trying to setup manjaro KDE in an old netbook. Everything works very well except for the login and lock screen. They are extremely slow (i.e. 30 seconds to show and uncapable of updating the screen while I type my password.

I have replaced sddm with lightdm, but I can't get any screenlocker to start after some time. When I trigger the lock action, the KDE locker appears always.

I tried xss-lock without luck. The "dm-tool lock" command works as expected, but I can't run it automatically after some idling time.

Does somebody know a way to set an alternate lock screen on KDE?

Thank you!

System:    Host: eeekde Kernel: 5.0.18-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.3.0 Console: tty 2 Distro: Manjaro Linux 
Machine:   Type: Laptop System: ASUSTeK product: 1215N v: x.x serial: <filter> 
           Mobo: ASUSTeK model: 1215N v: x.xx serial: <filter> BIOS: American Megatrends v: 0902 date: 05/05/2011 
Battery:   ID-1: BAT0 charge: 33.2 Wh condition: 52.9/56.7 Wh (93%) model: ASUS 1215N status: Discharging 
CPU:       Topology: Dual Core model: Intel Atom D525 bits: 64 type: MT MCP arch: Bonnell rev: A L2 cache: 512 KiB 
           flags: lm nx pae sse sse2 sse3 ssse3 bogomips: 14407 
           Speed: 1800 MHz min/max: N/A Core speeds (MHz): 1: 1800 2: 1800 3: 1799 4: 1799 
Graphics:  Device-1: Intel Atom Processor D4xx/D5xx/N4xx/N5xx Integrated Graphics vendor: ASUSTeK driver: i915 v: kernel 
           bus ID: 00:02.0 
           Device-2: NVIDIA GT218M [ION 2] driver: N/A bus ID: 04:00.0 
           Display: tty server: X.org 1.20.4 driver: intel unloaded: modesetting tty: 212x51 
           Message: Advanced graphics data unavailable in console. Try -G --display 
Audio:     Device-1: Intel NM10/ICH7 Family High Definition Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           bus ID: 00:1b.0 
           Sound Server: ALSA v: k5.0.18-1-MANJARO 
Network:   Device-1: Qualcomm Atheros AR8152 v2.0 Fast Ethernet vendor: ASUSTeK Eee PC 1015PX driver: atl1c v: 1.0.1.1-NAPI 
           port: dc00 bus ID: 01:00.0 
           IF: enp1s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
           Device-2: Broadcom and subsidiaries BCM4313 802.11bgn Wireless Network Adapter vendor: AzureWave 
           driver: bcma-pci-bridge v: N/A port: dc00 bus ID: 02:00.0 
           IF-ID-1: wlp2s0b1 state: up mac: <filter> 
Drives:    Local Storage: total: 232.89 GiB used: 47.95 GiB (20.6%) 
           ID-1: /dev/sda vendor: Western Digital model: WD2500BEVT-80A23T0 size: 232.89 GiB 
Partition: ID-1: / size: 19.56 GiB used: 10.10 GiB (51.6%) fs: ext4 dev: /dev/sda7 
           ID-2: /boot size: 511.0 MiB used: 53.7 MiB (10.5%) fs: vfat dev: /dev/sda1 
           ID-3: /home size: 160.43 GiB used: 20.70 GiB (12.9%) fs: ext4 dev: /dev/sda3 
           ID-4: swap-1 size: 8.38 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda4 
Sensors:   System Temperatures: cpu: 49.0 C mobo: N/A 
           Fan Speeds (RPM): cpu: 3903 
Info:      Processes: 161 Uptime: 12m Memory: 3.84 GiB used: 582.3 MiB (14.8%) Init: systemd Compilers: gcc: 8.3.0 
           clang: 8.0.0 Shell: bash v: 5.0.7 inxi: 3.0.34 

KDE's locker is built-in. It has nothing to do with SDDM (default login/DM)

And since you are expressing what seems to be a known bug with nvidia+qt .. try this:

Edit /etc/environment to include:

QSG_RENDERER_LOOP=basic

[reboot and tell us how the locker goes as far as slow and/or cpu usage]

1 Like

Hi,

I know sddm and kscreenlocker are not related... but both work horribly in this netbook. The fix you suggested does not work. Actually, the nvidia card is disabled through bbswith and I use the intel integrated only. This is an old Pineview Atom with nvidia ion graphics

Is haveged service enabled?

systemctl status haveged

Hi,

it was not enabled by default. I enabled it, rebooted and it did not make any difference.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by