AMD Ryzen 7 3700X and Radeon RX 5700 XT support

Is there a way we could stay in touch on this install? I have the same laptop and going crazy trying everything.

I'll try to keep the thread updated on my progress.

I have now, using the above parameters, booted and installed Manjaro on the machine, using a USB keyboard and mouse. Before doing this, on Windows, I extracted my ACPI tables, made the modifications recommended here, followed the instructions here to combine the ACPI table with Manjaro's initrd. I sporadically get the error "initrd is too big," but most of the time it boots.

Unfortunately, I still have no keyboard, mouse, or Wifi. Next, I'm going to try kernel 5.1, since in the Ask Ubuntu thread a comment was made that the Wifi drivers are being "reworked" in kernels > 5.1.

1 Like

Okay, I can confirm Wifi works on kernel 5.1, but no keyboard and mouse. The last tip in the kernel.org thread I referenced above is somebody who said the kernel needs this parameter to get keyboard and mouse working:

 i8042.nopnp

However, when I add that parameter I get this error:

   Booting a command list
 error: the initrd is too big. 
 Press any key to continue...

That's where I'm stuck at the moment. :frowning:

1 Like

Thanks for the update!
I will try and get going based on your progress.

Modifying and inserting the ACPI tables are tough for me. I'm still relatively new.

Well, if I remove

 quiet splash

from the kernel options, I can avoid the "initrd is too big" error. However, I've tried all of these options:

 i8042.reset i8042.nomux i8042.nopnp i8042.noloop

and none of them seems to help. I can't get the keyboard/touchpad working.

Does anyone else have any ideas? Thanks!

you should probably start a new thread for those 2 issues since it's not likely related to ryzen/radeon issues. touchpad threads can be consuming and would probably sidetrack this thread quite a bit.

in that new thread, include

(from a clean boot)

inxi -Fxxxza --no-host
libinput list-devices
hwinfo --mouse
lspci -v
cat /var/log/Xorg.0.log
2 Likes

Okay; thank you! I posted a thread here.

2 Likes

Looks like the Mesa-Git in the AUR has moved to 19.2.0
Any one have any tips for getting it installed and running via the architect installer? should it all just work if i chroot into the system post install and get it downloaded and built locally?

I got my 5700XT working today on Manjaro.
I have been following this thread for a while hoping for an easy fix.

What I ended up doing to get it working:
Went to the testing branch of manjaro to get the 5.3 kernel
Installed mesa-git from lcarlier repo:

I had to add in

[mesa-git]
Server = http://pkgbuild.com/~lcarlier/$repo/$arch

to /etc/pacman.conf

then installed mesa-git and that should bring in llvm with it also.

And then rebooted.

I had issues with the mesa-git in the aur directly, I did originally install that one but I could not get LLVM installing with it because of ocaml version differences.

4 Likes

Hello, I am attempting to upgrade Mesa with this method, but Pacman is throwing 2 errors:

error: llvm-libs-git: missing required signature
error: mesa-git: missing required signature
error: failed to commit transaction (package missing required signature)
Errors occurred, no packages were upgraded.

Where/how would I get the required signatures for this repo?

Edit:
According to Archlinux's wiki, this repo is unsigned so the edit to Pacman.conf would be

[mesa-git]
SigLevel = PackageOptional
Server = http://pkgbuild.com/~lcarlier/$repo/$arch

if you have Pacman configured to its default settings

1 Like

From a fresh install on Manjaro Architect (also followed RobertPlant's instructions by chrooting and disabling signatures in pacman.conf), the system does not get past Started Rebuild Journal Catalog. I use refind and btrfs if it matters.

Update on previous post:
I have installed Mesa-git, its 32-bit version and the associated vulkan layers. Everything is working fine so long as I am using my Nvidia card, but when I attempt to boot with my 5700XT installed, the computer does not fully boot, with the last message showing up in verbose mode being "Reached target offline system update (pre)", and the boot does not advance past this step. When using the Nvidia card, the system boots with no issues.

Does anyone have any idea how to fix this issue?

edit grub during boot and add the number 3 to the end of the linux boot line, this will prevent a graphical environment from starting. if this lets you boot to a TTY login you can start working the configuration angle rather than "shyte, my hardware wont let it boot". you can also remove the nvidia drivers from tty

sudo mhwd -r pci video-nvidia
sudo mhwd -a nonfree 0300
#might need a reboot, but try anyway
startx

if the second command fails, use this instead

sudo mhwd -i pci video-linux
1 Like

After editing grub and adding the 3 to the linux line did not fix the booting issue on my main install, however it does work when using the live environment on a USB. Would using the live environment work to replace the drivers?

yes, boot the live environment, connect to network, open a terminal and

sudo manjaro-chroot -a

if it asks and only lists a single option and the number is zero " 0 ", enter the number " 1 " anyway even though it's not listed. this should drop you to a root shell on your installed manjaro and you can do what you need to do.

might want to add another kernel or 2 while your there so you can try booting with each after your done installing drivers

Removing the video-nvidia driver worked, however when I tried to install the nonfree or the video-linux driver, both gave a conflicting packages error between lib32-mesa-vdpau and lib32-mesa-git.

Edit: Booting now works on the 4.19 kernel.

gave as in past tense, or currently?

without the actual errors this is of little use. if it's still a problem then copy/paste the output here

I was able to get the installed version to boot by using the 4.19 kernel, but mhwd still fails. Here's the output from sudo mhwd -i pci video-linux:

> installing video-linux...
Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/db/pci/graphic_drivers/video-linux/MHWDCONFIG
processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
processing classid: 0380
processing classid: 0302
:: Synchronizing package databases...
  core is up to date
  extra is up to date
  community is up to date
  mesa-git is up to date
  multilib is up to date
resolving dependencies...
looking for conflicting packages...
::lib32-mesa-vdpau and lib32-mesa-git are in conflict. Remove lib32-mesa-git? [y/N] error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)

::lib32-mesa-vdpau and lib32-mesa-git are in conflict.
Error: pacman failed!
Error: script failed!

so your currently booted to a graphical environment or no?

if not and if mesa-git are the packages you need, use pacman to remove the aur git packages that are conflicting with manjaro's and after video-linux gets installed you can reinstall the aur packages to replace the mhwd supplied ones.

im assuming you need the mesa-git packages due to the newer hardware?

if your not sure, post:

mhwd -li
pacman -Qs mesa

Yes, and your advice worked to get video-linux and mesa-git installed together. Now startx is giving an error.

(II) LoadModule "amdgpu"
...
(EE) Screen 0 deleted because of no matching config section
(II) UnloadModule "amdgpu"
(EE) Screen 0 deleted because of no matching config section
(II) UnloadModule "amdgpu"
(EE) Screen 0 deleted because of no matching config section
(II) UnloadModule "amdgpu"
(EE) Screen 0 deleted because of no matching config section
(II) UnloadModule "amdgpu"
(EE) Device(s) detected , but none match those in the config file
Fatal server error:
(EE) no screens found
(EE) Please consult the X.org foundation support at wiki.x.org
(EE) Server terminated with error 1. Closing log file. 

The wiki says that the solution to this is to run X -configure, but this is after I have run it. Before I got the same error but without amdgpu being unloaded 4 times. The wiki also suggests using a distro specific configuration tool, doe Manjaro have one?

Edit:
Apparently the problem was caused by me not installing video-vesa, now the graphical environment is running.
Thanks for the help!

Forum kindly sponsored by