Amharic Keyboard Layout Not Working.

I was trying to use the Amharic keyboard layout. and after I add the layout it's not fully functional.
it works only with the consonant letters like (ሀ ለ መ) but I have to use the vowel letters like (ል ም
...) but when I try that I got something like this (ሀ﹩ለ﹩መ﹩)

What flavour of Manjaro do you use? I'm also not sure what specific info you could provide to distinguish between layouts? (Maybe someone else??)

  • I've found an askUbuntu thread which is aimed at this subject. It says that you have to install

which is available in the repos and can be installed via pamac GUI or

pacman -S ibus-m17n

and then select Amharic (sera (m17n)) in your Desktop Environment.

General problems I've encountered when I use other layouts:

  • Place the Amharic layout on top of the list of the used layouts. As you type now in English I guess en_GB or en_US is used, so place Amharic above the English one.
  • As I presume that you use a X11 based display manager you could try
setxkbmap et

in a terminal.

For the next time you open an issue please read the tutorial to provide more relevant information.

1 Like

thanks for the reply!
i am using Manjaro 20.0 Lysia
with GNOME 3.36.1

i installed the package ibus-m17n successfully but there is no option to chose Amharic (sera (m17n))

I'm not a Gnome user so I can only point you towards what I read myself. Did you log out and back in again. A reboot would also suffice.

After doing that you should find your layout as explained here

it worked ! after a reboot :star_struck: :star_struck:
and with my new keyboard layout i want to say :
አመሰግናለው ! which means thank you in Amharic.

1 Like

You are welcome :smile:

hello again!
I've been moved from gnome to KDE and followed the steps you said about adding the keyboard layout. and after installing I couldn't find Amharic (sera (m17n)) on KDE 5.69.0 / Plasma 5.18.4

In Plasma 5 you have to make the file .xprofile in your home folder, like so in the terminal:

echo export QT_IM_MODULE=ibus > ~/.xprofile

then reboot. It should be available now. Don't know whether this works with the Wayland session, so check on the login-screen which session you are about to start.

after executing this command

echo export QT_IM_MODULE=ibus > ~/.xprofile

still no sign of Amharic (sera (m17n))

You have to reboot and check to not use Plasma Wayland.

how can i check i'm not using Plasma Wayland??


In the lower left corner it says:

Desktop Session: Plasma

If you click on it, one of them should say something with Wayland. Choose the other one.

after reboot my system language partially changed like this

and i dont have the option to choose this

Did you choose the System language and not the keyboard layout?

When you start your computer you are not asked for a password?

ok now the system language changed back to english by resetting to default.
but the amharic keyboard is not working

There is no option for Amharic at all? Or does it only partially work?

EDIT: You should work through this troubleshooting section. The Kimpanel seems to be a good way to go.

after i reset my language preference and installing ibus-m17n with

and reboot.

i found Amharic (sera (m17n)) under amharic language with 2 variants
and it works fine !!!

thanks again :pray:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by