An AUR package stopped working after an update

The normal reasons

Generally, there will be two reasons why an AUR package has "stopped working":

  1. A repo package was updated and the AUR package was built against an older (and incompatible) version of that repo package;

  2. The AUR package was updated and requires a repo package version not present in Manjaro stable.

The solutions to these:

  1. Rebuild the AUR package.

  2. One of:

    • Revert the AUR package to the version which works with stable;
    • Wait for stable to catch up;
    • Switch up to the testing or unstable branches to get the newer libraries faster.

The other reasons

The other, less frequent reasons, are

  1. The package file (PKGBUILD) has an issue and needs to be fixed;

  2. The upstream software has broken in some way'

In these cases, once you have exhausted your own local testing/troubleshooting, the issue needs to be reported:

  1. To the AUR package maintainer via the comment area on the AUR package page;

  2. To the upstream project (e.g. on their issue tracker).

This way the issue can be fixed for everyone.

The further information (or, "But why???")

AUR "packages" are community-added and maintained package description files, not a ready-made package.

With a repo package the package maintainer maintains the package. With an AUR package you are the package maintainer, so you are responsible for maintaining the package.

AUR packages are targeted at Arch stable (so Manjaro unstable).

When software library versions change their features and way they work can also change. These changes are normally backwards-compatible, but not always, and almost never are they forward-compatible.

This means a package built with a new library version will rarely work with an older library version (not forward-compatible), and it's also the reason why "partial upgrades" can break things.

Hence, software compiled against certain software libraries needs to be re-compiled when those libraries change.

As the package file maintainer, you need to recompile the software in the AUR package file you maintain for your own system(s).

Networkmanager update
dependencies problem: installing x265 (3.1.1-1) breaks dependency '' required by ffmpeg
youtube-dl GUI is not working [solved]
[Solved] Version Mismatch between Virtualbox On Manjaro Repos and Virtualbox Oracle Extensions On AUR
chromium-vaapi-bin needs ICU 64
CIN-gg don't launch itself any more - Solved
[SOLVED]Xiphos problem
Forged Alliance Forever client crashes on start
[Stable Update] 2020-02-28 broke QVR Pro Client
Chromium broke after update
[Testing Update] 2019-08-12 - XFCE 4.14, LibreOffice 6.3, Kernels, LibInput 1.14, Haskell
skypeforlinux doesn't work anymore after updating
AUR disclaimer
[Testing Update] 2018-09-23 - Kernels, Gnome 3.30, Cinnamon, Deepin, LibreOffice
Program Needing Older Version of Protobuf
RetroShare crashing in libcrypto since Stable Update 2018-10-08
TeamViewer GUI broken
Vivaldi having issues
Lib32-libcanberra "desc: bad message" error
applications wont start.
namcap installed but can't be found by yaourt
Browsers Not Working Correctly After Latest Update
After update ICU: cannot open shared object file
`r-mkl` not working after update
Minitube 3.0.1 has gone haywire!
Strange behavior of seekbar in Clementine-qt5-git
Kernel bugs
Cannot run a python application - HMRC Basic Paye Tools
Problem connecting to Google hangouts with kde telepathy
XFCE -- rolled up from ver. 17 ISO (non-gtk3) - seek troubleshooting strategies - non critical
Need to downgrade opencv to 3.4
Minitube-aur again
pCloud-drive stopped working.
[Stable Update] 2019-09-05 - Kernels, Mesa 19.1.5, XFCE 4.14, KDE, Nvidia 435xx, LibreOffice
gendesk compiled versus an old in manjaro32 stable
Package for AUR not open files in which the name contains russian letters
Can't start mongodb on Raspberry Pi 4
Kernel 5.3 and 5.2 rtl8723de fail to build
Google Chrome slow, occasionally crashes, Fontconfig error, Fontservice error
Spotify suddenly not working
asbru-cm cannot start after upgrade
I-nex is Now Broken
R-Studio Fails to Launch Due to boost-libs Update - Help with Downgrading
Unknown module(s) in QT: webkit webkitwidgets, but working on Arch
Can not install ffmpeg-full
AUR packages breakage report in the Updates Announcements
Plex Media Player (AUR) needs a rebuild after Testing Update 2020-05-03
[Stable Update] 2020-05-08 - Kernels, KDE-git, Plasma 5.18.5, Firefox 76.0, Pamac 9.5rc, Pop-Shell
TrueConf postinstall problems
[SOLVED] Problem with remote desktop after update
TrueConf postinstall problems
[SOLVED] Amdgpu breaks dependency when trying to update

Forum kindly sponsored by