android-tools: adb complains of missing libprotobuf-lite.so.22

I'm on a pinebook pro, with the latest 20.06 updates. I installed android-tools, and adb fails with:

$ adb
adb: error while loading shared libraries: libprotobuf-lite.so.22: cannot open shared object file: No such file or directory

I have the main protobuf packages installed. I'm not sure what provides the lite version of the library.

I'm having this same issue and have searched everywhere and cannot seem to find the answer at all. Someone please help! I need adb to work.

Protobufuf provides libprotobuf-lite.so but on my machine its libprotobuf-lite.so.23

pacman -Qi libprotobuf-lite.so

I assume you are using adb from package android-tools from repo ?
What version is it?

pacman -Qi android-tools

so this is what I get. I'm not too sure what I'm looking at as I'm new to this.

[daveed@Daveed ~]$ pacman -Qi libprotobuf-lite.so
Name : protobuf
Version : 3.12.0-1
Description : Protocol Buffers - Google's data interchange format
Architecture : aarch64
URL : https://developers.google.com/protocol-buffers/
Licenses : BSD
Groups : None
Provides : libprotoc.so=23-64 libprotobuf.so=23-64 libprotobuf-lite.so=23-64
Depends On : gcc-libs glibc zlib
Optional Deps : None
Required By : android-tools
Optional For : None
Conflicts With : None
Replaces : protobuf-cpp
Installed Size : 9.37 MiB
Packager : Arch Linux ARM Build System builder+n1@archlinuxarm.org
Build Date : Tue 02 Jun 2020 08:45:53 AM EDT
Install Date : Sun 28 Jun 2020 05:54:51 PM EDT
Install Reason : Installed as a dependency for another package
Install Script : No
Validated By : Signature

[daveed@Daveed ~]$ pacman -Qi android-tools
Name : android-tools
Version : 29.0.6-1
Description : Android platform tools
Architecture : aarch64
URL : http://tools.android.com/
Licenses : Apache MIT
Groups : None
Provides : fastboot adb
Depends On : pcre2 libusb protobuf
Optional Deps : python: for mkbootimg script [installed]
python2: for unpack_bootimg & avbtool scripts [installed]
Required By : None
Optional For : None
Conflicts With : fastboot adb
Replaces : None
Installed Size : 7.50 MiB
Packager : Arch Linux ARM Build System builder+seattle@archlinuxarm.org
Build Date : Fri 06 Mar 2020 03:09:49 PM EST
Install Date : Mon 29 Jun 2020 11:03:32 PM EDT
Install Reason : Explicitly installed
Install Script : No
Validated By : Signature

[daveed@Daveed ~]$

So as on mine you are getting 23+, not 22.

OK .. so this is a slightly older version. Arch-ARM is at the same version but on x86_64 we have
android-tools 30.0.0-2
So .. this package needs an update/rebuild.
See the x86_64 Arch updates: https://git.archlinux.org/svntogit/community.git/log/trunk?h=packages/android-tools

..but hold on a tic..
https://archlinuxarm.org/packages/aarch64/android-tools/files/PKGBUILD

The arch-arm package version number in the repos is 29 .0.6-1 ... but the PKGBUILD above clearly states 30.0.0-2 and is identical to the x86_64 PKGBUILD.

So.. make sure you are up to date:

sudo pacman -Syyu

If you dont see anything related change then ..

..I guess lets just see about forcing it:

wget http://mirror.archlinuxarm.org/aarch64/community/android-tools-29.0.6-1-aarch64.pkg.tar.xz
sudo pacman -U android-tools-29.0.6-1-aarch64.pkg.tar.xz
1 Like

I appreciate you sharing this with us. However, when I did the sudo pacman -Syyu it told me that there was nothing to do. As for the forcing android-tools, I'm not quite sure I understand what I need to do. I tried downloading from the link you posted above but after installing it came back with the same error. Is there a way you can dumb down the instructions for those of us who aren't sure what actions we need to take exactly?

The instructions is just download and install that package..
If nothing changed .. I wonder if we can force a rebuild:
(I will comment things so you can see whats happening)

# lets make a directory to do our stuff in and move there
mkdir -p android-tools && cd android-tools
# then lets download each of the required files to build it ourselves
wget {https://archlinuxarm.org/packages/aarch64/android-tools/files/PKGBUILD,https://archlinuxarm.org/packages/aarch64/android-tools/files/bash_completion.fastboot,https://archlinuxarm.org/packages/aarch64/android-tools/files/boringssl-disable-thirdpartydeps.patch,https://archlinuxarm.org/packages/aarch64/android-tools/files/deployagent.jar,https://archlinuxarm.org/packages/aarch64/android-tools/files/fix_build_core.patch,https://archlinuxarm.org/packages/aarch64/android-tools/files/generate_build.rb} 
# now to use makepkg to build and install and clean up after itself
makepkg -sric

..let me know how it goes

I'm having this same issue

...and did you try the things in the post right above yours ?

This often happens with the Arch Linux ARM PKGBUILDs and is usually caused by the ALARM team pulling in the PKGBUILD from Arch, but it then fails to build.

I tried building this a few weeks back, but I also was not able to build it at the time.

installing that package produced the same error for me, and pacman -Syyu didn't catch anything new.

Please read the rest of the thread ^

I'm trying this now-- but did want to note that I had to strip HTML out of the downloaded files.

ah sorry ... it seemed to work here .. but yeah however you get em :wink:

I got this issue when trying these instructions. The first part worked for me though.

ERROR: Failed to source /home/daveed/android-tools/PKGBUILD

This is what I get

daveed@Daveed android-tools]$ makepkg -sric
/home/daveed/android-tools/PKGBUILD: line 1: syntax error near unexpected token newline' /home/daveed/android-tools/PKGBUILD: line 1: '

This looked like it was going pretty well, but my de-HTMLified version of the jar file was invalid.

Ultimately, my need for this isn't urgent-- I just wanted to highlight the problem. Is there a better way to report this issue?

yes, but doesn't work

[alucard@manjaro android-tools]$ makepkg -sric
/home/alucard/android-tools/PKGBUILD: line 1: syntax error near unexpected token `newline'
/home/alucard/android-tools/PKGBUILD: line 1: `<!DOCTYPE html>'
==> ERROR: Failed to source /home/alucard/android-tools/PKGBUILD

Hi,

Sorry, I have no pinebook, but I installed the android file transfer on each devices I have with pamac and not pacman, no problem to share the phone files or share the internet connection of the cell phone with the devices.

android file transfer installed

android-tools

only android file transfer is installed

android-tools_2

A workaround is to downgrade protobuf.
I used protobuf-3.11.4-1 from here
Works for me.

$ uname -a
Linux pbp 5.8.0-2-MANJARO-ARM #1 SMP Mon Aug 3 22:33:13 CEST 2020 aarch64 GNU/Linux
$ sudo pacman -Qs protobuf
local/protobuf 3.11.4-1
Protocol Buffers - Google's data interchange format
$ adb version
Android Debug Bridge version 1.0.41
Version 29.0.6-1
Installed as /usr/bin/adb

Forum kindly sponsored by