Annoying Intel Graphics issue, system becomes slow over time

Hi, Manjaro forum. I just installed this lovely distro on my PC running from Ubuntu because of one particular issue, I wrote this looking for help on their forum (with no response) so I hope someone can help me diagnose this problem:

"First of all, I use a old PC. Intel Pentium Dual Core at 2.00 ghz and Intel G41 as the iGPU.

When changing from marco (in Ubuntu Mate, but GPU compositing in general as it happens with other ubuntu 17.10 flavor I've tried) things run fine, no tearing, normal performance.

Then some time into actually using the PC things start to slow down like firefox lagging and choppy performance overall. What I see is that CPU 2 is usually running 30% more when compared to CPU 1. Then it justs slows down to a crawl (not mouse input though, it still normal) and the high CPU 2 usage stops. The only way to recover from this (if I manage to get to Mate Tweak with the sluggishness) is switching back to Marco (software) or no compositing at all. And if I don't do that rebooting the PC solves the problem temporally.

I've tried everything, even deactivating the Intel microcode in propietary drivers but one moment later rendering slows down like trying to run Skyrim on a pentium 4 CPU. Again, this happens on Xubuntu and Kubuntu (don't know the others) but Ubuntu Mate is my main one :frowning:

And yes, this does not happen on 16.04 as far as I know"

Turns out minutes into installing Manjaro and happily reading stuff on this forum THE SAME THING HAPPENS. No GPU compositing involved

head boils

So, I did some research and some people reported having issues with the new Linux Kernel (also on Ubuntu 17.10, which I'm not going back after trying Manjaro ;), ). I'll do that and look at the results but I post this just in case anyone has faced this same issue. It would also be helpful to know any way to diagnose the problem via logs or something

Which installer (edition and version) did you use to install Manjaro?

From what?

If you can also post the output of inxi -Fxxxz we'll also get a better idea of the hardware you have.

Overall, though, it sounds like either a memory leak or overheating.


(moved from #general-discussion to #newbies as it's not a discussion item; edited thread title from "Annoying Intel Graphics issue" to "Annoying Intel Graphics issue, system becomes slow over time" to provide more detail)

I installed Xfce stable. Marco is the window manager on Mate. I discard overheating as I actually checked that one out a few days ago and everything’s fine.

Also, there’s no high memory usage or anything, it’s CPU related.

I just turned off sync to vblank on setting and things get normal again, just like turning back software compositing on Mate when this exact problem happens but it comes back again when I enable it.
[/quote]

If you could read my post again and answer each of the points as fully as you can it will speed this up no end. :wink:

You might also have a read of:

Shot in the dark, but could it be an issue with GPU acceleration? I think that GPU was the GMA X4500 (not to be confused with HD 4xxx), which is super old. You could check your BIOS and try assigning more RAM to it (if you have RAM to spare). Its possible the gpu is dumping some of the load onto the cpu?

You could also try other DE's to see if its something specific to DE.

Does it happen when running Manjaro from the live cd?

There's not a lot of point trying to guess what's going on here. The OP apparently installed Xfce but is running Marco (not Xfwm), and also refers to hardware compositing which Marco doesn't have.

OP really needs to provide more information.

For example, a "Pentium Dual Core" could even be a 32-bit chip...

1 Like

Hi again, no. It's a 64 bit processor. And no, I'm not running marco on Xfce (is that even possible?) and yes, it can be paired with Compton for hardware compositing. I'm not a total noob :smile:

This is the inxi -b output:

[lenin@lenin-pc ~]$ inxi -b
Resuming in non X mode: xrandr not found. For package install advice run: inxi --recommends
System:    Host: lenin-pc Kernel: 4.14.10-2-MANJARO x86_64 bits: 64
           Desktop: N/A Distro: Manjaro Linux
Machine:   Device: desktop Mobo: ASRock model: G41M-VS3. serial: N/A
           BIOS: American Megatrends v: P1.80 date: 05/18/2012
CPU:       Dual core Intel Pentium Dual E2180 (-MCP-) speed: 2008 MHz (max)
Graphics:  Card: Intel 4 Series Integrated Graphics Controller
           Display Server: N/A drivers: intel (unloaded: modesetting)
           tty size: 80x24
Network:   Card-1: Qualcomm Atheros AR8152 v2.0 Fast Ethernet driver: atl1c
           Card-2: Qualcomm Atheros AR9485 Wireless Network Adapter
           driver: ath9k
Drives:    HDD Total Size: 500.1GB (21.1% used)
Info:      Processes: 131 Uptime: 9 min Memory: 1195.3/3885.7MB Init: systemd
           Client: Shell (bash) inxi: 2.3.53 
[lenin@lenin-pc ~]$

Yes its an old one, but doing some research shows that there are no reported issues with this specific GPU (now there is :frowning:) . it happens with Xfce, mate and KDE, this is why I think it could be a new kernel issue. Yes, it also happens on Live CD, even with other distros.

I'll try your suggestion.

I can confirm now that either assigning more RAM or downgrading kernel to 4.9 did it for me!

So... could you confirm whether it was one or the other? It may help others in the future.

I'm betting on the kernel, but it would be interesting to find out

Sorry for the late response. Yes, it's a kernel thing. I used an older one and it stopped crashing, tried the same with other distros with the same result.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by