Another "can't boot after clean install" post

Sorry, I misread the last post.

EDIT. Maybe this will help:

To fix, first try choosing the fallback image from your bootloader, as it is not filtered by autodetect . Once booted, run mkinitcpio on the new machine to rebuild the primary image with the correct modules. If the fallback image fails, try booting into an Arch Linux live CD/USB, chroot into the installation, and run mkinitcpio on the new machine. As a last resort, try manually adding modules to the initramfs.

If you use manjaro-architect, install without enabling hibernation. The hibernation support is quite flaky there.

Good to know. I should note that I did not use manjaro-architect for this install. I used Calamares and simply selected "Erase drive".

I'm at home now, so I can't look into this again until tomorrow (or maybe Monday). I will try mkinitcpio first thing once I'm back though!!!

1 Like

others have had issues with nvme's not being detected early enough and causing problems. let me see if i can dig up the past fixes

do you have the drive/s set as raid in bios? if not intentional, change to AHCI.

this should keep the nvme from going to its lowest power state and being ignored, add to parameters in grub:

then it seems you were not chrooted into your current install. from a manjaro live usb:
manjaro-chroot -a
it may or may not ask you to select a number, choose 1 even if its not listed. should look something like this:

~ >>> manjaro-chroot -a                                                                        
[sudo] password for dglt: 
==> Mounting (ManjaroLinux) [/dev/sdb2]
 --> mount: [/mnt]
 --> mount: [/mnt/boot/efi]
[dglt-ob /]# 

while your chrooted in, check /etc/fstab and make sure it matches output of blkid and make corrections to fstab if necessary.
also make sure in /etc/default/grub that this line is commented out with #
and make sure the resume UUID is correct. save>exit> sudo update-grub

Refer to this topic here. Use the [More Compicated Setups] and boot to prompt by adding '3' at Step 6.
You don't have to use livecd. Just do 'it' at your grub menu.

Below is some clarifications to make clear.

  1. At grub menu, press 'c' at the menu and we’ll get to the grub prompt (grub>).
  2. grub> search.file /etc/manjaro-release
    Any output?
  3. If yes continue
    grub> search.file /etc/manjaro-release root
    grub> probe -u $root --set=abc
    grub> ls ($root)/boot/
  4. grub> linux /boot/vmlinuz-4.19-x86_64 root=UUID=$abc rw 3
    grub> initrd /boot/initramfs-4.19-x86_64.img
    grub> boot
  5. Does that boot to prompt? Login with password.
  6. Let us know.

then it seems you were not chrooted into your current install. from a manjaro live usb: manjaro-chroot -a

Yep. Good call. Was using chroot not manjaro-chroot. My /etc/default/grub has #GRUB_DISABLE_LINUX_UUID=true properly commented. The UUID's are correct in /etc/fstab except that there are two swap partitions. Weird:

# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=4F55-0B41                            /boot/efi      vfat    defaults,noatime 0 2
UUID=c2a1511e-2a50-482a-9570-6f1396f0e902 /              ext4    defaults,noatime 0 1
UUID=31dddf24-663d-4c12-9ee9-83617efd16d6 swap           swap    defaults,noatime 0 2
UUID=85f9fb08-1b4f-4292-bf8e-9b359b48916e swap           swap    defaults,noatime 0 2

I should note that I didn't manually create partitions or anything during this install. I simply used the defaults. I also tried adding nvme_core.default_ps_max_latency_us=5500 to kernel parameters but to no avail.

Just tried booting from the fallback image on my bootloader. No cigar.

  1. Done
  2. Yes: hd3, gpt2
  3. Done.
  4. Done.
  5. Nope.
  6. :cry:

@gohlip @dglt @kainonergon @Chrysostomus @anon27588196 Sorry for the individual separate posts, guys. Just saw the recommendation not to do that.

At this point, what do you think about me re-installing using some suggested minimal configuration via marjaro-architect? Then I can retrace my steps, repeat some of your suggestions, and things will be a bit simpler? Or would it be better to keep going as is?

Try removing the line
UUID=85f9fb08-1b4f-4292-bf8e-9b359b48916e swap swap defaults,noatime 0 2
from your fstab. Change also the kernel parameter by editing grub so that that UUID is not mentioned. Won't hurt, might help.

Just tried. Same output as before:

:: running early hook [udev]
starting version 239
:: running early hook [lvm2]
:: running hook [udev]
:: Triggering uevents...
:: running hook [keymap]
:: Loading keymap...done.
:: running hook [resume[
ERROR: resume: no device specified for hibernation
Waiting 10 seconds for device /dev/disk/by-uuid/c2a1511e-2a50-482-9570-6f1396f0e902 ...
[   39.947134] sd 9:0:0:0: [sdb] No Caching mode page found
[   39.947134] sd 9:0:0:0: [sdb] Assuming drive cache: write through
:: mounting 'UUID=c2a1511e-2a50-482a-9570-6f1396f0e902' on real root
mount: /new_root: can't find UUID=c2a1511e-2a50-482a-9570-6f1396f0e902.
You are now being dropped into an emergency shell. 
sh: can't access tty; job control turned off
[rootfs ]# _

Have you tried to chroot with manjaro-chroot and run mkinitcpio -P ?

Sorry I missed this one earlier. Just tried it; same result.

Somehow installed system fails to see the nvme drive during init process, but grub can boot kernel and initrd from the same nvme drive. And there is no separate boot partition. Really strange. I am out of ideas what else to try. Maybe reinstall is the only option.

i didnt notice this until now, in bios set the SATA controller to AHCI instead of RAID and your nvme ssd should work fine. you may have to reinstall, maybe not, idk. but this should take care of the issues your having, it happens on some XPS models also and thats the fix.


Unbelievably, the SATA controller was already set to AHCI (not RAID). I also tried disabling Intel VMD Technology, same result. Any other place this needs to be disabled? Did something go wrong during install?

In BIOS, if I go to "Other Options", select "Device configuration", and select the tab "Intel (R) Virtual RAID on CPU, it reads "No RAID volumes on the system". This may not be relevant - just trying to provide as much info as possible.

is there a way to possibly disable virtual raid and test it out?
i dont know if this is a possibility, does your system use intel optane? again, i dont know but you could try disabling some of the "unknowns" in bios and see if it changes anything.

also check your mkinitcpio hooks and make sure the right ones are included
cat /etc/mkinitcpio.conf
edit if need be, try with/without autodetect, there are examples explaining how it works in mkinitcpio and also man page iirc

It's working now. Finally.

I decided to re-install using manjaro-architect in an attempt to reduce the number of unknowns. I created a simple install using only two partitions: an efi boot, and a root partition (no swap, to eliminate the possibility of hibernate causing problems).

After this I was still receiving a similar error message on boot, i.e.

mount: /new_root: can't find UUID=..... ```
You are now being dropped into an emergency shell.

From this page I tried adding nvme to the MODULES list in /etc/mkinitcpio.conf and running mklinitcpio -p linux419, and rebooting, while manjaro-chroot'd of course. Still, same result. (I tried other combinations of HOOKS without success before my re-install).

I then went through every BIOS option and decided to disable anything that I thought could possibly cause problems. I found three things and disabled two: Intel VMD technology (which I had disabled before had re-enabled for the sake of trying to isolate issues) and Virtualization Support. I disabled virtualization, which I originally did not want to do since I use virtual machines quite a bit, but after this I rebooted with success. I think this was the root issue and not the lack of nvme in my mkinitcpio.conf, but I'm too worn out to go back and figure this out now. If others would benefit from it, let me know and I will restore mkinitcpio.conf to its default and try again.

I thought that this BIOS option was only for CPU virtualization and didn't have anything to do with RAID? But indeed, RAID does not show up in my output of inxi -Fxzc0 now.....

THANK YOU all for the help. I would be out on streets if you wasn't for you


maybe after a full update, try turning virtualization only back on and see if it causes a non-boot situation. anyway, glad to hear you were able to get it going. :+1:

Forum kindly sponsored by