Any chance of setup a HP MFP via hplip? (Color Laser MFP 179fnw)

Hi, it's so frutrating reading all the opened and unsolved threads regarding to hplip. A long time it was so easy to setup any HP Printer but currently i find no way to getting one to work. Is that a special Arch/Manjaro thing? Is there any suitable way that I miss? Are HP printers no longer recommended to use under Manjaro?
I enabled cups and started it manually several times, I tried hp-setup -i, -u, -g. Every-time appears another Error.
Please, help me.

Some hp models need specific plugins, for example the hplip-plugin:
https://wiki.archlinux.org/index.php/CUPS/Printer-specific_problems#HP

Did you see this thread:

Yes, I know all these threads. I can access the printers config page using http or https, no problem at all. But hplip doesn't find the device. I'll send it back and try a different model.
Thank you anyway!

HPLIP couldn't find my HP Laser-jet Pro P1102W.
I found this article:https://bugs.archlinux.org/task/64801
It was mentioned in this topic: [HPLIP (hp-setup) does not detect my HP printer after a clean installation of manjaro](HPLIP (hp-setup) does not detect my hp printer after a clean nstallation of manjaro)
I had to change the models.dat file (/usr/share/hplip/data/models/).
The name for my printer in that file was: hp_laserjet_professional_p_1102w, while hplip was searching for a slightly different name: hp_laserjet_professional_p1102w
(The underscore between p and 1102w was the reason that hplip could not find my printer).

I still have a problem with hplip 3.19.12 that i cannot install the plugin, that is required for the p1102w.
The plugin is downloaded with an error message about a key that could not be retrieved from the key server. But, after continuing, i get a message that the installation of the plugin was successful.
But in fact it was not successful and the P1102W can still not be used with the HP Toolbox or hplip because of the missing plugin.

I have posted a new topic about the hplip disaster, describing solutions for detecting the printer and for installing the plugin.

Any further leads to solutions will be appreciated - I'm new to this and am just now having the same issue.... there are very few HP printers available through the online CUPS website, and what worked with another OS does not work since I moved to Manjaro.

that's because you'll need to use hplip, CUPS alone doesn't contain the full database for HP multifunction devices. Find out from the page below if you also need to install the hplip-plugin

https://developers.hp.com/hp-linux-imaging-and-printing/supported_devices/index

also, what printer model? my MFP has worked out of the box since purchasing it with manjaro

1 Like

You need first to add two symbolic links before you can add a plugin.

sudo ln -s /usr/lib /usr/lib/i386-linux-gnu
sudo ln -s /usr/lib64 /usr/lib64/x86_64-linux-gnu

This topic was automatically closed after 90 days. New replies are no longer allowed.

Forum kindly sponsored by