Apple macbook 2009 with broadcom 4332 disconnect after sleep

I'm running Manjaro linux LTS with Cinnamon on Macbook from 2009.
The driver is Broadcom wireless chip:

mve@Aftermath ~> lspci | grep Wireless
03:00.0 Network controller: Broadcom Inc. and subsidiaries BCM4322 802.11a/b/g/n Wireless LAN Controller (rev 01)

I've noticed that if I close the lid and my laptop goes to sleep, it isn't able to reconnect to my wifi network (which is a mess/tp link deco m5), eventually after restarting NetworkManager it will connect but I would prefer it if my wifi reconnects at once after waking up after sleep mode :wink:
PS, I don't have this issue with Ubuntu/Linux Mint and their closed sourc BCM driver.

My error:

ERROR @wl_cfg80211_scan :
WLC_SCAN error (-22)
IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready

And the last one repeats itself for a couple of times ..

If anyone knows what to try to fix this error I'm more then grateful :slight_smile:

Thanks for any hint, tip or help!

I would go by this

but read the comment above it too.
Also see this


Also, did you tried hibernate and does the same thing?
You could disable IPv6 if you don't use it.

1 Like

Thanks! I tried to disable IPV6 but I still see those errors and tried your first advice (b43.conf).
Put my laptop to sleep for 10 mins and then reopened it and logged in and it is connecting (after 1 - 2 mins)!
That is great news!
I will check it the coming days if this is/was my fix :slight_smile:

Thanks again!

Sadly with my 2nd attempt I still got disconnects, a disable/enable wifi fixed it but still annoying..
Still the same error:

[15073.004931] ERROR @wl_cfg80211_scan : 
[15073.004935] WLC_SCAN error (-22)
[15080.016122] audit: type=1131 audit(1553102556.783:99): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=NetworkManager-dispatcher comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[15099.547738] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
[15125.006358] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
[15125.009516] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
[15128.546020] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready

I disabled IPV6 with network manager and sysctl.d/40-*.conf and rebooted my laptop but will try for the other solutions.
I do have the feeling it's faster in reconnecting though.

I also got the following information:

mve@Aftermath ~> modprobe --showconfig | egrep "^install|blacklist"
blacklist b43
blacklist b43legacy
blacklist ssb
blacklist bcm43xx
blacklist brcm80211
blacklist brcmfmac
blacklist brcmsmac
blacklist bcma
blacklist nouveau
blacklist ttm
blacklist drm_kms_helper
blacklist drm
install libnvdimm /usr/bin/ndctl load-keys ; /sbin/modprobe --ignore-install libnvdimm $CMDLINE_OPTS
alias symbol:ceph_monc_blacklist_add libceph

Shouldn't the b43 module be enabled?

Not if you're using the proprietary wl driver.

If you want your wifi to work after resuming then writing a service is generally the best way to do that.

Forum kindly sponsored by