Application GUI Bug

Hey there,

I used the Deepin Desktop Environment until last week and then changed to Gnome. Uninstalled the deepin stuff because the new update made it unusable. Gnome seems to work out much better but I still have some problems. One of them is that some of my application windows are buggy. See here:

Some specs which could be usable:

OS: Manjaro 20.0.3 Lysia
Kernel: x86_64 Linux 5.4.49-1-MANJARO
Uptime: 5m
Packages: 1617
Shell: bash 5.0.17
Resolution: 1600x900
DE: GNOME 3.36.3
WM: Mutter
WM Theme: Matcha-aliz
GTK Theme: vimix-light-beryl [GTK2/3]
Icon Theme: breeze
Font: Noto Sans 11
Disk: 45G / 107G (44%)
CPU: Intel Core i5-7200U @ 4x 3.1GHz [52.0°C]
GPU: Mesa Intel(R) HD Graphics 620 (KBL GT2)
RAM: 2290MiB / 7746MiB

If I start the apps from the console, I get the following output:

qt.qpa.xcb: QXcbConnection: XCB error: 5 (BadAtom), sequence: 554, resource id: 0, major code: 20 (GetProperty), minor code: 0

Someone has an idea what to do?

Thank you


Install qt5ct and kvantum-qt5 packages and set the qt5 style to it and chose a theme from kvantum manager to suit your gtk+ theme.

Isnt this no longer the preferred method?
Dont we want to set in /etc/environment

# This top one might be a matter of choice .. remove # to use
1 Like

It could be. My installs are still using the qt5ct even after update in unstable. I will try a fresh install and see the difference. Thanks for pointing that out.

Thank you guys for you fast reply.
I tried it with both methods, unfortunately nothing changed. Except the issue that after boot my screen was on 0 brightness until I configured it with the FN keys. Now I have normal brightness after boot.
But still the window trouble. The window of Kvantum-Manager itself is broken.
qt5ct and kvantum-qt5 was already installed, I renamed the .config/qt5ct folder and reinstalled both.

I wonder if all this is not because of some leftovers from Deepin configs that still load. Not sure how to go about investigating this. I would insist on strictly going with the suggestion from @cscs and nothing else.
Try to create a new TEST user and see if the issue persists.
Have you installed the manjaro-gnome-settings and copy the files from /etc/skel/ to your home directory? (might want to proceed this with caution tho)

Alright. I created the new user and everything worked. I replaced now only the .config folder with the one in /etc/skel/ and everything is working now as well.
So I don't know what the exact problem was, but something in the .config directory in combination with the envs.
Thank you guys!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by