Apps Don't Launch; Font-Size

Hello everyone I've just installed Manjaro Gnome it's my first linux distro so I've already faced some issues
1.The main one is some installed apps don't run; for example pre-installed steam, vs code, persepolis download manager and some others too;
In case of vs code I tried two versions one from snap and official one; snap version works
Pre-installed steam didn't work at first, then installed snap version and now both of them launch :smile:
2.I'll ask here as well how can i change font size everything seems to be very small in browsers I mean and in apps as well

Hi there.

Lets start with basics:

inxi -Fxxxza --no-host

That will give us system info.

sudo pacman-mirrors -f && sudo pacman -Syyu

That will sort/rank your mirrors and sync and update.

Also see this:

Thanks for quick response

System:
  Kernel: 5.6.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.6-x86_64 
  root=UUID=4dd3693a-9a11-4e73-b5cf-60be64a996ac rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: Gnome 3.36.3 wm: gnome-shell dm: GDM 3.34.1 Distro: Manjaro Linux 
Machine:
  Type: Laptop System: HP product: HP ProBook 450 G6 v: N/A serial: <filter> 
  Chassis: type: 10 serial: <filter> 
  Mobo: HP model: 8538 v: KBC Version 51.27.00 serial: <filter> UEFI: HP 
  v: R71 Ver. 01.10.00 date: 01/03/2020 
Battery:
  ID-1: BAT0 charge: 30.7 Wh condition: 42.5/42.5 Wh (100%) volts: 12.8/11.6 
  model: Hewlett-Packard Primary type: Li-ion serial: <filter> 
  status: Charging 
CPU:
  Topology: Quad Core model: Intel Core i5-8265U bits: 64 type: MT MCP 
  arch: Kaby Lake family: 6 model-id: 8E (142) stepping: C (12) 
  microcode: CA L2 cache: 6144 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 28808 
  Speed: 600 MHz min/max: 400/3900 MHz Core speeds (MHz): 1: 600 2: 600 
  3: 600 4: 600 5: 600 6: 600 7: 600 8: 600 
  Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: Intel UHD Graphics 620 vendor: Hewlett-Packard driver: i915 
  v: kernel bus ID: 00:02.0 chip ID: 8086:3ea0 
  Display: wayland server: X.org 1.20.8 driver: i915 compositor: gnome-shell 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: Mesa Intel UHD Graphics 620 (WHL GT2) v: 4.6 Mesa 20.0.7 
  direct render: Yes 
Audio:
  Device-1: Intel Cannon Point-LP High Definition Audio 
  vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
  chip ID: 8086:9dc8 
  Sound Server: ALSA v: k5.6.16-1-MANJARO 
Network:
  Device-1: Intel Cannon Point-LP CNVi [Wireless-AC] driver: iwlwifi 
  v: kernel port: 4000 bus ID: 00:14.3 chip ID: 8086:9df0 
  IF: wlp0s20f3 state: up mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Hewlett-Packard driver: r8169 v: kernel port: 3000 bus ID: 01:00.0 
  chip ID: 10ec:8168 
  IF: enp1s0 state: down mac: <filter> 
Drives:
  Local Storage: total: 238.47 GiB used: 17.40 GiB (7.3%) 
  ID-1: /dev/nvme0n1 vendor: SK Hynix model: BC501 HFM256GDJTNG-8310A 
  size: 238.47 GiB block size: physical: 512 B logical: 512 B 
  speed: 15.8 Gb/s lanes: 2 serial: <filter> rev: 80002C00 scheme: GPT 
Partition:
  ID-1: / raw size: 238.17 GiB size: 233.43 GiB (98.01%) 
  used: 17.40 GiB (7.5%) fs: ext4 dev: /dev/nvme0n1p2 
Sensors:
  System Temperatures: cpu: 49.0 C mobo: 0.0 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 348 Uptime: 4h 24m Memory: 7.65 GiB used: 2.67 GiB (35.0%) 
  Init: systemd v: 245 Compilers: gcc: 10.1.0 Shell: zsh v: 5.8 
  running in: gnome-terminal inxi: 3.0.37 

It seems there is no need to upgrade system

:: Starting full system upgrade...
 there is nothing to do

Ah .. missing xdpyinfo so I dont see resolution.
You probably have xrandr installed... maybe we can see the output of that ?

sorry can you please specify what command should i use to see that?
i tried xdpyinfo and xrandir but none works

Maybe you have neither installed...

From package xorg-xrandr
Command: xrandr

From package xorg-xdpyinfo
Command: xdpyinfo | grep dimensions

xorg-xrandr is installed, just instaleed xdpyinfo

mk. So what is the output of

xrandr

sorry forgot to show
here it is

Screen 0: minimum 16 x 16, current 1920 x 1080, maximum 32767 x 32767
XWAYLAND0 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 340mm x 190mm
   1920x1080     60.05*+

Ah so current resolution is 1920x1080.
That doesnt seem like a super huge resolution. But HiDPI I would guess.
I am pretty sure Gnome has a 'scale' option for example 1.25x or 1.5x might suit you.

For the applications... I suggest picking one and running it from the terminal and seeing if anything shows so you can share here.

Traceback (most recent call last):
  File "/snap/persepolis/43/bin/persepolis", line 11, in <module>
    load_entry_point('persepolis==3.2.0', 'console_scripts', 'persepolis')()
  File "/snap/persepolis/43/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 480, in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
  File "/snap/persepolis/43/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 2693, in load_entry_point
    return ep.load()
  File "/snap/persepolis/43/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 2324, in load
    return self.resolve()
  File "/snap/persepolis/43/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 2330, in resolve
    module = __import__(self.module_name, fromlist=['__name__'], level=0)
  File "/snap/persepolis/43/lib/python3.6/site-packages/persepolis/scripts/persepolis.py", line 94, in <module>
    from persepolis.scripts.mainwindow import MainWindow
  File "/snap/persepolis/43/lib/python3.6/site-packages/persepolis/scripts/mainwindow.py", line 56, in <module>
    from persepolis.scripts.video_finder_addlink import VideoFinderAddLink
  File "/snap/persepolis/43/lib/python3.6/site-packages/persepolis/scripts/video_finder_addlink.py", line 27, in <module>
    import youtube_dl
  File "/snap/persepolis/43/lib/python3.6/site-packages/youtube_dl/__init__.py", line 15, in <module>
    from .options import (
  File "/snap/persepolis/43/lib/python3.6/site-packages/youtube_dl/options.py", line 8, in <module>
    from .downloader.external import list_external_downloaders
  File "/snap/persepolis/43/lib/python3.6/site-packages/youtube_dl/downloader/__init__.py", line 3, in <module>
    from .common import FileDownloader
  File "/snap/persepolis/43/lib/python3.6/site-packages/youtube_dl/downloader/common.py", line 9, in <module>
    from ..compat import compat_os_name
  File "/snap/persepolis/43/lib/python3.6/site-packages/youtube_dl/compat.py", line 2348, in <module>
    import http.server as compat_http_server
  File "/snap/persepolis/43/usr/lib/python3.6/http/server.py", line 619, in <module>
    class SimpleHTTPRequestHandler(BaseHTTPRequestHandler):
  File "/snap/persepolis/43/usr/lib/python3.6/http/server.py", line 827, in SimpleHTTPRequestHandler
    mimetypes.init() # try to read system mime.types
  File "/snap/persepolis/43/usr/lib/python3.6/mimetypes.py", line 355, in init
    db.read(file)
  File "/snap/persepolis/43/usr/lib/python3.6/mimetypes.py", line 204, in read
    with open(filename, encoding='utf-8') as fp:
PermissionError: [Errno 13] Permission denied: '/etc/httpd/conf/mime.types'

it's for persepolis

Thats a snap .. they are suspposed to package everything together themselves. Cant help you there.
I meant a regular package. (repos or AUR)

Okay I'll try different program, thank you
sometimes system automatically logs me out what can be a reason?

I dont know .. but now we have 3 separate issues here.

Also .. it appears you are using 'wayland'
Maybe you might want to switch sessions to X11 as thats not as 'beta'
(choose at login screen)
and see if that works any better for you.

1 Like

thank you it seems better now

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by