Archlinux Installation Root Password Issue

I tried to install arch linux from the iso they provide. went through a normal process ie

  1. timedatctl set-ntp true
  2. cfdisk -z with dos config with 2 partitions root and swap
  3. create filesystems ext4 and swap
  4. mount the partitions
  5. pacstrap /mnt base base-devel linux linux-firmware nano dhcpcd
  6. genfstab -U /mnt >> /mnt/etc/fstab
  7. arch-chroot /mnt
  8. pacman -S grub
  9. grub-install /dev/sda
  10. grub-mkconfig -o /boot/grub/grub.cfg
  11. exit
  12. umount -R /mnt
  13. shutdown now.

when i restarted the computer after the fresh base install i was faced with being required to provide a root password that i have not even set yet. what's going on i wonder??

normally i would be faced with being able to access root without a password. i can't talk to arch linux devos as they are nasty

You should have set a root password before you reboot. Pretty sure it's in the Install Guide on the Arch wiki.

1 Like

i've never had to do this in the past.

In that case, you should asks the Arch developers if they have changed anything...

yeah i shall. infact i'm ircing them now

Follow the Arch wiki instructions to chroot and run:

passwd root


Please read-up here on why it is now needed to set a root password.


If you have not set a password - just hit Enter

Thanks to @philm - I didn't know that - I have just tried the other solution earlier - albeit - not recently :slight_smile:

I think it is an improvement - but I know of at least one member which would argue on freedom taken away.

it was suggested by Fedora's systemd developers ...

Moved from #manjaro-development:arch-collaboration to #other-os

thanks philm. i understand now

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by