[ARM Testing Update] 2020-05-14 - Plasma Frameworks, Cinnamon, Snapd and Kernels

Hello ARM community.

Another testing update for you all!

snapcraft


Some highlights:

  • Most of our kernels got updated
  • Plasma Frameworks is now at 5.70, which can result in slower animations
  • New point release of Cinnamon desktop, brings it to 4.6
  • Snapd got a major update with 2.45
  • Lots of python packages got updated

Upstream Notifications:

Older notifications

The nss package requires manual intervention:
https://www.archlinux.org/news/nss3511-1-and-lib32-nss3511-1-updates-require-manual-intervention/
The packages hplip and firewalld requires manual intervention:
https://www.archlinux.org/news/hplip-3203-2-update-requires-manual-intervention/
https://www.archlinux.org/news/firewalld081-2-update-requires-manual-intervention/


Package Changes Thu May 14 09:40:25 CEST 2020

  • arm-testing community aarch64: 155 new and 183 removed package(s)
  • arm-testing core aarch64: 9 new and 9 removed package(s)
  • arm-testing extra aarch64: 179 new and 181 removed package(s)
:: Different overlay package(s) in repository community aarch64

-------------------------------------------------------------------------------
                             PACKAGE          2020-05-10         2020-05-14
-------------------------------------------------------------------------------
                       libarchive-qt              2.0.0-1              2.0.2-1
                               snapd             2.44.5-1               2.45-1


:: Different sync package(s) in repository community aarch64

-------------------------------------------------------------------------------
                             PACKAGE          2020-05-10         2020-05-14
-------------------------------------------------------------------------------
                              acpica           20200326-1           20200430-1
                             ansible              2.9.7-1              2.9.9-1
                               ascii               3.18-2               3.18-3
                             avr-gcc              9.3.0-1             10.1.0-1
                             buildah             1.14.8-1             1.14.9-1
             cinnamon-control-center              4.4.0-1              4.6.0-1
                    cinnamon-desktop              4.4.1-1              4.6.0-1
                cinnamon-screensaver              4.4.1-1              4.6.0-1
                    cinnamon-session              4.4.1-1              4.6.0-1
            cinnamon-settings-daemon              4.4.0-2              4.6.0-1
                               clash             0.19.0-1             0.20.0-1
                              clinfo       2.2.18.04.06-1       2.2.18.04.06-2
                         cni-plugins              0.8.5-1              0.8.6-1
                     colorhug-client              0.2.8-1              0.2.8-2
                              conmon           1:2.0.15-1           1:2.0.16-1
                               copyq             3.10.0-1             3.11.1-1
                            cppcheck               1.90-2                2.0-1
                                dart              2.7.4-1              2.7.6-1
               elementary-icon-theme              5.3.0-1              5.3.1-1
                              erlang               22.3-1             22.3.4-1
                          erlang-nox               22.3-1             22.3.4-1
                     erlang-unixodbc               22.3-1             22.3.4-1
                          fanficfare             3.18.0-1             3.19.0-1
                       fcitx-chewing              0.2.3-2              0.2.3-4
                              fcitx5     0.0.0.20200509-3     0.0.0.20200513-2
                        fcitx5-anthy     0.0.0.20200509-2     0.0.0.20200513-1
               fcitx5-chinese-addons     0.0.0.20200509-2     0.0.0.20200513-1
                           fcitx5-qt     0.0.0.20200509-1     0.0.0.20200513-1
                   firefox-tridactyl             1.18.1-1             1.19.0-1
                            flashrom                1.2-1                1.2-2
                               fwupd              1.4.0-1              1.4.1-1
                               gitea             1.11.4-2             1.11.5-1
                        glew-wayland              2.1.0-5              2.2.0-1
                         go-ethereum             1.9.13-1             1.9.14-1
                              gopass              1.9.0-2              1.9.2-1
                              hcloud             1.14.0-3             1.16.2-1
                        ibus-chewing              1.6.1-1              1.6.1-3
                             img2pdf              0.3.4-1              0.3.6-1
                              jgmenu              4.1.0-1              4.2.0-1
                               kicad              5.1.5-2              5.1.6-1
                    kicad-library-3d              5.1.5-1              5.1.6-1
                       kicad-library              5.1.5-1              5.1.6-1
                                knot              2.9.3-1              2.9.4-1
                         kvantum-qt5             0.15.2-1             0.15.3-1
                              libime     0.0.0.20200509-1     0.0.0.20200513-1
                             libjcat              0.1.1-1              0.1.2-1
                  libretro-core-info              1.8.5-1              1.8.6-1
                      linuxdoc-tools             0.9.73-1             0.9.78-1
                       lxqt-archiver              0.1.1-1              0.1.1-2
                     man-pages-zh_cn            1.6.3.3-1            1.6.3.4-2
                     man-pages-zh_tw            1.6.3.3-1            1.6.3.4-2
                       mate-terminal             1.24.0-1             1.24.0-2
             mkinitcpio-systemd-tool                 35-1                 36-1
                             netdata             1.21.1-2             1.22.1-1
             nextcloud-app-bookmarks            1:3.0.4-1           1:3.0.12-1
                 nextcloud-app-tasks             0.12.2-1             0.13.0-1
                            parallel           20191122-1           20200322-1
                             perl-gd               2.71-1               2.71-2
                    perl-net-dns-sec               1.15-1               1.16-1
                  perl-text-markdown           1.000031-8           1.000031-9
                              podman              1.9.1-1              1.9.2-1
                       podman-docker              1.9.1-1              1.9.2-1
                    python-aspectlib              1.4.2-5              1.4.2-6
                    python-blessings                1.7-4                1.7-5
                     python-cfn-lint             0.30.1-1             0.31.0-1
                    python-chameleon              3.7.0-1              3.7.1-1
                python-click-plugins              1.1.1-4              1.1.1-5
                   python-cloudflare              2.6.5-1              2.7.0-1
                     python-cmarkgfm              0.4.2-7              0.4.2-8
                     python-curtsies              0.3.1-1              0.3.1-2
                python-dogpile.cache              0.9.0-1              0.9.1-1
                  python-easyprocess             0.2.10-1                0.3-1
                        python-faker              4.0.3-1              4.1.0-1
                         python-flup              1.0.3-3              1.0.3-4
                        python-geopy             1.21.0-1             1.22.0-1
                      python-hacking              3.0.0-1              3.0.0-2
                   python-hypothesis             5.11.0-1             5.13.0-1
                    python-jsonlines              1.2.0-4              1.2.0-5
                 python-jupyter_core              4.6.3-1              4.6.3-2
                   python-kiwisolver              1.1.0-3              1.1.0-4
               python-logilab-common              1.6.1-1              1.6.2-1
                   python-matrix-nio             0.10.0-1             0.11.2-1
                    python-memcached               1.59-4               1.59-5
                        python-munch              2.5.0-1              2.5.0-2
                   python-nosexcover             1.0.11-4             1.0.11-5
                    python-ntlm-auth              1.2.0-6              1.4.0-1
                   python-opt_einsum              3.1.0-1              3.2.1-1
                         python-oset              0.1.3-4              0.1.3-5
                     python-paramiko              2.7.1-1              2.7.1-2
                        python-paste              3.4.0-1              3.4.0-2
                         python-purl                1.5-3                1.5-4
                        python-pyaml             20.4.0-1             20.4.0-2
                        python-pyjwt              1.7.1-3              1.7.1-4
                      python-pylibmc              1.6.1-2              1.6.1-3
                       python-pynacl              1.3.0-3              1.3.0-4
                    python-pyrfc3339                1.1-4                1.1-5
                python-pytest-flake8              1.0.5-1              1.0.6-1
                python-pytest-pylint             0.15.1-1             0.17.0-1
                        python-raven             6.10.0-4             6.10.0-5
                        python-redis              3.4.1-1              3.5.1-2
                        python-regex           2020.4.4-1           2020.5.7-1
             python-requests-credssp              1.0.2-3              1.1.1-1
            python-requests-kerberos             0.12.0-4             0.12.0-5
                         python-rope             0.16.0-2             0.17.0-1
                      python-tzlocal              2.0.0-3                2.1-1
                    python-unidecode              1.1.1-3              1.1.1-4
                       python-uproot             3.11.5-1             3.11.6-1
                  python-uproot-docs             3.11.5-1             3.11.6-1
                        python-w3lib             1.21.0-3             1.21.0-4
                        python-xattr              0.9.7-1              0.9.7-2
                       python-xcffib              0.9.0-1              0.9.0-2
                           python-z3              4.8.7-1              4.8.8-1
                   python2-aspectlib              1.4.2-5                    -
python2-backports.ssl_match_hostname            3.7.0.1-1                    -
                   python2-blessings                1.7-4                    -
               python2-click-plugins              1.1.1-4                    -
                    python2-cmarkgfm              0.4.2-7                    -
                    python2-curtsies              0.3.1-1                    -
               python2-dogpile.cache              0.9.0-1                    -
                        python2-flup              1.0.3-3                    -
                     python2-hacking              3.0.0-1                    -
                   python2-jsonlines              1.2.0-4                    -
                python2-jupyter_core              4.6.3-1                    -
                  python2-kiwisolver              1.1.0-3                    -
                   python2-memcached               1.59-4                    -
                       python2-munch              2.5.0-1                    -
                  python2-nosexcover             1.0.11-4                    -
                      python2-openid              2.2.5-5                    -
                        python2-oset              0.1.3-4                    -
                    python2-paramiko              2.7.1-1                    -
                       python2-paste              3.4.0-1                    -
                        python2-purl                1.5-3                    -
                       python2-pyaml             20.4.0-1                    -
                       python2-pyjwt              1.7.1-3                    -
                     python2-pylibmc              1.6.1-2                    -
                      python2-pynacl              1.3.0-3                    -
                   python2-pyrfc3339                1.1-4                    -
                       python2-raven             6.10.0-4                    -
                       python2-redis              3.4.1-1                    -
                       python2-regex           2020.4.4-1           2020.5.7-1
           python2-requests-kerberos             0.12.0-4                    -
                     python2-tzlocal              2.0.0-3                    -
                   python2-unidecode              1.1.1-3                    -
                       python2-w3lib             1.21.0-3                    -
                       python2-xattr              0.9.7-1                    -
                      python2-xcffib              0.9.0-1                    -
                              qprint                1.1-1                1.1-2
                                raft             0.9.18-1             0.9.19-1
                                repo                2.5-1                2.7-1
                            restinio              0.6.6-1              0.6.7-1
                              retext              7.1.0-3              7.1.0-4
                           retroarch              1.8.5-1              1.8.6-1
              retroarch-assets-ozone              1:298-1              1:300-1
                retroarch-assets-xmb              1:298-1              1:300-1
                           ruby-rack              2.0.8-1              2.2.2-1
                ruby-rack-protection              2.0.5-2            2.0.8.1-1
                       rust-analyzer           20200504-2           20200511-1
                               smb4k              3.0.4-1              3.0.5-1
                              spyder              3.3.6-2              3.3.6-3
                             sysstat             12.3.2-1             12.3.3-1
                               tclap              1.2.2-1              1.2.2-2
                    telegram-desktop              2.1.4-1              2.1.5-1
                              tenshi               0.17-1               0.17-2
                          typescript              3.8.3-1              3.9.2-1
                             udiskie              2.1.1-1              2.2.0-1
                           uglify-js              3.9.2-1              3.9.3-1
         v2ray-domain-list-community       202005061230-1       202005130002-1
                         v2ray-geoip       202005060001-1       202005130002-1
                         vapoursynth                R49-2                R50-1
                           vdpauinfo                1.3-1                1.4-1
                        vim-nerdtree              6.6.1-1              6.7.0-1
                                wabt             1.0.13-1             1.0.15-1
      wingpanel-indicator-nightlight              2.0.2-1              2.0.3-1
                            xandikos              0.1.0-2              0.2.1-1
                               xapps              1.8.1-1              1.8.4-1
                                 xed              2.4.1-1              2.6.0-1
                           xlockmore               5.61-1               5.63-1
                                xpra              3.0.7-2              3.0.9-1
                               yaegi              0.8.0-1              0.8.4-1
                                  z3              4.8.7-1              4.8.8-1
             zsh-theme-powerlevel10k              1.7.0-2              1.8.0-1
                      python-feedgen                    -              0.9.0-1
                    python-junit-xml                    -                1.9-1
   ruby-minitest-global_expectations                    -              1.0.1-2
                ruby-minitest-sprint                    -              1.2.1-1
                  ruby-path_expander                    -              1.1.0-2


:: Different overlay package(s) in repository core aarch64

-------------------------------------------------------------------------------
                             PACKAGE          2020-05-10         2020-05-14
-------------------------------------------------------------------------------
                       linux-aarch64             5.6.11-1             5.6.12-1
               linux-aarch64-headers             5.6.11-1             5.6.12-1
                    linux-aarch64-rc            5.7.rc4-1            5.7.rc5-3
            linux-aarch64-rc-headers            5.7.rc4-1            5.7.rc5-3
                          linux-rpi4           4.19.120-1           4.19.122-1
                  linux-rpi4-headers           4.19.120-1           4.19.122-1
                     linux-rpi4-next             5.4.38-2             5.4.40-1
             linux-rpi4-next-headers             5.4.38-2             5.4.40-1


:: Different sync package(s) in repository core aarch64

-------------------------------------------------------------------------------
                             PACKAGE          2020-05-10         2020-05-14
-------------------------------------------------------------------------------
                             libsasl             2.1.27-2             2.1.27-3


:: Different overlay package(s) in repository extra aarch64

-------------------------------------------------------------------------------
                             PACKAGE          2020-05-10         2020-05-14
-------------------------------------------------------------------------------
                            mesa-git20.2.0_devel.123458.7f6a491eec0-120.2.0_devel.123631.8d8ba7fb44f-1


:: Different sync package(s) in repository extra aarch64

-------------------------------------------------------------------------------
                             PACKAGE          2020-05-10         2020-05-14
-------------------------------------------------------------------------------
                         389-ds-base            1.4.4.1-1            1.4.4.2-2
                        alsa-plugins              1.2.2-1            1:1.2.2-2
                           appstream            0.12.10-2            0.12.11-1
                        appstream-qt            0.12.10-2            0.12.11-1
                              attica             5.69.0-1             5.70.0-1
                               baloo             5.69.0-1             5.70.0-1
                            bluez-qt             5.69.0-1             5.70.0-1
                        breeze-icons             5.69.0-1             5.70.0-1
                              c-ares             1.16.0-1             1.16.1-1
                              clamav            0.102.2-2            0.102.3-1
                         clutter-gtk              1.8.4-1              1.8.4-2
                          cyrus-sasl             2.1.27-1             2.1.27-3
                   cyrus-sasl-gssapi             2.1.27-1             2.1.27-3
                     cyrus-sasl-ldap             2.1.27-1             2.1.27-3
                      cyrus-sasl-sql             2.1.27-1             2.1.27-3
                         dbus-broker                 22-2                 23-1
                           dbus-glib              0.110-1              0.110-2
                              expect             5.45.4-1             5.45.4-2
                 extra-cmake-modules             5.69.0-1             5.70.0-1
                              ffmpeg            1:4.2.2-6            1:4.2.2-8
                                 fmt              6.2.0-1              6.2.1-1
                frameworkintegration             5.69.0-1             5.70.0-1
                             freetds             1.1.33-1             1.1.36-1
                           freetype2             2.10.1-2             2.10.2-1
                     freetype2-demos             2.10.1-2             2.10.2-1
                      freetype2-docs             2.10.1-2             2.10.2-1
                                  gn    0.1700.97cc440d-1    0.1731.5ed3c9cc-1
                        gnome-clocks             3.36.0-1             3.36.2-1
                       gnome-nettool 3.8.1+205+g8550eef-2 3.8.1+205+g8550eef-3
                    gnome-system-log3.9.90+160+g4b07190-13.9.90+160+g4b07190-2
                  gnome-themes-extra               3.28-1               3.28-2
                               habak              0.2.5-6              0.2.5-7
                            harfbuzz              2.6.5-2              2.6.6-1
                        harfbuzz-icu              2.6.5-2              2.6.6-1
                  hicolor-icon-theme               0.17-1               0.17-2
                         kactivities             5.69.0-1             5.70.0-1
                   kactivities-stats             5.69.0-1             5.70.0-1
                             kapidox             5.69.0-1             5.70.0-1
                            karchive             5.69.0-1             5.70.0-1
                               kauth             5.69.0-1             5.70.0-1
                          kbookmarks             5.69.0-2             5.70.0-1
                       kcalendarcore             5.69.0-1             5.70.0-1
                            kcmutils             5.69.0-1             5.70.0-1
                             kcodecs             5.69.0-1             5.70.0-1
                         kcompletion             5.69.0-1             5.70.0-1
                             kconfig             5.69.0-1             5.70.0-1
                      kconfigwidgets             5.69.0-1             5.70.0-1
                           kcontacts           1:5.69.0-1           1:5.70.0-1
                         kcoreaddons             5.69.0-1             5.70.0-1
                              kcrash             5.69.0-1             5.70.0-1
                         kdbusaddons             5.69.0-1             5.70.0-1
                        kdeclarative             5.69.0-1             5.70.0-1
                                kded             5.69.0-1             5.70.0-1
                     kdelibs4support             5.69.0-1             5.70.0-1
                     kdesignerplugin             5.69.0-1             5.70.0-1
                               kdesu             5.69.0-1             5.70.0-1
                           kdewebkit             5.69.0-1             5.70.0-1
                              kdnssd             5.69.0-1             5.70.0-1
                           kdoctools             5.69.0-1             5.70.0-1
                          kemoticons             5.69.0-1             5.70.0-1
                       kfilemetadata             5.69.0-1             5.70.0-1
                        kglobalaccel             5.69.0-1             5.70.0-1
                          kguiaddons             5.69.0-1             5.70.0-1
                           kholidays           1:5.69.0-1           1:5.70.0-1
                               khtml             5.69.0-1             5.70.0-1
                               ki18n             5.69.0-1             5.70.0-1
                         kiconthemes             5.69.0-1             5.70.0-1
                           kidletime             5.69.0-1             5.70.0-1
                       kimageformats             5.69.0-1             5.70.0-1
                               kinit             5.69.0-1             5.70.0-1
                                 kio             5.69.0-1             5.70.0-2
                           kirigami2             5.69.0-1             5.70.0-1
                         kitemmodels             5.69.0-1             5.70.0-1
                          kitemviews             5.69.0-1             5.70.0-1
                         kjobwidgets             5.69.0-1             5.70.0-1
                                 kjs             5.69.0-1             5.70.0-1
                            kjsembed             5.69.0-1             5.70.0-1
                        kmediaplayer             5.69.0-1             5.70.0-1
                          knetattach             5.18.5-1             5.18.5-2
                           knewstuff             5.69.0-1             5.70.0-1
                      knotifications             5.69.0-1             5.70.0-1
                       knotifyconfig             5.69.0-1             5.70.0-1
                            kpackage             5.69.0-1             5.70.0-1
                              kparts             5.69.0-1             5.70.0-1
                             kpeople             5.69.0-1             5.70.0-1
                           kplotting             5.69.0-1             5.70.0-1
                                kpty             5.69.0-1             5.70.0-1
                        kquickcharts             5.69.0-1             5.70.0-1
                               kross             5.69.0-1             5.70.0-1
                             krunner             5.69.0-1             5.70.0-1
                            kservice             5.69.0-1             5.70.0-1
                         ktexteditor             5.69.0-1             5.70.0-1
                        ktextwidgets             5.69.0-1             5.70.0-1
                     kunitconversion             5.69.0-1             5.70.0-1
                             kwallet             5.69.0-1             5.70.0-1
                            kwayland             5.69.0-1             5.70.0-1
                      kwidgetsaddons             5.69.0-1             5.70.0-1
                       kwindowsystem             5.69.0-1             5.70.0-1
                             kxmlgui             5.69.0-1             5.70.0-1
                       kxmlrpcclient             5.69.0-1             5.70.0-1
                             l-smash             2.14.5-1             2.14.5-2
                         libart-lgpl             2.3.21-4             2.3.21-5
                              libass             0.14.0-1             0.14.0-2
                          libavc1394              0.5.4-3              0.5.4-4
                             libcddb              1.3.2-5              1.3.2-6
                        libqalculate            3.9.0.a-2             3.10.0-1
                            libvdpau                1.3-1                1.4-1
                           mercurial              5.3.2-1                5.4-1
                     modemmanager-qt             5.69.0-1             5.70.0-1
                               munin             2.0.56-1             2.0.61-1
                          munin-node             2.0.56-1             2.0.61-1
                   networkmanager-qt             5.69.0-2             5.70.0-1
                        oxygen-icons           1:5.69.0-1           1:5.70.0-1
                    oxygen-icons-svg           1:5.69.0-1           1:5.70.0-1
                   perl-ffi-checklib               0.26-1               0.27-1
                   perl-http-message               6.22-1               6.24-1
                                 php              7.4.5-2              7.4.6-1
                          php-apache              7.4.5-2              7.4.6-1
                             php-cgi              7.4.5-2              7.4.6-1
                           php-dblib              7.4.5-2              7.4.6-1
                           php-embed              7.4.5-2              7.4.6-1
                         php-enchant              7.4.5-2              7.4.6-1
                             php-fpm              7.4.5-2              7.4.6-1
                              php-gd              7.4.5-2              7.4.6-1
                            php-imap              7.4.5-2              7.4.6-1
                            php-intl              7.4.5-2              7.4.6-1
                            php-odbc              7.4.5-2              7.4.6-1
                           php-pgsql              7.4.5-2              7.4.6-1
                          php-phpdbg              7.4.5-2              7.4.6-1
                          php-pspell              7.4.5-2              7.4.6-1
                            php-snmp              7.4.5-2              7.4.6-1
                          php-sodium              7.4.5-2              7.4.6-1
                          php-sqlite              7.4.5-2              7.4.6-1
                            php-tidy              7.4.5-2              7.4.6-1
                             php-xsl              7.4.5-2              7.4.6-1
                            pipewire            0.3.4-1.1              0.3.5-1
                       pipewire-docs            0.3.4-1.1              0.3.5-1
                       pipewire-jack            0.3.4-1.1              0.3.5-1
                      pipewire-pulse            0.3.4-1.1              0.3.5-1
                      plasma-desktop             5.18.5-1             5.18.5-2
                    plasma-framework             5.69.0-2             5.70.0-1
              plasma-wayland-session             5.18.5-1             5.18.5-2
                    plasma-workspace             5.18.5-1             5.18.5-2
                              prison             5.69.0-1             5.70.0-1
                          prometheus             2.18.0-1             2.18.1-1
                     pulseaudio-alsa                  2-5            1:1.2.2-2
                             purpose             5.69.0-1             5.70.0-1
                      python-appdirs              1.4.3-5              1.4.4-1
                      python-asgiref              3.2.5-1              3.2.7-1
                       python-beaker             1.11.0-3             1.11.0-4
                         python-mako              1.1.2-1              1.1.2-3
                   python-setuptools           1:46.1.3-1           1:46.2.0-1
                      python-wstools              0.4.9-1             0.4.10-1
                     python2-appdirs              1.4.3-5              1.4.4-1
                      python2-beaker             1.11.0-3                    -
                       python2-isort              4.3.9-1             4.3.10-1
                        python2-mako              1.1.2-1                    -
                       python2-scour               0.37-4                    -
                     python2-wstools              0.4.9-1             0.4.10-1
                       qalculate-gtk            3.9.0.a-1             3.10.0-1
                                qemu              5.0.0-5              5.0.0-6
                     qemu-arch-extra              5.0.0-5              5.0.0-6
                  qemu-block-gluster              5.0.0-5              5.0.0-6
                    qemu-block-iscsi              5.0.0-5              5.0.0-6
                    qemu-guest-agent              5.0.0-5              5.0.0-6
                       qemu-headless              5.0.0-5              5.0.0-6
            qemu-headless-arch-extra              5.0.0-5              5.0.0-6
                  qqc2-desktop-style             5.69.0-1             5.70.0-1
                               scour               0.37-4               0.37-5
                               solid             5.69.0-1             5.70.0-1
                              sonnet             5.69.0-1             5.70.0-1
                          stellarium             0.20.0-1             0.20.1-1
                         syndication             5.69.0-1             5.70.0-1
                 syntax-highlighting             5.69.0-1             5.70.0-1
                        threadweaver             5.69.0-1             5.70.0-1
                                 w3m  0.5.3.git20190105-1  0.5.3.git20200507-1
                     wireguard-tools       1.0.20200319-1       1.0.20200510-1
                        wxgtk-common              3.0.5-1            3.0.5.1-1
                              wxgtk2              3.0.5-1            3.0.5.1-1
                              wxgtk3              3.0.5-1            3.0.5.1-1
                       pipewire-alsa                    -              0.3.5-1


  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Known Issues and Solutions

This is a wiki post, please edit it when you find a solution to an issue you encountered

Old Issues

Manual interventions:
The nss and zn_poly packages prior to version 3.51.1-1 and version 0.9.2-2 respectively, were missing a soname link each. This has been fixed in 3.51.1-1 and 0.9.2-2 of these packages, so the upgrade will need to overwrite the untracked files created by ldconfig. If you get any of these errors

nss: /usr/lib/p11-kit-trust.so exists in filesystem
zn_poly: /usr/lib/libzn_poly-0.9.so  exists in filesystem

when updating, use

pacman -Syu --overwrite /usr/lib/p11-kit-trust.so --overwrite /usr/lib/libzn_poly-0.9.so

to perform the upgrade.

Device stopped booting after Uboot update
The uboot update included a change to the extlinux.conf file. This change will be incompatible with the old 1 partition layout of some devices.
So if you are updating installs made with images 20.02.1 or older, you need to apply this fix before rebooting!
To fix this please edit your /boot/extlinux/extlinux.conf file and add 2 periods in front of each first slash, like so:

KERNEL ../Image
FDT ../dtbs/ #etc.
APPEND initrd=../initramfs-linux.img #etc.

Save the file and reboot.

Forum kindly sponsored by