[ARM Testing Update] 2020-06-17 - Plasma Framework, KDE Plasma, Yay, Pamac and kernels

That's what I'm using. Aside from the orange led, it offers much more power savings under mem sleep, but sound doesn't work after wake.

Be aware of the one partition vs two issue, since that bsp package is from before manjaro switched to two partitions and will come with an incorrect setting for an up-to-date system. It's a simple edit.

The uboot that supports the Orange LED is a downstream uboot, that does not get updates since support for the Pinebook Pro got into mainline.

The orange LED is purely cosmetic...

I would also really like some more testers on the uboot-pinebookpro package included in this update, before it gets to stable.

Especially if you run Manjaro on the eMMC and boot other distros via SD sometimes.
This uboot is a pure upstream one, with a patch to make it boot from SD cards before eMMC.

So any issues you encounter, I would like to know about.

I got really confused because of the missing orange led. I thought this uboot has messed up my pbp, because it didn't come on. I had my finger on the power switch for minutes. I only realized, it's something to do with the led, because I went for a screwdriver to open the case in order to disable the emmc. When I returned, I saw the login screen :woozy_face:

I prepared a sd card with mrfixit2001's latest debian image. When I booted from sd, immedately after the green led came on, the "open sesame" splash appeared. The green led started flickering (expanding the root file system) and after a short while ---- I got the manjaro splash and login screen. So after reboot it booted from emmc. Shutting down and starting again, however, booted into Debian from the sd card. From now on, the boot process is reliable. With a sd card inserted, it boots from the sd card. Otherwise it boots from emmc.

Okay. I am working on patching in the Orange LED again, since it is a good indicator that something is indeed happening. But it's a hacky patch (the dev's words), so it can't be upstreamed.

This is great news.
I am also gonna attempt a USB boot patch. :slight_smile:

The behavior of the LED and bootorder also confused me while setting up a new clean KDE install. By the way the manjaro-arm-flasher is a realy nice tool. Differently than mentioned it does not ask for sudo password.
Boot from SD card before eMMC works, but if a different ROOT partition is defined in extlinux (on SD) and ROOT_MNJRO partition is present on eMMC, extlinux.conf is ignored and ROOT_MNJRO is taken as ROOT. By renaming ROOT_MNJRO on eMMC the ROOT from extlinux.conf is used.

Just tested with a NetBSD SD card I burned and it booted up as expected.

1 Like

Ok, thanks for your answer.

Did you read this post about the n2 image I built ?

the n2 is working and reboot without problem with the 20.06 arm release, but the blue led is not blinking and stay off, the red led is on and fix...

Can I get you to test rebooting from SD booted, and see if it can reboot?

It seems to have worked as intended I believe. The order of operations was:

  1. From Manjaro ARM (on eMMC), issued shutdown
  2. Inserted NetBSD SD card and powered on PBP
  3. Automatically booted into NetBSD
  4. Issued Reboot from NetBSD
  5. Automatically booted into NetBSD again

Okay. Great.

This does not happen for me with my tests with a Manjaro ARM SD, but I guess it could be because it's the "same system" on both SD and eMMC.

PS: Just pushed an update, that brings back orange LED. :slight_smile:

Installed the update, orange LED lights up again. Many thanks!

One thing I noticed is, that the boot process takes a very long time when you don't have network access. The spinning circle in the boot splash freezes for a pretty long time. When I then log in to the kde de, the connection widget in the system tray is missing. I have to start NetworkManager manually to bring it up.

Okey, I just flashed uboot-pinebookpro-2020.06.17rc4-4 and the results are... strange.

Before going further, an important note - this was a dirty flash over dhivael version installed around February(?).

So:

  • 1/3rd of the boots aren't enabling the display (no backlight) - this happened with dhivael versions as well
  • another 1/3rd boots fine
  • the last 1/3rd boots with what appears to be incorrectly interpreted display output: 20200620_135018 20200620_135114

The plan for later tonight:

  1. Do a clean flash of uboot - aka clean the initial bytes before flashing uboot over them
  2. If the problems persists, grab the UART cable and try to get some logs (this could be postponed for tomorrow)

Note:
Just installing the new uboot package does not mean that the new uboot is applied. Manual flashing with dd is required to ensure an updated uboot.

PS: Now to find the command to clean uboot section to flash cleanly :smiley:

So, the thread above perhaps already answers this for me but: is ARM Testing meant to be stable enough that you can test updates with a machine in real use? Or should we stay clear if we somewhat depend on the machine normally working for us? I'd like to help, but the PBP is currently my only personal laptop and I would like to have it normally mostly working.

It’s meant to be less stable than the stable branch, but more stable than the unstable branch. I would say you should expect at least some things to break from time to time, so if you need your system to be the most reliable, you should stick to the stable branch.

1 Like

I tested booting 7 SD cards with distros installed. All cards successfully boot from power on with uboot-pinebookpro-bsp 1.5-7 installed and written to emmc.

With uboot-pinebookpro 2020.07rc4-4 installed and written to emmc the results are varied.

I came to the conclusion that SD card model effects the boot order. Four cards are the same model (ADATA 64GB A1) but with different distros. None of these four cards will boot from power on, the manjaro installation on emmc boots instead. All four cards will attempt to boot when restarting from manjaro on emmc, whether the boot is successful depends on the distro.

The three other SD cards I tested booted from power on but did not boot from restart, whether it was restarted from emmc or SD card distro.

Distros that booted successfully:

  • Manjaro pinebook pro factory image
  • Manjaro image from earlier this year without separate boot partition
  • Danielt unofficial Debian installer
  • Debian Desktop Community Build Image by mrfixit2001 (but fails to poweroff)

Distros that did not successfully boot:

  • Ubuntu Bionic Mate Community Build Image by ayufan
  • Q4OS Test Build
2 Likes

ayufan's Ubuntu and ChromeOS builds (at least not his mainline builds - haven't tried those) won't boot with dhivael's uboot as well. This shouldn't be unique to 2020.07.rc4-4

Not sure about Q4OS, haven't tried to boot this one since November (?) :smiley:

Alright, back in business.
After some questionable decisions to wipe certain bits and fixing broken partitions, I've backed up my settings and re-installed through Etcher. There is a high chance that my original install used different dd settings for the block sizes messing up things which wouldn't be otherwise visible.

So, it's a bit early to provide full results yet can already see a few things with rc4-4:

  • So far, no odd grey line display initialization
  • Boots fine targeting default uboot with 20.06 on SD card

Things to check when I can:

  • rc4-4 towards rc4-4 on sd/ usb
  • mrfixit debian on sd/usb
  • auyfan's new Ubuntu builds
  • pmOS from sd/ usb

Forum kindly sponsored by