[ARM Testing Update] 2020-07-19 - Plasma Frameworks, Pacman and kernels

Hello ARM community.

A new testing update! Woo!


Manjaro working together with UBPorts to bring Lomiri to Manjaro


Some highlights:

  • Most of our kernels got updated
  • Plasma Frameworks updated to 5.72.0
  • Added a fix for kwin to fix the keyboard issue in Plasma Mobile
  • Lots of new packages for both Phosh and Lomiri
  • Pacman got updated to 5.2.2
  • Lots of python packages got updated

Upstream Notifications:

Older notifications

The nss package requires manual intervention:
https://www.archlinux.org/news/nss3511-1-and-lib32-nss3511-1-updates-require-manual-intervention/
The packages hplip and firewalld requires manual intervention:
https://www.archlinux.org/news/hplip-3203-2-update-requires-manual-intervention/
https://www.archlinux.org/news/firewalld081-2-update-requires-manual-intervention/


Package Changes (Sun Jul 19 12:28:53 CEST 2020)

  • arm-testing community aarch64: 267 new and 258 removed package(s)
  • arm-testing core aarch64: 23 new and 23 removed package(s)
  • arm-testing extra aarch64: 161 new and 160 removed package(s)
:: Different overlay package(s) in repository community aarch64

-------------------------------------------------------------------------------
                             PACKAGE          2020-07-13         2020-07-19
-------------------------------------------------------------------------------
             actkbd-pinephone-volume              0.2.8-2              0.2.8-3
                  alsa-ucm-pinephone                0.1-4                0.1-5
                       calindori-git       r373.fa18968-1       r375.cd30527-1
                               calls              0.1.7-2              0.1.7-3
         gnome-control-center-mobile             3.36.3-1             3.36.3-2
                            grimshot                1.4-1                1.5-1
                           index-git       r458.77511db-1       r461.2c58ae6-1
                                 mir              1.8.0-1              1.8.0-2
                            nota-git      0_git20200417-1         r1.df27910-1
                               ofono               1.31-2               1.31-3
                                phoc              0.4.0-2   0.4.0+8+gc8a07c6-1
                               phosh  0.4.0+26+g384448c-2              0.4.1-1
            pinephone-manjaro-tweaks           20200713-3           20200718-2
               pinephone-modem-audio                  1-5                  1-6
             pinephone-modem-scripts              0.7.1-3                0.8-1
                plasma-angelfish-git       r688.1313960-1       r689.ef3402c-1
                   plasma-dialer-git       r218.6be4849-1       r220.2b1d44b-1
                     plasma-nano-git       r105.5b0c2d1-1       r107.4b954a4-1
         plasma-phone-components-git      r1119.d76fc14-1      r1138.d4e4431-1
                plasma-phonebook-git       r162.3a6c5b4-1       r164.0e47f7b-1
                 plasma-settings-git       r743.36792ff-1       r770.5ad0a01-1
                          rpi-eeprom         2020.06.15-1         2020.07.16-1
                        spacebar-git       r202.ae37c15-1       r261.dd72b7e-1
                     telepathy-ofono           20200305-1           20200305-2
                          unity8-git   r18213.d07cfbed2-1   r18199.11c06cfd1-1
                     ayatana-ido-git                    -           git_r569-1
      ayatana-indicator-datetime-git                    -          git_r2192-1
       ayatana-indicator-display-git                    -       r233.ac2f7de-1
      ayatana-indicator-messages-git                    -              0.6.1-1
 ayatana-indicator-notifications-git                    -                  1-1
         ayatana-indicator-power-git                    -          git_r1043-1
       ayatana-indicator-session-git                    -          git_r2440-1
         ayatana-indicator-sound-git                    -          git_r2735-1
                      deviceinfo-git                    -        r33.544833a-2
                       evince-mobile                    -             3.34.1-1
                        gnome-camera                    -  0.0.0+git20200715-1
               gnome-contacts-mobile                    -             3.36.2-1
          gnome-initial-setup-mobile                    -             3.36.4-1
                         libaperture                    -  0.0.0+git20200708-0
            libayatana-indicator-git                    -          git_r1878-1
         unity-system-compositor-git                    -      r1170.5a93741-2


:: Different sync package(s) in repository community aarch64

-------------------------------------------------------------------------------
                             PACKAGE          2020-07-13         2020-07-19
-------------------------------------------------------------------------------
                                 ack              3.3.1-2              3.4.0-1
                              acpica           20200528-1           20200717-1
                  appmenu-gtk-module              0.7.3-2            0.7.3.1-1
                    arduino-avr-core              1.8.2-2              1.8.3-1
                       atomicparsley              0.9.6-120200701.154658.b0d6223-1
                               aubio              0.4.9-7              0.4.9-8
                    autoconf-archive       1:2019.01.06-1       1:2019.01.06-2
                             aws-cli            1.18.97-1           1.18.100-1
                           bandwhich             0.15.0-1             0.16.0-1
                             barrier              2.3.2-2              2.3.3-1
                    barrier-headless              2.3.2-2              2.3.3-1
                             bashtop             0.9.12-1             0.9.24-1
                              batctl             2020.1-1             2020.2-1
                           bettercap             2.27.1-2               2.28-1
                               broot             0.18.3-1             0.18.6-1
                               cacti             1.2.12-1             1.2.13-1
                                cage 0.1.1.r40.gcc1f975-2            0.1.2.1-1
                             cargo-c              0.6.8-1              0.6.9-1
                              catch2             2.12.2-1             2.13.0-1
                              ccache              3.7.9-1             3.7.10-1
                            checksec              2.2.2-1              2.2.3-1
                        cmake-fedora              2.9.3-1              2.9.3-2
                              conmon           1:2.0.18-2           1:2.0.19-1
                                croc             8.0.11-1             8.0.12-1
                              docker         1:19.03.12-1         1:19.03.12-2
                                 dub             1.21.0-1             1.22.0-1
                              eslint              7.4.0-1              7.5.0-1
               fcitx5-chinese-addons     0.0.0.20200626-1     0.0.0.20200716-1
              firefox-tree-style-tab              3.5.9-1             3.5.12-1
               firefox-ublock-origin             1.28.0-1             1.28.2-1
                                fltk              1.3.5-2              1.3.5-3
                           fltk-docs              1.3.5-2              1.3.5-3
                       fltk-examples              1.3.5-2              1.3.5-3
                             foliate              2.4.0-2              2.4.2-1
                      gnome-firmware             3.34.0-1             3.36.0-1
                                  go           2:1.14.4-1           2:1.14.5-1
                              gopass              1.9.2-2              1.9.2-3
                            gpsbabel              1.7.0-1              1.7.0-2
                            guitarix             0.40.0-1             0.41.0-1
                             hashcat            1:5.1.0-2            1:6.0.0-1
                         hcxdumptool              6.0.6-1              6.0.7-1
                            hcxtools              6.0.2-1              6.0.3-1
                               hexer              1.0.5-2              1.0.6-1
                              httpie              2.2.0-1              2.2.0-2
                                  hy             0.18.0-1             0.19.0-2
                               hydra                9.0-2                9.0-3
                          ibus-table             1.10.0-1             1.10.1-1
                               isync              1.3.1-2              1.3.2-1
                          jack_mixer                 12-2                 13-1
                   java-commons-lang               3.10-2               3.11-1
                             jenkins              2.243-1              2.244-1
                          jupyterlab              2.1.5-1              2.2.0-1
                             keepass               2.45-2               2.45-4
                               khard             0.15.1-1             0.16.1-2
                          kio-gdrive              1.3.0-2                    -
                             klavaro               3.09-3               3.10-1
                       kodi-platform  20190726.809c5e9-11  20190726.809c5e9-12
                              kstars            1:3.4.2-2            1:3.4.3-1
                         kvantum-qt5             0.15.3-1             0.16.0-1
               kvantum-theme-materia           20200523-1           20200713-1
                              libcec              5.0.0-1              6.0.2-1
                              libime     0.0.0.20200626-1     0.0.0.20200716-1
                             libjcat              0.1.2-1              0.1.3-1
                            libressl              3.1.2-1              3.2.0-1
                         libva-utils              2.7.1-1              2.8.0-1
                         lsp-plugins             1.1.22-1             1.1.24-1
                             lv2lint              0.6.0-1              0.8.0-1
                             mailman             2.1.33-1             2.1.34-1
                            mailman3              3.3.1-1              3.3.1-2
                              marked              1.1.0-1              1.1.1-1
                         materia-kde           20200523-1           20200713-1
                        mephisto.lv2              0.8.8-2             0.12.0-1
                     midi_matrix.lv2             0.24.0-1             0.26.0-1
                           miniupnpc       2.1.20190408-3       2.1.20191224-1
                            molecule              3.0.5-1              3.0.6-1
                           moony.lv2             0.32.0-1             0.34.0-1
                             moosefs            3.0.112-1            3.0.113-1
                              mopidy              3.0.2-1              3.0.2-2
                                mypy              0.782-1              0.782-2
                     mysql-workbench             8.0.20-3             8.0.21-1
                             netdata             1.23.1-1             1.23.2-1
                 new-session-manager              1.3.2-1              1.4.0-2
                            newsboat             2.20.1-1             2.20.1-2
                  nextcloud-app-deck            1:1.0.4-1            1:1.0.5-1
                    nginx-mod-brotli            1:0.1.2-7          1:1.0.0rc-1
                              nikola              8.1.1-1              8.1.1-2
                                 nim              1.2.0-1              1.2.4-1
                                 nnn                3.2-1                3.3-1
                              nomacs             3.14.2-2          3.16.1705-1
                   npm-check-updates              7.0.1-1              7.0.2-1
                    otf-font-awesome             5.13.1-2             5.14.0-1
                         patchmatrix             0.18.0-1             0.20.0-1
                        pathological             1.1.3-10                    -
                         pdfarranger              1.5.3-1              1.6.0-1
                                peek              1.5.1-2              1.5.1-3
                           postorius              1.3.3-1              1.3.3-2
                   python-astunparse              1.6.2-2              1.6.3-1
                        python-aubio              0.4.9-7              0.4.9-8
                     python-autobahn             20.6.2-1             20.7.1-1
                        python-boto3            1.14.20-1            1.14.23-1
                     python-botocore            1.17.20-1            1.17.23-1
                 python-calmjs.parse              1.2.5-1              1.2.5-3
                     python-cfn-lint             0.33.2-1             0.34.0-1
                      python-cheroot              8.3.0-1              8.3.1-1
                    python-click-log              0.3.2-4              0.3.2-5
                   python-cloudflare              2.8.3-1              2.8.6-1
                    python-cx_freeze                6.1-1                6.2-1
               python-django-appconf              1.0.4-1              1.0.4-2
                         python-docs              3.8.2-1              3.8.4-1
                      python-edalize              0.2.2-1              0.2.2-2
                   python-flufl.i18n              2.0.2-2                3.0-1
                    python-fonttools             4.12.1-1             4.13.0-1
                    python-gitpython              3.1.3-1              3.1.7-1
                  python-google-auth             1.18.0-1             1.19.0-1
                        python-httpx             0.13.3-4             0.13.3-5
                   python-hypothesis             5.19.1-1             5.20.1-1
              python-internetarchive              1.9.3-1              1.9.4-1
                       python-joblib             0.14.1-1             0.16.0-1
              python-language-server             0.34.1-1             0.34.1-2
                  python-lark-parser              0.8.9-1              0.9.0-1
                     python-m2crypto             0.35.2-3             0.36.0-1
                     python-markdown              3.1.1-4              3.2.2-1
                   python-matplotlib              3.2.2-1              3.3.0-1
                         python-nltk                3.5-1                3.5-2
                python-nmigen-boards       r105.86ae791-1       r133.d9264bf-1
              python-openstackclient              5.3.0-1              5.3.1-1
                      python-oslo-db              8.2.1-1              8.3.0-1
             python-ovirt-engine-sdk              4.3.0-3              4.4.4-1
            python-pandas-datareader              0.8.1-2              0.9.0-1
                        python-paste              3.4.1-1              3.4.2-1
                     python-pendulum              2.1.0-1              2.1.1-2
                       python-pg8000             1.15.3-1             1.16.1-1
                      python-pikepdf             1.17.0-1             1.17.2-1
                       python-pipenv           2020.6.2-1           2020.6.2-2
                     python-pydantic                1.6-1              1.6.1-1
                      python-pymysql              0.9.3-3             0.10.0-1
                    python-pystemmer            2.0.0.1-1              2.0.1-1
               python-pytest-timeout              1.4.1-1              1.4.2-1
                     python-pytzdata             2019.3-2             2020.1-1
                        python-pyvcd              0.1.7-1              0.2.3-1
                        python-regex           2020.6.8-1          2020.7.14-1
                    python-reportlab             3.5.42-1             3.5.44-1
                    python-schemdraw              0.6.0-1              0.7.1-1
                   python-simplejson             3.17.0-1             3.17.2-1
                    python-stevedore              3.0.0-1              3.2.0-1
                python-threadpoolctl              2.0.0-1              2.1.0-1
                        python-toolz             0.10.0-2             0.10.0-3
                          python-tox             3.16.1-1             3.17.1-1
                         python-tqdm             4.47.0-1             4.48.0-1
                     python-userpath              1.3.0-1              1.3.0-2
                        python-wheel             0.34.2-2             0.34.2-3
                         python-yara              4.0.1-1              4.0.2-1
              python-zope-exceptions                4.3-3                4.4-1
                     python2-cheroot              8.3.0-1              8.3.1-1
                    python2-m2crypto             0.35.2-3             0.36.0-1
                    python2-markdown              3.1.1-4                    -
                   python2-pystemmer            2.0.0.1-1              2.0.1-1
              python2-pytest-timeout              1.4.1-1              1.4.2-1
                       python2-regex           2020.6.8-1          2020.7.14-1
                  python2-simplejson             3.17.0-1             3.17.2-1
                         python2-tox             3.16.1-1             3.17.1-1
                      python2-typing            3.7.4.2-1            3.7.4.3-1
                       python2-wheel             0.34.2-2             0.34.2-3
                        python2-yara              4.0.1-1              4.0.2-1
             python2-zope-exceptions                4.3-3                4.4-1
                         qutebrowser             1.13.0-2             1.13.1-1
                                raft             0.9.23-1             0.9.24-1
                                rink              0.4.5-1              0.5.0-1
                     ruby-multi_json             1.14.1-2             1.15.0-1
                       rust-analyzer           20200706-1           20200713-1
                        rust-bindgen             0.54.0-1             0.54.0-2
                                 sbt           1:1.3.10-1           1:1.3.12-1
                              scrapy              2.2.0-1              2.2.1-1
                        sherlock.lv2             0.22.0-1             0.24.0-1
                           shorewall              5.2.6-1            5.2.6.1-1
                      shorewall-core              5.2.6-1            5.2.6.1-1
                          shorewall6              5.2.6-1            5.2.6.1-1
                             shotcut           20.06.28-1           20.07.11-1
                               siege              4.0.5-2              4.0.7-1
                         slirp4netns              1.1.3-1              1.1.4-1
                            smplayer             20.4.2-1             20.6.0-1
                             snapper             0.8.10-1             0.8.11-1
                                solr              8.5.2-1              8.6.0-1
                  sqlite-replication           3.32.1.4-1           3.32.3.4-1
                          strawberry             0.6.12-2             0.6.13-1
                          streamlink              1.5.0-1              1.5.0-2
                              stylus             0.54.7-2             0.54.8-1
                                sway              1:1.4-9              1:1.5-1
                          swi-prolog              8.2.0-1              8.2.1-1
                        systemd-swap              4.2.3-2              4.3.2-1
                           tcpreplay              4.3.2-2              4.3.3-1
                    ttf-font-awesome             5.13.1-2             5.14.0-1
                          typescript              3.9.6-1              3.9.7-1
                             udiskie              2.2.0-1              2.2.0-2
                 ukui-control-center              2.0.4-1              2.0.5-1
                          ukui-media              2.0.3-1              2.0.4-1
                         ukui-themes              1.3.0-1              1.4.0-1
                             uranium              4.5.0-1              4.5.0-2
                            urlwatch               2.18-4               2.19-1
                               uwsgi           2.0.19.1-2           2.0.19.1-3
                    uwsgi-plugin-cgi           2.0.19.1-2           2.0.19.1-3
                    uwsgi-plugin-jvm           2.0.19.1-2           2.0.19.1-3
                  uwsgi-plugin-lua51           2.0.19.1-2           2.0.19.1-3
               uwsgi-plugin-notfound           2.0.19.1-2           2.0.19.1-3
                    uwsgi-plugin-php           2.0.19.1-2           2.0.19.1-3
                   uwsgi-plugin-psgi           2.0.19.1-2           2.0.19.1-3
                 uwsgi-plugin-python           2.0.19.1-2           2.0.19.1-3
                uwsgi-plugin-python2           2.0.19.1-2                    -
                   uwsgi-plugin-rack           2.0.19.1-2           2.0.19.1-3
                 uwsgi-plugin-webdav           2.0.19.1-2           2.0.19.1-3
                 uwsgi-plugin-zabbix           2.0.19.1-2           2.0.19.1-3
         v2ray-domain-list-community     20200712080909-1     20200719015510-1
                         v2ray-geoip       202007080004-1       202007150004-1
                          vdirsyncer             0.16.8-2             0.16.8-3
                               vim-a              2.18-10                    -
                         vim-ansible                2.1-2                3.0-1
                vim-colorsamplerpack         2012.10.28-6                    -
                  vim-doxygentoolkit             0.2.13-5                    -
                  vim-guicolorscheme                1.2-6                    -
                     vim-minibufexpl              6.5.2-3                    -
                         vim-project             1.4.1-10                    -
                         vim-taglist                 46-5                    -
                       vim-ultisnips                3.2-2                3.2-3
                      vim-vcscommand            1.99.47-4                    -
                       vim-workspace             1.0b1-10                    -
                              vm.lv2              0.8.0-1             0.10.0-1
                       wireshark-cli              3.2.4-1              3.2.5-1
                        wireshark-qt              3.2.4-1              3.2.5-1
                             wlroots             0.10.1-1             0.11.0-1
                         x42-plugins           20200411-1           20200714-1
                            yamllint             1.23.0-1             1.24.2-1
                                yara              4.0.1-1              4.0.2-1
                        zerotier-one              1.4.6-1              1.4.6-2
                                muse                    -              3.1.1-1
                           nicotine+                    -              2.0.1-1
                            notes-up                    -              2.0.2-2
                    python-miniupnpc                    -       2.1.20191224-1
                               scite                    -              4.4.3-3
                                zola                    -             0.11.0-4


:: Different overlay package(s) in repository core aarch64

-------------------------------------------------------------------------------
                             PACKAGE          2020-07-13         2020-07-19
-------------------------------------------------------------------------------
                       linux-aarch64              5.7.8-1              5.7.9-1
               linux-aarch64-headers              5.7.8-1              5.7.9-1
                     linux-pinephone              5.7.0-8              5.7.0-9
             linux-pinephone-headers              5.7.0-8              5.7.0-9
                 linux-rpi4-mainline              5.7.7-2              5.7.8-1
         linux-rpi4-mainline-headers              5.7.7-2              5.7.8-1
                     linux-rpi4-next             5.4.50-2             5.4.51-1
             linux-rpi4-next-headers             5.4.50-2             5.4.51-1
                              pacman              5.2.1-5              5.2.2-1
                        pacman-debug              5.2.1-5              5.2.2-1
              raspberrypi-bootloader           20200702-1           20200713-1
            raspberrypi-bootloader-x           20200702-1           20200713-1
                     uboot-pinephone            2020.04-5            2020.04-7


:: Different sync package(s) in repository core aarch64

-------------------------------------------------------------------------------
                             PACKAGE          2020-07-13         2020-07-19
-------------------------------------------------------------------------------
                              dhcpcd              9.1.4-1              9.1.4-2
                               gpgme             1.13.1-7             1.14.0-1
                              libcap               2.36-1               2.37-1
                            libevent             2.1.11-5             2.1.12-1
                          mkinitcpio                 27-3                 28-1
                             openssh              8.3p1-1              8.3p1-3
                        python-gpgme             1.13.1-7             1.14.0-1
                              qgpgme             1.13.1-7             1.14.0-1
                              shadow              4.8.1-1              4.8.1-3
                        shadow-debug              4.8.1-1              4.8.1-3


:: Different overlay package(s) in repository extra aarch64

-------------------------------------------------------------------------------
                             PACKAGE          2020-07-13         2020-07-19
-------------------------------------------------------------------------------
                 kwayland-server-git      r1016.e27405c-15.19.80.r1071.g7172fa7-1
                            kwin-git   r17973.b77d29119-1   r18133.3cdfdeb98-1
                   manjaro-arm-tools              2.8.5-1              2.8.6-1
                                kwin                    -           5.19.3-1.1


:: Different sync package(s) in repository extra aarch64

-------------------------------------------------------------------------------
                             PACKAGE          2020-07-13         2020-07-19
-------------------------------------------------------------------------------
                      akonadi-search            20.04.3-1            20.04.3-2
                        alertmanager             0.21.0-1             0.21.0-2
                              attica             5.71.0-1             5.72.0-1
                        avidemux-cli              2.7.4-5              2.7.6-1
                         avidemux-qt              2.7.4-5              2.7.6-1
                               baloo             5.71.0-1             5.72.0-1
                                bind             9.16.4-1             9.16.5-1
                          bind-tools             9.16.4-1             9.16.5-1
                            bluez-qt             5.71.0-1             5.72.0-1
                        breeze-icons             5.71.0-1             5.72.0-1
                            chromium      83.0.4103.116-3       84.0.4147.89-1
                          claws-mail             3.17.5-3             3.17.6-1
                               cmake             3.17.3-1             3.18.0-1
                            composer             1.10.8-1             1.10.9-1
                                cups              2.3.3-1              2.3.3-2
                             digikam             6.4.0-10              7.0.0-1
                                dkms              2.8.1-4              2.8.3-1
                       docbook-dsssl               1.79-7               1.79-8
                 extra-cmake-modules             5.71.0-1             5.72.0-1
                              ffmpeg            2:4.2.3-2            2:4.3.1-1
                          fluidsynth              2.1.3-1              2.1.4-1
                frameworkintegration             5.71.0-1             5.72.0-1
                         gdk-pixbuf2             2.40.0-22.40.0+6+g5432316df-1
                                 gdm             3.36.2-1             3.36.3-1
                               icewm              1.6.6-1              1.7.0-1
                         imagemagick          7.0.10.23-1          7.0.10.24-1
                     imagemagick-doc          7.0.10.23-1          7.0.10.24-1
                             ipp-usb              0.9.8-1             0.9.10-1
                         jdk-openjdk          14.0.1.u7-1         14.0.2.u12-1
                       jdk11-openjdk         11.0.7.u10-1         11.0.8.u10-1
                        jdk8-openjdk             8.u252-1             8.u262-1
                         jre-openjdk          14.0.1.u7-1         14.0.2.u12-1
                jre-openjdk-headless          14.0.1.u7-1         14.0.2.u12-1
                       jre11-openjdk         11.0.7.u10-1         11.0.8.u10-1
              jre11-openjdk-headless         11.0.7.u10-1         11.0.8.u10-1
                        jre8-openjdk             8.u252-1             8.u262-1
               jre8-openjdk-headless             8.u252-1             8.u262-1
                         kactivities             5.71.0-1             5.72.0-1
                   kactivities-stats             5.71.0-1             5.72.0-1
                             kapidox             5.71.0-1             5.72.0-1
                            karchive             5.71.0-1             5.72.0-1
                               kauth             5.71.0-1             5.72.0-1
                          kbookmarks             5.71.0-1             5.72.0-1
                       kcalendarcore             5.71.0-1             5.72.0-1
                            kcmutils             5.71.0-1             5.72.0-1
                             kcodecs             5.71.0-1             5.72.0-1
                         kcompletion             5.71.0-1             5.72.0-1
                             kconfig             5.71.0-1             5.72.0-1
                      kconfigwidgets             5.71.0-1             5.72.0-1
                           kcontacts           1:5.71.0-1           1:5.72.0-1
                         kcoreaddons             5.71.0-1             5.72.0-1
                              kcrash             5.71.0-1             5.72.0-1
                                kdav            20.04.3-1           1:5.72.0-1
                         kdbusaddons             5.71.0-1             5.72.0-1
                        kdeclarative             5.71.0-1             5.72.0-1
                                kded             5.71.0-1             5.72.0-1
                     kdelibs4support             5.71.0-1             5.72.0-1
                      kdepim-runtime            20.04.3-1            20.04.3-2
                     kdesignerplugin             5.71.0-1             5.72.0-1
                               kdesu             5.71.0-1             5.72.0-1
                           kdewebkit             5.71.0-1             5.72.0-1
                              kdnssd             5.71.0-1             5.72.0-1
                           kdoctools             5.71.0-1             5.72.0-1
                          kemoticons             5.71.0-1             5.72.0-1
                       kfilemetadata             5.71.0-1             5.72.0-1
                        kglobalaccel             5.71.0-1             5.72.0-1
                          kguiaddons             5.71.0-1             5.72.0-1
                           kholidays           1:5.71.0-1           1:5.72.0-1
                               khtml             5.71.0-1             5.72.0-1
                               ki18n             5.71.0-1             5.72.0-1
                         kiconthemes             5.71.0-1             5.72.0-1
                           kidletime             5.71.0-1             5.72.0-1
                       kimageformats             5.71.0-1             5.72.0-1
                               kinit             5.71.0-1             5.72.0-1
                                 kio             5.71.0-1             5.72.0-1
                           kirigami2             5.71.0-1             5.72.0-1
                         kitemmodels             5.71.0-1             5.72.0-1
                          kitemviews             5.71.0-1             5.72.0-1
                         kjobwidgets             5.71.0-1             5.72.0-1
                                 kjs             5.71.0-1             5.72.0-1
                            kjsembed             5.71.0-1             5.72.0-1
                        kmediaplayer             5.71.0-1             5.72.0-1
                           knewstuff             5.71.0-1             5.72.0-1
                      knotifications             5.71.0-1             5.72.0-1
                       knotifyconfig             5.71.0-1             5.72.0-1
                            kpackage             5.71.0-1             5.72.0-1
                              kparts             5.71.0-1             5.72.0-1
                             kpeople             5.71.0-1             5.72.0-1
                           kplotting             5.71.0-1             5.72.0-1
                                kpty             5.71.0-1             5.72.0-1
                        kquickcharts             5.71.0-1             5.72.0-1
                               kross             5.71.0-1             5.72.0-1
                             krunner             5.71.0-1             5.72.0-2
                            kservice             5.71.0-1             5.72.0-1
                         ktexteditor             5.71.0-1             5.72.0-1
                        ktextwidgets             5.71.0-1             5.72.0-1
                     kunitconversion             5.71.0-1             5.72.0-1
                             kwallet             5.71.0-1             5.72.0-1
                            kwayland             5.71.0-1             5.72.0-1
                      kwidgetsaddons             5.71.0-1             5.72.0-1
                       kwindowsystem             5.71.0-1             5.72.0-1
                             kxmlgui             5.71.0-1             5.72.0-1
                       kxmlrpcclient             5.71.0-1             5.72.0-1
                              libbpf              0.0.8-1              0.0.9-1
                             libcups              2.3.3-1              2.3.3-2
                            libevdev              1.9.0-1              1.9.1-1
                              libgdm             3.36.2-1             3.36.3-1
                               libnm             1.24.2-1             1.26.0-1
                               llvm9              9.0.1-1                    -
                          llvm9-libs              9.0.1-1                    -
                                 mlt             6.20.0-3             6.20.0-4
                     modemmanager-qt             5.71.0-1             5.72.0-1
                                mono          6.8.0.123-1         6.10.0.104-1
                           mpdecimal              2.4.2-3              2.5.0-1
                                nasm            2.14.02-2            2.15.02-1
                      networkmanager             1.24.2-1             1.26.0-1
                   networkmanager-qt             5.71.0-1             5.72.0-1
                      nm-cloud-setup             1.24.2-1             1.26.0-1
                         openjdk-src          14.0.1.u7-1         14.0.2.u12-1
                       openjdk11-src         11.0.7.u10-1         11.0.8.u10-1
                        openjdk8-src             8.u252-1             8.u262-1
                        oxygen-icons           1:5.71.0-1           1:5.72.0-1
                    oxygen-icons-svg           1:5.71.0-1           1:5.72.0-1
             perl-lwp-protocol-https               6.07-5               6.09-1
               perl-template-toolkit              3.008-2              3.009-1
                    plasma-framework             5.71.0-2             5.72.0-1
                             poppler             0.90.0-1             0.90.1-1
                        poppler-glib             0.90.0-1             0.90.1-1
                         poppler-qt5             0.90.0-1             0.90.1-1
                              prison             5.71.0-1             5.72.0-1
                       python-django              3.0.8-1              3.0.8-2
                         python-idna                2.9-1               2.10-1
                   python-setuptools           1:49.1.3-1           1:49.2.0-1
                        python2-idna                2.9-1               2.10-1
                  qqc2-desktop-style             5.71.0-1             5.72.0-1
                                rust           1:1.44.1-1           1:1.45.0-2
                           rust-docs           1:1.44.1-1           1:1.45.0-2
                        sane-airscan             0.99.9-1            0.99.10-1
                               solid             5.71.0-1             5.72.0-1
                              sonnet             5.71.0-1             5.72.0-1
                         suitesparse              5.8.0-2              5.8.1-1
                         syndication             5.71.0-1             5.72.0-1
                 syntax-highlighting             5.71.0-1             5.72.0-1
                           syslog-ng             3.27.1-1             3.28.1-1
                        threadweaver             5.71.0-1             5.72.0-1
                      vulkan-headers          1:1.2.146-1          1:1.2.147-1
                    vulkan-html-docs          1:1.2.146-1          1:1.2.147-1
                   vulkan-icd-loader            1.2.145-1            1.2.147-1
                        vulkan-tools          1.2.141.0-1            1.2.146-1
            vulkan-validation-layers            1.2.145-1            1.2.146-1
                      wireguard-dkms       1.0.20200623-1       1.0.20200712-1
                               xterm                357-1                358-1
                        zabbix-agent              5.0.1-1              5.0.2-1
                       zabbix-agent2              5.0.1-1              5.0.2-1
                 zabbix-frontend-php              5.0.1-1              5.0.2-1
                        zabbix-proxy              5.0.1-1              5.0.2-1
                       zabbix-server              5.0.1-1              5.0.2-1
                          kio-gdrive                    -              1.3.0-2
          prometheus-mysqld-exporter                    -             0.12.1-2


Testers needed on arm-testing branch
We are in need of testers for our arm-testing and arm-unstable branches.
So if you are adventurous and want newer software quicker, we would love for you to help us test out the new packages in arm-testing branch.

All you have to do to switch to this branch is:

  • Edit /etc/pacman-mirrors.conf and change Branch = arm-stable to Branch = arm-testing.
  • Run this command: sudo pacman-mirrors -f5 && sudo pacman -Syyu. This will generate a new mirrorlist for you, sync your databases with the new mirror and update your system using the arm-testing branch.

We would then love for you to give feedback in our update posts in #manjaro-arm:arm-testing-updates. That way we can better find and fix bugs, before they hit arm-stable branch. Thank you!


  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Known Issues and Solutions

This is a wiki post, please edit it when you find a solution to an issue you encountered

Plasma Mobile Keyboard
The plasma mobile onscreen keyboard does not work with QT 5.15.0.
This is fixed by updating to kwin 5.19.3-1.1.

Old Issues

PinePhone uboot
This update to the PinePhone Uboot package (2020.04-2), changed how the DTS is loaded from the kernel, since the Kernel DTS for the Pinephone also changed. When doing this update on the PinePhone images from Alpha5 and back, please make this change to the /boot/extlinux/extlinux.conf before rebooting:

  • sun50i-a64-pinephone.dtb to sun50i-a64-pinephone-1.2.dtb
  • root=LABEL=ROOT to root=LABEL=ROOT_MNJRO

Manual interventions:
The nss and zn_poly packages prior to version 3.51.1-1 and version 0.9.2-2 respectively, were missing a soname link each. This has been fixed in 3.51.1-1 and 0.9.2-2 of these packages, so the upgrade will need to overwrite the untracked files created by ldconfig. If you get any of these errors

nss: /usr/lib/p11-kit-trust.so exists in filesystem
zn_poly: /usr/lib/libzn_poly-0.9.so  exists in filesystem

when updating, use

pacman -Syu --overwrite /usr/lib/p11-kit-trust.so --overwrite /usr/lib/libzn_poly-0.9.so

to perform the upgrade.

Device stopped booting after Uboot update
The uboot update included a change to the extlinux.conf file. This change will be incompatible with the old 1 partition layout of some devices.
So if you are updating installs made with images 20.02.1 or older, you need to apply this fix before rebooting!
To fix this please edit your /boot/extlinux/extlinux.conf file and add 2 periods in front of each first slash, like so:

KERNEL ../Image
FDT ../dtbs/ #etc.
APPEND initrd=../initramfs-linux.img #etc.

Save the file and reboot.

Hi,

Mntray is working well.

Screenshot_20200719_144425

Nice to see Manjaro working with Ubuntu.

Update via tty ... all fine

Host: Hardkernel ODROID-C2
Kernel: 5.7.9-1-MANJARO-ARM
Host: Hardkernel ODROID-N2
Kernel: 5.7.9-1-MANJARO-ARM
Host: Pine64 PinePhone (1.2)
Kernel: 5.7.0-9-MANJARO-ARM
1 Like

Odroid c4 up to date.

before the update

[nlc4@c4 ~]$ uptime
 17:10:15 up 4 days, 16:56,  2 users,  load average: 0,97, 0,64, 0,48
[nlc4@c4 ~]$ screenfetch
                             nlc4@c4.test.2020.05.14
                             OS: Manjaro-ARM 20.07
                             Kernel: aarch64 Linux 5.7.8-1-MANJARO-ARM
         #####               Uptime: 4d 16h 56m
        #######              Packages: Unknown
        ##O#O##              Shell: bash 5.0.17
        #######              Resolution: 1920x1080
      ###########            DE: KDE 5.71.0 / Plasma 5.19.3
     #############           WM: KWin
    ###############          GTK Theme: Breeze [GTK2/3]
    ################         Icon Theme: oxygen
   #################         Disk: 258G / 991G (27%)
 #####################       CPU: Unknown @ 4x 1.908GHz
 #####################       GPU: 
   #################         RAM: 1195MiB / 3628MiB
                            
                            
                            
[nlc4@c4 ~]$ date -u
dim. 19 juil. 2020 15:10:40 UTC
[nlc4@c4 ~]$ uname -a
Linux c4.test.2020.05.14 5.7.8-1-MANJARO-ARM #1 SMP Thu Jul 9 14:42:31 CEST 2020 aarch64 GNU/Linux
[nlc4@c4 ~]$ sudo pacman -Syyuu
[sudo] password for nlc4: 
:: Synchronising package databases...
 core                                    218,6 KiB   705 KiB/s 00:00 [######################################] 100%
 extra                                     2,3 MiB   966 KiB/s 00:02 [######################################] 100%
 community                                 5,2 MiB  1142 KiB/s 00:05 [######################################] 100%
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

Packages (92) attica-5.72.0-1  baloo-5.72.0-1  bluez-qt-5.72.0-1  breeze-icons-5.72.0-1  dhcpcd-9.1.4-2
              ffmpeg-2:4.3.1-1  firefox-ublock-origin-1.28.2-1  frameworkintegration-5.72.0-1
              gdk-pixbuf2-2.40.0+6+g5432316df-1  gpgme-1.14.0-1  kactivities-5.72.0-1  kactivities-stats-5.72.0-1
              karchive-5.72.0-1  kauth-5.72.0-1  kbookmarks-5.72.0-1  kcmutils-5.72.0-1  kcodecs-5.72.0-1
              kcompletion-5.72.0-1  kconfig-5.72.0-1  kconfigwidgets-5.72.0-1  kcoreaddons-5.72.0-1
              kcrash-5.72.0-1  kdbusaddons-5.72.0-1  kdeclarative-5.72.0-1  kded-5.72.0-1
              kdelibs4support-5.72.0-1  kdesu-5.72.0-1  kdnssd-5.72.0-1  kemoticons-5.72.0-1
              kfilemetadata-5.72.0-1  kglobalaccel-5.72.0-1  kguiaddons-5.72.0-1  kholidays-1:5.72.0-1
              ki18n-5.72.0-1  kiconthemes-5.72.0-1  kidletime-5.72.0-1  kinit-5.72.0-1  kio-5.72.0-1
              kirigami2-5.72.0-1  kitemmodels-5.72.0-1  kitemviews-5.72.0-1  kjobwidgets-5.72.0-1  kjs-5.72.0-1
              knewstuff-5.72.0-1  knotifications-5.72.0-1  knotifyconfig-5.72.0-1  kpackage-5.72.0-1
              kparts-5.72.0-1  kpeople-5.72.0-1  kpty-5.72.0-1  kquickcharts-5.72.0-1  krunner-5.72.0-2
              kservice-5.72.0-1  ktexteditor-5.72.0-1  ktextwidgets-5.72.0-1  kunitconversion-5.72.0-1
              kwallet-5.72.0-1  kwayland-5.72.0-1  kwidgetsaddons-5.72.0-1  kwin-5.19.3-1.1
              kwindowsystem-5.72.0-1  kxmlgui-5.72.0-1  libcap-2.37-1  libcups-2.3.3-2  libevdev-1.9.1-1
              libevent-2.1.12-1  libnm-1.26.0-1  linux-aarch64-5.7.9-1  mkinitcpio-28-1  modemmanager-qt-5.72.0-1
              networkmanager-1.26.0-1  networkmanager-qt-5.72.0-1  openssh-8.3p1-3  oxygen-icons-1:5.72.0-1
              pacman-5.2.2-1  plasma-framework-5.72.0-1  poppler-0.90.1-1  poppler-glib-0.90.1-1
              poppler-qt5-0.90.1-1  prison-5.72.0-1  python-idna-2.10-1  python-setuptools-1:49.2.0-1
              qqc2-desktop-style-5.72.0-1  rav1e-0.3.3-1  shadow-4.8.1-3  smplayer-20.6.0-1  solid-5.72.0-1
              sonnet-5.72.0-1  suitesparse-5.8.1-1  syntax-highlighting-5.72.0-1  threadweaver-5.72.0-1
              vulkan-icd-loader-1.2.147-1

Total Download Size:   200,61 MiB
Total Installed Size:  577,53 MiB
Net Upgrade Size:       17,59 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages...
 libcap-2.37-1-aarch64                    56,5 KiB  1131 KiB/s 00:00 [######################################] 100%
 shadow-4.8.1-3-aarch64                 1123,5 KiB  1320 KiB/s 00:01 [######################################] 100%
 gpgme-1.14.0-1-aarch64                  395,9 KiB  1200 KiB/s 00:00 [######################################] 100%
 dhcpcd-9.1.4-2-aarch64                  183,2 KiB  1145 KiB/s 00:00 [######################################] 100%
 libevent-2.1.12-1-aarch64               241,5 KiB  1342 KiB/s 00:00 [######################################] 100%
 mkinitcpio-28-1-any                      41,0 KiB  2,00 MiB/s 00:00 [######################################] 100%
 linux-aarch64-5.7.9-1-aarch64            69,1 MiB  1234 KiB/s 00:57 [######################################] 100%
 openssh-8.3p1-3-aarch64                 829,1 KiB  1168 KiB/s 00:01 [######################################] 100%
 pacman-5.2.2-1-aarch64                  773,4 KiB  2035 KiB/s 00:00 [######################################] 100%
 libcups-2.3.3-2-aarch64                 259,5 KiB  2,11 MiB/s 00:00 [######################################] 100%
 libevdev-1.9.1-1-aarch64                 54,0 KiB  2,64 MiB/s 00:00 [######################################] 100%
 attica-5.72.0-1-aarch64                 538,0 KiB  1922 KiB/s 00:00 [######################################] 100%
 ki18n-5.72.0-1-aarch64                 1386,2 KiB  1873 KiB/s 00:01 [######################################] 100%
 karchive-5.72.0-1-aarch64               363,6 KiB  1731 KiB/s 00:00 [######################################] 100%
 kconfig-5.72.0-1-aarch64                953,3 KiB  2028 KiB/s 00:00 [######################################] 100%
 kcoreaddons-5.72.0-1-aarch64           1232,2 KiB  1521 KiB/s 00:01 [######################################] 100%
 poppler-0.90.1-1-aarch64               1140,0 KiB  2036 KiB/s 00:01 [######################################] 100%
 poppler-qt5-0.90.1-1-aarch64            166,9 KiB  1855 KiB/s 00:00 [######################################] 100%
 rav1e-0.3.3-1-aarch64                   885,6 KiB  1845 KiB/s 00:00 [######################################] 100%
 vulkan-icd-loader-1.2.147-1-aarch64      94,6 KiB  2,31 MiB/s 00:00 [######################################] 100%
 ffmpeg-2:4.3.1-1-aarch64                  8,6 MiB  1478 KiB/s 00:06 [######################################] 100%
 kfilemetadata-5.72.0-1-aarch64          361,7 KiB  2009 KiB/s 00:00 [######################################] 100%
 kidletime-5.72.0-1-aarch64              131,9 KiB  2,15 MiB/s 00:00 [######################################] 100%
 solid-5.72.0-1-aarch64                  815,8 KiB  1275 KiB/s 00:01 [######################################] 100%
 kwidgetsaddons-5.72.0-1-aarch64           4,7 MiB  1177 KiB/s 00:04 [######################################] 100%
 kjobwidgets-5.72.0-1-aarch64            293,0 KiB  2,04 MiB/s 00:00 [######################################] 100%
 kdbusaddons-5.72.0-1-aarch64            211,8 KiB  2,07 MiB/s 00:00 [######################################] 100%
 kwindowsystem-5.72.0-1-aarch64          726,4 KiB   765 KiB/s 00:01 [######################################] 100%
 kcrash-5.72.0-1-aarch64                 113,7 KiB  1895 KiB/s 00:00 [######################################] 100%
 kglobalaccel-5.72.0-1-aarch64           244,7 KiB   597 KiB/s 00:00 [######################################] 100%
 kauth-5.72.0-1-aarch64                  325,7 KiB   562 KiB/s 00:01 [######################################] 100%
 kcodecs-5.72.0-1-aarch64                336,0 KiB  1050 KiB/s 00:00 [######################################] 100%
 kguiaddons-5.72.0-1-aarch64             254,7 KiB  1213 KiB/s 00:00 [######################################] 100%
 kconfigwidgets-5.72.0-1-aarch64         961,2 KiB  1780 KiB/s 00:01 [######################################] 100%
 kitemviews-5.72.0-1-aarch64             579,4 KiB  1233 KiB/s 00:00 [######################################] 100%
 kiconthemes-5.72.0-1-aarch64            494,8 KiB  1151 KiB/s 00:00 [######################################] 100%
 kxmlgui-5.72.0-1-aarch64               1561,2 KiB  1346 KiB/s 00:01 [######################################] 100%
 kbookmarks-5.72.0-1-aarch64             482,9 KiB  1305 KiB/s 00:00 [######################################] 100%
 knotifications-5.72.0-1-aarch64         419,8 KiB  1166 KiB/s 00:00 [######################################] 100%
 kservice-5.72.0-1-aarch64               689,7 KiB  1379 KiB/s 00:01 [######################################] 100%
 kwallet-5.72.0-1-aarch64                482,9 KiB  1305 KiB/s 00:00 [######################################] 100%
 kcompletion-5.72.0-1-aarch64            668,9 KiB  2,04 MiB/s 00:00 [######################################] 100%
 sonnet-5.72.0-1-aarch64                 611,5 KiB  1853 KiB/s 00:00 [######################################] 100%
 ktextwidgets-5.72.0-1-aarch64           813,0 KiB  1232 KiB/s 00:01 [######################################] 100%
 kded-5.72.0-1-aarch64                    54,1 KiB  2,64 MiB/s 00:00 [######################################] 100%
 kio-5.72.0-1-aarch64                      7,0 MiB  1520 KiB/s 00:05 [######################################] 100%
 baloo-5.72.0-1-aarch64                  583,5 KiB   989 KiB/s 00:01 [######################################] 100%
 bluez-qt-5.72.0-1-aarch64               842,2 KiB  1257 KiB/s 00:01 [######################################] 100%
 breeze-icons-5.72.0-1-any                10,2 MiB  1146 KiB/s 00:09 [######################################] 100%
 kpackage-5.72.0-1-aarch64               343,3 KiB  2,10 MiB/s 00:00 [######################################] 100%
 knewstuff-5.72.0-1-aarch64             1656,2 KiB  1466 KiB/s 00:01 [######################################] 100%
 frameworkintegration-5.72.0-1-aarch64  1583,3 KiB   910 KiB/s 00:02 [######################################] 100%
 gdk-pixbuf2-2.40.0+6+g5432316df-1-...   649,5 KiB  1382 KiB/s 00:00 [######################################] 100%
 kactivities-5.72.0-1-aarch64            310,6 KiB  1941 KiB/s 00:00 [######################################] 100%
 kactivities-stats-5.72.0-1-aarch64      277,1 KiB  1979 KiB/s 00:00 [######################################] 100%
 kdeclarative-5.72.0-1-aarch64           471,8 KiB  2,09 MiB/s 00:00 [######################################] 100%
 kcmutils-5.72.0-1-aarch64               650,6 KiB  1971 KiB/s 00:00 [######################################] 100%
 kunitconversion-5.72.0-1-aarch64        914,5 KiB   914 KiB/s 00:01 [######################################] 100%
 kitemmodels-5.72.0-1-aarch64            668,7 KiB  2,04 MiB/s 00:00 [######################################] 100%
 kemoticons-5.72.0-1-aarch64            1852,7 KiB  1393 KiB/s 00:01 [######################################] 100%
 kparts-5.72.0-1-aarch64                 983,1 KiB  1260 KiB/s 00:01 [######################################] 100%
 kdelibs4support-5.72.0-1-aarch64          3,2 MiB  1082 KiB/s 00:03 [######################################] 100%
 kpty-5.72.0-1-aarch64                   201,2 KiB  1118 KiB/s 00:00 [######################################] 100%
 kdesu-5.72.0-1-aarch64                  230,9 KiB   592 KiB/s 00:00 [######################################] 100%
 kdnssd-5.72.0-1-aarch64                 310,5 KiB  2,02 MiB/s 00:00 [######################################] 100%
 kholidays-1:5.72.0-1-aarch64            354,3 KiB  2,04 MiB/s 00:00 [######################################] 100%
 kinit-5.72.0-1-aarch64                  128,0 KiB   427 KiB/s 00:00 [######################################] 100%
 kirigami2-5.72.0-1-aarch64              402,6 KiB  2013 KiB/s 00:00 [######################################] 100%
 kjs-5.72.0-1-aarch64                    356,4 KiB  1876 KiB/s 00:00 [######################################] 100%
 knotifyconfig-5.72.0-1-aarch64          202,3 KiB  2,19 MiB/s 00:00 [######################################] 100%
 kpeople-5.72.0-1-aarch64                376,6 KiB  2,04 MiB/s 00:00 [######################################] 100%
 kquickcharts-5.72.0-1-aarch64            91,9 KiB  1531 KiB/s 00:00 [######################################] 100%
 kwayland-5.72.0-1-aarch64                 2,8 MiB  1621 KiB/s 00:02 [######################################] 100%
 plasma-framework-5.72.0-1-aarch64         3,9 MiB  1554 KiB/s 00:03 [######################################] 100%
 threadweaver-5.72.0-1-aarch64           438,1 KiB  1752 KiB/s 00:00 [######################################] 100%
 krunner-5.72.0-2-aarch64                338,4 KiB  1538 KiB/s 00:00 [######################################] 100%
 syntax-highlighting-5.72.0-1-aarch64   1198,3 KiB  1619 KiB/s 00:01 [######################################] 100%
 ktexteditor-5.72.0-1-aarch64              3,2 MiB  1686 KiB/s 00:02 [######################################] 100%
 kwin-5.19.3-1.1-aarch64                   6,0 MiB  1286 KiB/s 00:05 [######################################] 100%
 libnm-1.26.0-1-aarch64                 1042,8 KiB   931 KiB/s 00:01 [######################################] 100%
 modemmanager-qt-5.72.0-1-aarch64        558,2 KiB   681 KiB/s 00:01 [######################################] 100%
 networkmanager-1.26.0-1-aarch64           2,8 MiB   805 KiB/s 00:04 [######################################] 100%
 networkmanager-qt-5.72.0-1-aarch64     1745,6 KiB   949 KiB/s 00:02 [######################################] 100%
 oxygen-icons-1:5.72.0-1-any              30,3 MiB  1175 KiB/s 00:26 [######################################] 100%
 python-idna-2.10-1-any                   66,8 KiB  2,18 MiB/s 00:00 [######################################] 100%
 python-setuptools-1:49.2.0-1-any        534,1 KiB  1008 KiB/s 00:01 [######################################] 100%
 poppler-glib-0.90.1-1-aarch64           231,0 KiB  1216 KiB/s 00:00 [######################################] 100%
 prison-5.72.0-1-aarch64                 146,3 KiB  2,04 MiB/s 00:00 [######################################] 100%
 qqc2-desktop-style-5.72.0-1-aarch64      64,8 KiB  2,11 MiB/s 00:00 [######################################] 100%
 suitesparse-5.8.1-1-aarch64             875,2 KiB  2,08 MiB/s 00:00 [######################################] 100%
 firefox-ublock-origin-1.28.2-1-any        2,7 MiB  1489 KiB/s 00:02 [######################################] 100%
 smplayer-20.6.0-1-aarch64                 3,2 MiB  1599 KiB/s 00:02 [######################################] 100%
(92/92) checking keys in keyring                                     [######################################] 100%
(92/92) checking package integrity                                   [######################################] 100%
(92/92) loading package files                                        [######################################] 100%
(92/92) checking for file conflicts                                  [######################################] 100%
(92/92) checking available disk space                                [######################################] 100%
:: Processing package changes...
( 1/92) upgrading libcap                                             [######################################] 100%
( 2/92) upgrading libcups                                            [######################################] 100%
( 3/92) upgrading libevdev                                           [######################################] 100%
( 4/92) upgrading shadow                                             [######################################] 100%
( 5/92) upgrading attica                                             [######################################] 100%
( 6/92) upgrading ki18n                                              [######################################] 100%
( 7/92) upgrading karchive                                           [######################################] 100%
( 8/92) upgrading kconfig                                            [######################################] 100%
( 9/92) upgrading kcoreaddons                                        [######################################] 100%
(10/92) upgrading poppler                                            [######################################] 100%
(11/92) upgrading poppler-qt5                                        [######################################] 100%
(12/92) installing rav1e                                             [######################################] 100%
(13/92) upgrading vulkan-icd-loader                                  [######################################] 100%
(14/92) upgrading ffmpeg                                             [######################################] 100%
(15/92) upgrading kfilemetadata                                      [######################################] 100%
(16/92) upgrading kidletime                                          [######################################] 100%
(17/92) upgrading gpgme                                              [######################################] 100%
(18/92) upgrading solid                                              [######################################] 100%
(19/92) upgrading kwidgetsaddons                                     [######################################] 100%
(20/92) upgrading kjobwidgets                                        [######################################] 100%
(21/92) upgrading kdbusaddons                                        [######################################] 100%
(22/92) upgrading kwindowsystem                                      [######################################] 100%
(23/92) upgrading kcrash                                             [######################################] 100%
(24/92) upgrading kglobalaccel                                       [######################################] 100%
(25/92) upgrading kauth                                              [######################################] 100%
(26/92) upgrading kcodecs                                            [######################################] 100%
(27/92) upgrading kguiaddons                                         [######################################] 100%
(28/92) upgrading kconfigwidgets                                     [######################################] 100%
(29/92) upgrading kitemviews                                         [######################################] 100%
(30/92) upgrading kiconthemes                                        [######################################] 100%
(31/92) upgrading kxmlgui                                            [######################################] 100%
(32/92) upgrading kbookmarks                                         [######################################] 100%
(33/92) upgrading knotifications                                     [######################################] 100%
(34/92) upgrading kservice                                           [######################################] 100%
(35/92) upgrading kwallet                                            [######################################] 100%
(36/92) upgrading kcompletion                                        [######################################] 100%
(37/92) upgrading sonnet                                             [######################################] 100%
(38/92) upgrading ktextwidgets                                       [######################################] 100%
(39/92) upgrading kded                                               [######################################] 100%
(40/92) upgrading kio                                                [######################################] 100%
(41/92) upgrading baloo                                              [######################################] 100%
(42/92) upgrading bluez-qt                                           [######################################] 100%
(43/92) upgrading breeze-icons                                       [######################################] 100%
(44/92) upgrading dhcpcd                                             [######################################] 100%
(45/92) upgrading firefox-ublock-origin                              [######################################] 100%
(46/92) upgrading kpackage                                           [######################################] 100%
(47/92) upgrading knewstuff                                          [######################################] 100%
(48/92) upgrading frameworkintegration                               [######################################] 100%
(49/92) upgrading gdk-pixbuf2                                        [######################################] 100%
(50/92) upgrading kactivities                                        [######################################] 100%
(51/92) upgrading kactivities-stats                                  [######################################] 100%
(52/92) upgrading kdeclarative                                       [######################################] 100%
(53/92) upgrading kcmutils                                           [######################################] 100%
(54/92) upgrading kunitconversion                                    [######################################] 100%
(55/92) upgrading kitemmodels                                        [######################################] 100%
(56/92) upgrading kemoticons                                         [######################################] 100%
(57/92) upgrading kparts                                             [######################################] 100%
(58/92) upgrading kdelibs4support                                    [######################################] 100%
(59/92) upgrading kpty                                               [######################################] 100%
(60/92) upgrading kdesu                                              [######################################] 100%
(61/92) upgrading kdnssd                                             [######################################] 100%
(62/92) upgrading kholidays                                          [######################################] 100%
(63/92) upgrading kinit                                              [######################################] 100%
(64/92) upgrading kirigami2                                          [######################################] 100%
(65/92) upgrading kjs                                                [######################################] 100%
(66/92) upgrading knotifyconfig                                      [######################################] 100%
(67/92) upgrading kpeople                                            [######################################] 100%
(68/92) upgrading kquickcharts                                       [######################################] 100%
(69/92) upgrading kwayland                                           [######################################] 100%
(70/92) upgrading plasma-framework                                   [######################################] 100%
(71/92) upgrading threadweaver                                       [######################################] 100%
(72/92) upgrading krunner                                            [######################################] 100%
(73/92) upgrading syntax-highlighting                                [######################################] 100%
(74/92) upgrading ktexteditor                                        [######################################] 100%
(75/92) upgrading kwin                                               [######################################] 100%
(76/92) upgrading libevent                                           [######################################] 100%
(77/92) upgrading libnm                                              [######################################] 100%
(78/92) upgrading mkinitcpio                                         [######################################] 100%
(79/92) upgrading linux-aarch64                                      [######################################] 100%
(80/92) upgrading modemmanager-qt                                    [######################################] 100%
(81/92) upgrading networkmanager                                     [######################################] 100%
(82/92) upgrading networkmanager-qt                                  [######################################] 100%
(83/92) upgrading openssh                                            [######################################] 100%
(84/92) upgrading oxygen-icons                                       [######################################] 100%
(85/92) upgrading python-idna                                        [######################################] 100%
(86/92) upgrading python-setuptools                                  [######################################] 100%
(87/92) upgrading pacman                                             [######################################] 100%
New optional dependencies for pacman
    findutils: for pacdiff --find [installed]
    haveged: for pacman-init.service [installed]
    mlocate: for pacdiff --locate
    sudo: privilege elevation for several scripts [installed]
    vim: default merge program for pacdiff
(88/92) upgrading poppler-glib                                       [######################################] 100%
(89/92) upgrading prison                                             [######################################] 100%
(90/92) upgrading qqc2-desktop-style                                 [######################################] 100%
(91/92) upgrading smplayer                                           [######################################] 100%
(92/92) upgrading suitesparse                                        [######################################] 100%
:: Running post-transaction hooks...
( 1/16) Creating system user accounts...
( 2/16) Reloading system manager configuration...
( 3/16) Creating temporary files...
( 4/16) Reloading device manager configuration...
( 5/16) Arming ConditionNeedsUpdate...
( 6/16) Updating module dependencies...
( 7/16) Updating linux-aarch64 module dependencies...
( 8/16) Updating linux-aarch64 initcpios...
==> Building image from preset: /etc/mkinitcpio.d/linux-aarch64.preset: 'default'
  -> -k 5.7.9-1-MANJARO-ARM -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
==> Starting build: 5.7.9-1-MANJARO-ARM
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [filesystems]
  -> Running build hook: [keyboard]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-linux.img
==> Image generation successful
( 9/16) Updating linux initcpios...
==> Building image from preset: /etc/mkinitcpio.d/linux-aarch64.preset: 'default'
  -> -k 5.7.9-1-MANJARO-ARM -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
==> Starting build: 5.7.9-1-MANJARO-ARM
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [filesystems]
  -> Running build hook: [keyboard]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-linux.img
==> Image generation successful
(10/16) Updating uimg initcpios...
Image Name:   Ramdisk Image
Created:      Sun Jul 19 17:16:34 2020
Image Type:   AArch64 Linux RAMDisk Image (uncompressed)
Data Size:    7854991 Bytes = 7670.89 KiB = 7.49 MiB
Load Address: 00000000
Entry Point:  00000000
(11/16) Reloading system bus configuration...
(12/16) Probing GDK-Pixbuf loader modules...
(13/16) Updating icon theme caches...
(14/16) Updating the info directory file...
(15/16) Updating the desktop file MIME type cache...
(16/16) Updating the MIME type database...
[nlc4@c4 ~]$ 

after the update

[nlc4@c4 ~]$ uptime
 17:24:05 up 5 min,  2 users,  load average: 0,72, 0,47, 0,20
[nlc4@c4 ~]$ screenfetch
                             nlc4@c4.test.2020.05.14
                             OS: Manjaro-ARM 20.07
                             Kernel: aarch64 Linux 5.7.9-1-MANJARO-ARM
         #####               Uptime: 4m
        #######              Packages: Unknown
        ##O#O##              Shell: bash 5.0.17
        #######              Resolution: 1920x1080
      ###########            DE: KDE 5.72.0 / Plasma 5.19.3
     #############           WM: KWin
    ###############          GTK Theme: Breeze [GTK2/3]
    ################         Icon Theme: oxygen
   #################         Disk: 16G / 59G (28%)
 #####################       CPU: Unknown @ 4x 1.908GHz
 #####################       GPU: 
   #################         RAM: 725MiB / 3628MiB
                            
                            
                            
[nlc4@c4 ~]$ date -u
dim. 19 juil. 2020 15:24:27 UTC
[nlc4@c4 ~]$ uname -a
Linux c4.test.2020.05.14 5.7.9-1-MANJARO-ARM #1 SMP Thu Jul 16 08:48:13 CEST 2020 aarch64 GNU/Linux
[nlc4@c4 ~]$ 
1 Like

Everything seems good on Pinebook Pro

1 Like

I added few more packages.

  • arm-testing community aarch64: 52 new and 47 removed package(s)
  • arm-testing core aarch64: 3 new and 2 removed package(s)
  • arm-testing extra aarch64: 16 new and 17 removed package(s)
:: Different overlay package(s) in repository community aarch64

-------------------------------------------------------------------------------
                             PACKAGE           2020-07-19           2020-07-20
-------------------------------------------------------------------------------
                  gnome-usage-mobile 3.33.2+28+g05741cb-2 3.33.2+28+g05741cb-3
                    matcha-gtk-theme           20200408-1           20200618-1
                   plasma-dialer-git       r220.2b1d44b-1       r221.2bfb2ef-1
                                 yay             10.0.2-1             10.0.3-1
                     element-desktop                    -              1.7.1-1
                         element-web                    -              1.7.1-1
                          mplus-font                    -              2.2.4-3


:: Different sync package(s) in repository community aarch64

-------------------------------------------------------------------------------
                             PACKAGE           2020-07-19           2020-07-20
-------------------------------------------------------------------------------
                      cargo-outdated             0.9.10-1             0.9.11-1
                            dokuwiki         20180422_c-1         20200609rc-1
                              drupal              9.0.0-1              9.0.2-1
                          fcitx5-gtk     0.0.0.20200607-1     0.0.0.20200607-2
                           fcitx5-qt     0.0.0.20200616-1     0.0.0.20200616-2
                             freerdp            2:2.1.2-1            2:2.2.0-1
                               fwupd              1.4.4-1              1.4.4-2
                               gajim              1.1.3-2              1.2.1-1
                       i3status-rust             0.14.1-3             0.14.1-4
                         jami-daemon           20190813-4           20190813-5
                             jenkins              2.244-1              2.245-1
                            libdwarf           20200703-1           20200719-1
                         libopenshot              0.2.5-2              0.2.5-3
                          librdkafka              1.4.4-1              1.5.0-1
                          mate-menus             1.24.0-1             1.24.0-2
                           nextcloud             19.0.0-1             19.0.1-1
                  nextcloud-app-mail              1.4.0-1              1.4.1-1
                 nextcloud-app-notes              3.6.0-1              3.6.1-1
                 nextcloud-app-tasks             0.13.1-1             0.13.2-1
                    nextcloud-client              2.6.5-1              2.6.5-2
                              nomacs          3.16.1705-1         1:3.16.224-1
                             opendht           1:1.10.1-6           1:1.10.1-7
                         pdfarranger              1.6.0-1              1.6.0-2
                            plantuml           1.2020.7-1          1.2020.15-1
                         python-caja             1.22.1-1             1.24.0-1
                     python-identify             1.4.23-1             1.4.24-1
                       python-minidb              2.0.3-1              2.0.4-1
                       python-nbxmpp             0.6.10-3              1.0.1-1
                        python2-caja             1.22.1-1                    -
                    python2-trollius                2.1-3          2.1.post2-1
                   python2-unittest2              1.1.0-5              1.1.0-6
                               qt5ct                1.0-1                1.1-1
                       roundcubemail              1.4.6-1              1.4.7-1
                            shotwell           2:0.30.8-2          2:0.30.10-1
                                sslh               1.20-2              1.21b-1
                         stratis-cli              2.1.0-1              2.1.1-1
                          unrealircd            5.0.5.1-1              5.0.6-1
                      usb_modeswitch              2.6.0-2              2.6.1-1
         v2ray-domain-list-community     20200719015510-1     20200719172212-1
                                 vtk             8.2.0-13             8.2.0-14
                              waybar              0.9.2-2              0.9.2-3
                             weechat                2.8-3                2.9-1
                             you-get           0.4.1432-2           0.4.1456-1
                             cpptoml                    -              0.1.1-2
              python-hypothesis-auto                    -              1.1.4-1
                         wireplumber                    -              0.3.0-1


:: Different overlay package(s) in repository core aarch64

-------------------------------------------------------------------------------
                             PACKAGE           2020-07-19           2020-07-20
-------------------------------------------------------------------------------
                            linux-rc            5.8.rc5-1            5.8.rc6-1
                    linux-rc-headers            5.8.rc5-1            5.8.rc6-1
                          uboot-vim1                    -            2020.04-2


:: Different sync package(s) in repository extra aarch64

-------------------------------------------------------------------------------
                             PACKAGE           2020-07-19           2020-07-20
-------------------------------------------------------------------------------
                                bind             9.16.5-1             9.16.5-2
                          bind-tools             9.16.5-1                    -
                               check             0.15.0-1             0.15.0-2
                          check-docs             0.15.0-1             0.15.0-2
                               cmake             3.18.0-1             3.18.0-2
                              deluge2.0.4.dev38+g23a48dd01-12.0.4.dev38+g23a48dd01-2
                          deluge-gtk2.0.4.dev38+g23a48dd01-12.0.4.dev38+g23a48dd01-2
                  gnome-disk-utility             3.36.1-2             3.36.3-1
                             gnuplot              5.2.8-2              5.4.0-1
                             hddtemp      0.3.beta15.53-2      0.3.beta15.53-3
                             jsoncpp              1.9.2-1              1.9.3-1
                         jsoncpp-doc              1.9.2-1              1.9.3-1
              plasma-wayland-session             5.19.3-1             5.19.3-2
                    plasma-workspace             5.19.3-1             5.19.3-2
                 python2-ordered-set              3.1.1-2              3.1.1-3
                            rinutils              0.4.0-1              0.4.1-1
                            xorg-xev              1.2.3-2              1.2.4-1
2 Likes

Can't start wayfire-git. I get an error from wlroots-0.11.0-1 :

wayfire: error while loading shared libraries: libwlroots.so.5: cannot open shared object file: No such file or directory

I guess recompiling wayfire-git , wf-config-git, wf-shell-git, wcm-git would do the trick.

Yes. Since wlroots got updated, the library is probably not avialable anymore.

I'll give a recompile a go tonight.

Wayfire can be set with wf-configand wlrootsas submodules to avoid such problems. Though I don't think it's worth the hassle of using such setup.

If something fails downgrade from AUR does the trick :smiley:

Forum kindly sponsored by