asbru not working after upgrade (Lysia 20.0.3)

Asbru not working after upgrade. I believe the perl version is changed and it is breaking something.

Can't locate OSSP/uuid.pm in @INC (you may need to install the OSSP::uuid module) (@INC contains: /opt/asbru/lib /opt/asbru/lib/ex /opt/asbru/lib/edit /home/krishna/perl5/lib/perl5/5.32.0/x86_64-linux-thread-multi /home/krishna/perl5/lib/perl5/5.32.0 /home/krishna/perl5/lib/perl5/x86_64-linux-thread-multi /home/krishna/perl5/lib/perl5 /usr/lib/perl5/5.32/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.32/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.32/core_perl /usr/share/perl5/core_perl) at /opt/asbru/lib/PACMain.pm line 44.
BEGIN failed--compilation aborted at /opt/asbru/lib/PACMain.pm line 44.
Compilation failed in require at /usr/bin/asbru-cm line 93.
BEGIN failed--compilation aborted at /usr/bin/asbru-cm line 93.

System:
Host: linux Kernel: 5.6.19-2-MANJARO x86_64 bits: 64 compiler: gcc
v: 10.1.0 Desktop: Cinnamon 4.6.6 dm: LightDM 1.30.0 Distro: Manjaro Linux
Machine:
Type: Virtualbox System: innotek product: VirtualBox v: 1.2
serial: Chassis: Oracle Corporation type: 1 serial:
Mobo: Oracle model: VirtualBox v: 1.2 serial: BIOS: innotek
v: VirtualBox date: 12/01/2006
Battery:
ID-1: BAT0 charge: 48.5 Wh condition: 50.0/50.0 Wh (100%) volts: 10.0/10.0
model: innotek 1 type: Unknown serial: N/A status: Charging
CPU:
Topology: Triple Core model: Intel Core i5-8350U bits: 64 type: MCP
arch: Kaby Lake rev: A L2 cache: 6144 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
bogomips: 11379
Speed: 1896 MHz min/max: N/A Core speeds (MHz): 1: 1896 2: 1896 3: 1896
Graphics:
Device-1: VMware SVGA II Adapter driver: vmwgfx v: 2.17.0.0
bus ID: 00:02.0 chip ID: 15ad:0405
Display: x11 server: X.Org 1.20.8 driver: vmware unloaded: modesetting
alternate: fbdev,vesa resolution: 1440x900~60Hz
OpenGL: renderer: SVGA3D; build v: 2.1 Mesa 20.1.3 direct render: Yes
Audio:
Device-1: Intel 82801AA AC97 Audio vendor: Dell driver: snd_intel8x0
v: kernel bus ID: 00:05.0 chip ID: 8086:2415
Sound Server: ALSA v: k5.6.19-2-MANJARO
Network:
Device-1: Intel 82540EM Gigabit Ethernet driver: e1000 v: 7.3.21-k8-NAPI
port: d020 bus ID: 00:03.0 chip ID: 8086:100e
IF: enp0s3 state: up speed: 1000 Mbps duplex: full mac:
Device-2: Intel 82371AB/EB/MB PIIX4 ACPI type: network bridge
driver: piix4_smbus v: N/A port: d200 bus ID: 00:07.0 chip ID: 8086:7113
Device-3: Intel 82540EM Gigabit Ethernet driver: e1000 v: 7.3.21-k8-NAPI
port: d240 bus ID: 00:08.0 chip ID: 8086:100e
IF: enp0s8 state: up speed: 1000 Mbps duplex: full mac:
Drives:
Local Storage: total: 60.00 GiB used: 9.54 GiB (15.9%)
ID-1: /dev/sda vendor: VirtualBox model: VBOX HARDDISK size: 60.00 GiB
speed: 3.0 Gb/s serial: rev: 1.0 scheme: MBR
Partition:
ID-1: / size: 58.80 GiB used: 9.54 GiB (16.2%) fs: ext4 dev: /dev/sda1
Sensors:
Message: No sensors data was found. Is sensors configured?
Info:
Processes: 171 Uptime: 2h 36m Memory: 2.92 GiB used: 1.54 GiB (52.7%)
Init: systemd v: 245 Compilers: gcc: 10.1.0 Shell: bash v: 5.0.18
running in: gnome-terminal inxi: 3.0.37

Yes, it did recently. There would have been a message during installation. You'll need to rebuild any affected AUR packages. Standard procedure.

1 Like

I rebuild asbru. Still, getting the same error.

It is generally good practice and recommended to rebuild all AUR packages after a system update.

The reason is simple - you may not know if all dots are connected - and often you need to reboot your system to ensure all loaded system modules are using the - possible - update.

how to rebuild all AUR packages.
Recently, i switched to manjaro.

pamac update --aur

Done. Still, asbru is not working. Getting the same error.

I don't know what the application's usage is but I have no problem building asbru-cm-git (the recommended version) and running it - so I am thinking it is something at your end.

Relevant sysinfo

System:
  Kernel: 5.7.10-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 
  Desktop: Openbox 3.6.1 info: polybar, tint2 dm: LXDM Distro: Manjaro Linux
Info:
  Processes: 335 Uptime: 11h 38m Memory: 62.70 GiB used: 2.25 GiB (3.6%) 
  Init: systemd v: 245 target: graphical.target Compilers: gcc: 10.1.0 
  Shell: zsh v: 5.8 running in: termite inxi: 3.0.37
Summary

20200726-172337_1074x846_screenshot

Hi Aarhus,

Please let me know the perl version.

I am using unstable branch fully updated.

➜  ~ perl -v

This is perl 5, version 32, subversion 0 (v5.32.0) built for x86_64-linux-thread-multi
....
➜  ~ pamac build asbru-cm-git
Preparing...
Cloning asbru-cm-git build files...
Checking asbru-cm-git dependencies...
Cloning perl-io-stty build files...
Checking perl-io-stty dependencies...
Cloning perl-crypt-rijndael build files...
Checking perl-crypt-rijndael dependencies...
Cloning uuid build files...
Checking uuid dependencies...
Cloning perl-net-arp build files...
Checking perl-net-arp dependencies...
Cloning perl-expect build files...
Checking perl-expect dependencies...
Resolving dependencies...
Checking inter-conflicts...
To install (33):
  autoconf                        2.69-7                 core       605,4 kB
  automake                        1.16.2-3               core       617,9 kB
  binutils                        2.34-5                 core       5,5 MB
  bison                           3.6.4-1                core       720,2 kB
  cairo-perl                      1.107-2                extra      87,2 kB
  elfutils                        0.180-1                core       634,7 kB
  fakeroot                        1.24-2                 core       68,6 kB
  flex                            2.6.4-3                core       304,4 kB
  gc                              8.0.4-4                extra      240,3 kB
  gcc                             10.1.0-2               core       33,2 MB
  glib-perl                       1.329-4                extra      313,7 kB
  guile                           2.2.6-2                extra      6,7 MB
  libmicrohttpd                   0.9.71-1               core       207,7 kB
  libmpc                          1.1.0-2                core       66,6 kB
  libwnck3                        3.36.0-1               extra      441,8 kB
  libxres                         1.2.0-2                extra      10,7 kB
  m4                              1.4.18-3               core       173,4 kB
  make                            4.3-3                  core       493,2 kB
  pango-perl                      1.227-13               extra      158,4 kB
  patch                           2.7.6-8                core       94,7 kB
  perl-cairo-gobject              1.004-10               community  9,2 kB
  perl-crypt-blowfish             2.14-11                community  15,8 kB
  perl-crypt-cbc                  2.33-4                 community  22,1 kB
  perl-glib-object-introspection  0.047-5                community  66,9 kB
  perl-gtk3                       0.037-1                community  28,9 kB
  perl-gtk3-simplelist            0.21-1                 community  17,6 kB
  perl-inc-latest                 0.500-7                extra      12,7 kB
  perl-io-tty                     1.12-10                community  32,7 kB
  perl-module-build               0.4231-3               extra      179,8 kB
  perl-socket6                    0.29-5                 extra      17,8 kB
  perl-test-manifest              2.021-2                community  11,0 kB
  perl-yaml                       1.30-2                 extra      47,9 kB
  pkgconf                         1.7.3-1                core       59,6 kB
To build (6):
  asbru-cm-git                    6.2.1.r3.g9f10b16-1    AUR
  perl-crypt-rijndael             1.14-1                 AUR
  perl-expect                     1.35-1                 AUR
  perl-io-stty                    0.30.0-6               AUR
  perl-net-arp                    1.0.9-1                AUR
  uuid                            1.6.2-19               AUR

Total download size: 51,1 MB
Total installed size: 251,8 MB
Edit build files ? [y/N] 
...

==> Creating package "asbru-cm-git"...
  -> Generating .PKGINFO file...
  -> Generating .BUILDINFO file...
  -> Generating .MTREE file...
  -> Compressing package...
==> Leaving fakeroot environment.
==> Finished making: asbru-cm-git 6.2.1.r10.gd6123cf-1 (2020-08-01T15:32:42 CEST)
==> Cleaning up...

Checking keyring...                                                         [1/1]
Checking integrity...                                                       [1/1]
Loading packages files...                                                   [1/1]
Checking file conflicts...                                                  [1/1]
Checking available disk space...                                            [1/1]
Installing asbru-cm-git (6.2.1.r10.gd6123cf-1)...                           [1/1]
Running post-transaction hooks...
Arming ConditionNeedsUpdate...                                              [1/2]
Updating the desktop file MIME type cache...                                [2/2]
Transaction successfully finished.


Current system has just been reinstalled - just playing :slight_smile:

Hi,

I'm on stable branch. Manjaro - cinnamon.

I can see two versions of perl.
krishna@hp440 ~]$ ls -ltrh /usr/lib/perl5/
total 12K
drwxr-xr-x 2 root root 4.0K Sep 11 2018 x86_64-linux-thread-multi
drwxr-xr-x 5 root root 4.0K Jul 5 2019 5.30
drwxr-xr-x 5 root root 4.0K Jul 21 10:58 5.32
[krishna@hp440 ~]$

In my view asbru is not configured to use perl 5.32. How can i configure asbru to use perl 5.32

I don't know - my system yields same result as yours

➜  ~ ls -ltrh /usr/lib/perl5
total 8,0K
drwxr-xr-x 5 root root 4,0K Aug  1 12:56 5.32
drwxr-xr-x 3 root root 4,0K Aug  1 12:56 5.30

Launching from console - it appears to be using 5.32

➜  ~ asbru-cm
INFO: Ásbrú Connection Manager 6.2.2 (asbru-cm) started with PID 27618
INFO: Desktop environment detected : xfce
INFO: Config directory is '/home/fh/.config/asbru'
GLib-LOG **: unsetenv() is not thread-safe and should not be used after threads are created at /usr/lib/perl5/5.32/vendor_perl/Glib/Object/Introspection.pm line 67.
INFO: Used config file '/home/fh/.config/asbru/asbru.nfreeze'
INFO: Virtual terminal emulator (VTE) version is 0.60
INFO: Theme directory is '/opt/asbru-cm/res/themes/default'
INFO: Using Gnome tray icon

A note - my environment is not xfce - it just pretend to be - using xfsettingsd.

System:
  Kernel: 5.7.12-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 
  Desktop: Xfce info: polybar, tint2 wm: Openbox 3.6.1 dm: LXDM 
  Distro: Manjaro Linux 

Thanks Aarhus,

Finally, i was able to fix it. You were perfectly right rebuild the packages. Thanks for help.

I rebuild the packages, showing in the error.
pamac build asbru-cm-git
pamac build uuid
pamac build perl-net-arp

[krishna@hp440 ~]$ asbru-cm
Can't locate Net/ARP.pm in @INC (you may need to install the Net::ARP module) (@INC contains: /opt/asbru-cm/lib /opt/asbru-cm/lib/ex /opt/asbru-cm/lib/edit /usr/lib/perl5/5.32/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.32/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.32/core_perl /usr/share/perl5/core_perl) at /opt/asbru-cm/lib/PACUtils.pm line 43.
BEGIN failed--compilation aborted at /opt/asbru-cm/lib/PACUtils.pm line 43.
Compilation failed in require at /opt/asbru-cm/lib/PACMain.pm line 54.
BEGIN failed--compilation aborted at /opt/asbru-cm/lib/PACMain.pm line 54.
Compilation failed in require at /usr/bin/asbru-cm line 93.
BEGIN failed--compilation aborted at /usr/bin/asbru-cm line 93.

[krishna@hp440 ~]$ asbru-cm
INFO: Ásbrú Connection Manager 6.2.2 (asbru-cm) started with PID 5669
INFO: Desktop environment detected : cinnamon
INFO: Config directory is '/home/krishna/.config/asbru'
GLib-LOG **: unsetenv() is not thread-safe and should not be used after threads are created at /usr/lib/perl5/5.32/vendor_perl/Glib/Object/Introspection.pm line 67.
INFO: Used config file '/home/krishna/.config/asbru/asbru.nfreeze'
INFO: Virtual terminal emulator (VTE) version is 0.60
INFO: Theme directory is '/opt/asbru-cm/res/themes/default'
INFO: Using Gnome tray icon

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by