ASUS Netbook FN-Volume keys not working

Ok, so i installed Manjaro 19.2 Xfce onto my Netbook. Working great so far. Had some problems with signatures but its been solved by now. I have a problem with my FN-Volume keys. they just dont work. I had the same problem in linux mint but back then i found a fix for that. I needed to edit the grub config and add "acpi=os" or something similar to that and after a restart it started working. Now the question: Can i use the same tuorial from linux mint on manjaro? Do i need to add something ?

Link to the Linux Mint Tutorial: https://askubuntu.com/questions/866437/function-keys-do-not-work-brightness-sound-ubuntu-16-04

( I know its a ubuntu tutorial but linux mint is basically ubuntu so im sorry for that)

P.S. I installed Manjaro the second time already because i followed this tutorial and ■■■■■■■ my system. Plz help

Can you post inxi -F or sth., please?

I guess, it is a better idea to follow the Arch Wiki: https://wiki.archlinux.org/index.php/ASUS_Eee_PC_1201N#ACPI_Functions
But your EeePC might be different!

Hi,

Just adding this link in continuation of eugen's post.

ASUS Eee PC - Arch Wiki:

https://wiki.archlinux.org/index.php/ASUS_Eee_PC

Kind regards

Strarup

This is something you should not ask us, because we don't use Ubuntu.. As stated before, better search for os specific documentation, instead of Ubuntu's. You can try Ubuntu documentation and tutorials, but you're mostly on your own (at least that's how I see it).

@datiswous
regarding Ubuntu, a lot of arch Aur package's use Ubuntu deb packages. And some linux stuff is similar, no matter what linux distro you use.

e.g. I had a problem with my wife's Asus eeepc 1001pxd that uses a alc269vb sound driver
I wasn't able to find any solution on either Manjaro or the Arch forums, but did find a solution on a Ubuntu forum after 3 days search.
The problem was somehow a conf thingie between Alsa and Pulseaudio with that driver. So without the Ubuntu forum I wouldn't have found a solution. :slight_smile:
Now the sound is working on her Asus with Manjaro32 xfce on it.

Also dennikali is asking for an Manjaro/Arch solution as far as i have understood, and not a Ubuntu solution, just linking to something from a ubuntu forum, asking if the same is possible in Manjaro/arch.


@dennikali
regarding Fn keys, I don't know which Asus netbook you have.
but if you have a eee pc, there is an AUR package called acpi-eeepc-generic

however it is not possible to install via pamac, or something else as it depends on xorg-server-utils,
which has been removed from repo, which might explain the Aur package hasn't been updated since 2017. (original github package not since 2015)

if you have a eee pc, that it supports you can try the following, and build it yourself.

to be able to build it you need the base-devel package

pacman -S base-devel

more info at wiki about makepkg cmd
https://wiki.manjaro.org/index.php?title=Makepkg

to get the source use git clone in terminal.

git clone https://aur.archlinux.org/acpi-eeepc-generic.git

edit the line depends, in the downloaded PKGBUILD file, and remove xorg-server-utils from it.

before: depends=(acpid xorg-server-utils dmidecode)
after: depends=(acpid dmidecode)

xorg-server-utils seems to have become xorg-apps.
I tried to modify xorg-server-utils to xorg-apps in PKGBUILD, it didn't work, why I deleted it from the line...

And before making the package, i installed xorg-apps, just to be sure.

sudo pacman -S xorg-apps

then in terminal:

cd acpi-eeepc-generic
makepkg

this will create: acpi-eeepc-generic-1.0.2-3-any.pkg.tar.xz
to install

sudo pacman -U acpi-eeepc-generic-1.0.2-3-any.pkg.tar.xz

I have tried on my wife's Asus EEE pc 1001pxd, unfortunately there's no conf file on the git page.
and i haven't had time to dig deeper into it at the moment. So if it works as intended I don't know.

regarding GRUB, if you by accident get it ■■■■■■■ again

I used this wiki article to restore the grub with a manjaro live usb, once i messed up the grub.
https://wiki.manjaro.org/index.php/Restore_the_GRUB_Bootloader

list of boot grub problems tutorials

so you hopefully don't have to reinstall Manjaro if grub gets messed up again. :slight_smile:

kind regards

Strarup

1 Like

kernel parameters (and this is what the Ubuntu advice is about) are indeed very similar between Linuxes

I also use Ubuntu sources for manjaro problem fixes, but I don't ask this forum if they can be applied. But anyway, maybe I'm wrong.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by