At my wits end... random freezing!

In addition to the preceding recommendations, pls note this:

Since that hard-fought discovery, i now inspect/clean that mesh every few months, & all those horrible random freezes have ceased.

1 Like

Check your memory usage. Is your 16GB all used up? If yes, you may be experiencing a disk thrashing issue.

I forgot to mention that Windows works perfectly fine on the system.
I clean the system every 3 months. Everything is plugged in correctly.
Conky shows that ram usage doesn't go above 4.
I've had the system for a year and have been having trouble since day one. I've factory resetted the BIOS a few times to no avail.

I haven't run fsck or memtest on everything as Windows always worked fine but I'm pretty desperate at this point so I'll give ita whirl.

could you give us the output of the terminal command inxi -Fxz

For troubleshooting check for error logs

journalctl -p3 | cat
cat /var/log/Xorg.0.log* | grep "(EE)"

Most "random" freezes are hardware-related.

You can rule out any changes to Manjaro (configuration, updates) by booting from a live installer and see if the issue still occurs.

Since this is a CPU and not an APU, you can rule out those issues caused by the new integrated GPUs, which is good. The thing is that Ryzen 1700 is quite mature now and should have good support.

I have a 1200 and a 1600 from the same generation. Both on similar motherboards from the same brand. Both listed my chosen memory in the "Memory Qualified Vendor List" but also specified a specific version of it. My dealer could not deliver any specific version, and of course in the end it did not exactly match. On the 1600 it worked perfectly, but the 1200 had random freezes, but those were also in Windows. So check your Memory QVL, but it should be fine since it works in Windows.

Since you haven't mentioned any kernel boot parameters, please check this thread (worked on my Ryzen APU, but I have read it also worked on some first generation Ryzen): AMD Ryzen: Problems and Fixes 🔧

Also update the kernel to the latest stable, just in case. Best wishes! :+1:

1 Like

inxi -Fxz output:

           Desktop: KDE Plasma 5.13.5 Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: ASUSTeK model: PRIME X370-PRO v: Rev X.0x serial: <filter> 
           UEFI: American Megatrends v: 4012 date: 06/14/2018 
CPU:       Topology: 8-Core model: AMD Ryzen 7 1700 bits: 64 type: MT MCP arch: Zen rev: 1 L2 cache: 4096 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 95854 
           Speed: 1496 MHz min/max: 1550/3000 MHz Core speeds (MHz): 1: 1393 2: 1376 3: 2906 4: 2587 5: 1445 
           6: 1277 7: 2558 8: 2585 9: 1372 10: 1369 11: 1372 12: 1371 13: 1373 14: 1371 15: 2576 16: 2592 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X] 
           driver: amdgpu v: kernel bus ID: 09:00.0 
           Device-2: NVIDIA GP106 [GeForce GTX 1060 6GB] driver: nvidia v: 410.57 bus ID: 0a:00.0 
           Display: x11 server: X.Org 1.20.1 driver: amdgpu,ati,modesetting,nouveau resolution: 1920x1080~60Hz 
           OpenGL: renderer: AMD Radeon RX 480 Graphics (POLARIS10 DRM 3.19.0 4.14.74-1-MANJARO LLVM 7.0.0) 
           v: 4.5 Mesa 18.2.2 direct render: Yes 
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] Ellesmere [Radeon RX 580] driver: snd_hda_intel v: kernel 
           bus ID: 09:00.1 
           Device-2: NVIDIA GP106 High Definition Audio driver: snd_hda_intel v: kernel bus ID: 0a:00.1 
           Device-3: Advanced Micro Devices [AMD] Family 17h HD Audio driver: snd_hda_intel v: kernel 
           bus ID: 0c:00.3 
           Device-4: Logitech HD Pro Webcam C920 type: USB driver: snd-usb-audio,uvcvideo bus ID: 3-1:2 
           Sound Server: ALSA v: k4.14.74-1-MANJARO 
Network:   Device-1: Intel I211 Gigabit Network driver: igb v: 5.4.0-k port: c000 bus ID: 07:00.0 
           IF: enp7s0 state: down mac: <filter> 
           Device-2: Realtek RTL8192CE PCIe Wireless Network Adapter driver: rtl8192ce v: kernel port: b000 
           bus ID: 08:00.0 
           IF: wlp8s0 state: up mac: <filter> 
Drives:    Local Storage: total: 2.73 TiB used: 80.81 GiB (2.9%) 
           ID-1: /dev/sda vendor: Samsung model: SSD 850 EVO 500GB size: 465.76 GiB 
           ID-2: /dev/sdb vendor: Seagate model: ST1500DL003-9VT16L size: 1.36 TiB 
           ID-3: /dev/sdc vendor: Seagate model: ST1000DM003-1CH162 size: 931.51 GiB 
Partition: ID-1: / size: 95.62 GiB used: 23.33 GiB (24.4%) fs: ext4 dev: /dev/sda5 
Sensors:   System Temperatures: cpu: 27.5 C mobo: N/A gpu: amdgpu temp: 25 C 
           Fan Speeds (RPM): cpu: 0 gpu: amdgpu fan: 907 
Info:      Processes: 305 Uptime: 2m Memory: 15.66 GiB used: 1.52 GiB (9.7%) Init: systemd Compilers: 
           gcc: 8.2.1 Shell: bash v: 4.4.23 inxi: 3.0.26

cat /var/log/Xorg.0.log* | grep "(EE)" output:

[     6.216] (EE) Failed to load module "nv" (module does not exist, 0)
[     6.217] (EE) Failed to load module "fbdev" (module does not exist, 0)
[     6.217] (EE) Failed to load module "vesa" (module does not exist, 0)
[     6.218] (EE) [drm] Failed to open DRM device for (null): -2
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  2118.209] (EE) Failed to load module "nv" (module does not exist, 0)
[  2118.209] (EE) Failed to load module "fbdev" (module does not exist, 0)
[  2118.209] (EE) Failed to load module "vesa" (module does not exist, 0)
[  2118.209] (EE) [drm] Failed to open DRM device for (null): -2

Also, should I try updating the kernel to the experimental one? I had it on 4.18 when I was trying to fix it with Arch. I will do everything in that posted thread. There were some things in that list I did, but not everything.

Also, Memory QVL... I can't seem to find my exact model. I had (CMK16GX4M2B3200C16W).

I have found CMK16GX4M2B3600C18 and CMK16GX4M2B3000C15(Ver4.24) on the list but not mine. Is this it? Should I try just switching RAM modules? I have another set of 16 GB in another machine and it's GSkill.

Latest stable should be fine.

It could be, and if you have some others you can test then I would. The "works fine in Windows" is a counter argument, so I would try the simpler alternatives first.

There is this:

Do not have Ryzen so cannot help further.

The thread I linked above takes into account that older thread. Me and @Strit have since solved our lockups. :grinning:

1 Like

So after updating and after following everything in that thread I thought I was safe. I was wrong. It just happened again.

I haven't tried replacing the RAM yet. I guess I'll do that next.

A little more detail. Right before it completely locks up, the computer seriously stutters like I'm playing a game at around 8fps and then gets worse and worse until it completely locks up. I had forgotten to mention it because the few times before I posted I was away. This time I was actively doing things so I took note of it this time around.

This sounds like you ran out of RAM - possibly caused by a memory leak in an application or driver.

Check your running processes (e.g. using top or htop) and watch for anything out of the ordinary. Ideally you can work out which application(s) is common to these events.

See... I thought that too. But memory never reached above 4gb out of 16gb even when I had quite a few firefox tabs, an electron app or 2, and then the actual KDE environment itself. As far as I could tell, I was always FAR away from running out of RAM. My RAM usage widget has always reported that I was more than fine.

I'll try to keep an even closer eye on it though. I've never seen the RAM usage the moment the freeze happens.

Next step would be to test your RAM. memtest should be on the GRUB boot menu.

Sounds solid. Thank you so much. Even if my problem isn't solved I'll be sure to recommend Manjaro to everyone just for the amount of support I've gotten from you guys.

1 Like

RAM passed all tests in memtest so there isn't anything there.

I don't currently have any swap as I never seemed to use it before. Would getting a little bit of swap be useful?

It provides some extra buffer instead of a hard lockup when RAM is exhausted - if it's on an HDD the slowdown and disk churn normally provides some early-warning while allowing you to take avoiding action.

Disk churn has saved me many a time. :slight_smile:

So... I made 10 Gb of swap and activated it. It happened again and the RAM usage was visible. It was only 2.4 Gb used and 0 bytes of swap was used. No audible disk churn. The swap partition was on an HDD. Just to test if it can get past 2.4 Gb of RAM I wrote a quick python script to load a lot of images into RAM by putting them in a list. It got to 15 GB of usage and then swap started to fill up and that got to 7GB usage before I terminated the program. The system slowed down a little bit while it was using swap but other than that, it didn't freeze completely.

I'm not sure what else to try outside of swapping RAM sticks. Any other ideas?

1 Like

Outside of physical RAM issues, the power supply would be a prime suspect in my book. So out of curiosity what kind of power supply? Also are you using an UPS? Does your area also have clean power (as in is the voltage consistent)?

Forum kindly sponsored by