Atheros AR9287 - Wireless Internet randomly stops working even when I am still connected (it load indefinetely)

Hello,

I am using manjaro i3 for a long time now, and I allways had this bug which drives me crazy :frowning:

What is happenning?

I am using manjaro, for programming personnal projects and for school.

Sometimes I want to see on the internet some documentation, what happen is that the page load indefinitely, I am still connected to the internet but it keeps loading and never finally loads.

The only fix I found is to click on the wifi icon and reclick in my wifi to restart the wifi. Then it is working fine for some time then randomly the bug come back again.

Please note than when my page is loading and I click on the wifi icon, the wifi disconnect and firefox display the page "no internet connection" after wifi disconnected. This is weird like if firefox know he have connection to the internet and try to load my page (indefinitely), but when I really disconnect the network, firefox know that he is no longer connected.

I had this issue also with discord and minecraft: not being able to see discord messages / minecraft available servers.

Another thing is that sometimes I play minecraft with a friend on discord, and the bug is happening, I am still connected to the server and able to talk with my friend but unable to load any new internet page.

I have seen some other people having the same issue like on this post: Wifi stops working even thought it appears as connected

I did not quite understood the fix of this post, thats why I am posting my own.

Here are some additional information they asked on the above post:

inxi -Fxxxza --no-host
System:    Kernel: 5.6.15-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.6-x86_64 root=UUID=4caa190d-5d25-4e4e-ac2a-f725132c82e8 rw quiet apparmor=1 
           security=apparmor udev.log_priority=3 
           Desktop: i3 4.18.1 info: i3bar dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:   Type: Desktop System: ASUS product: All Series v: N/A serial: <filter> 
           Mobo: ASUSTeK model: H81M-PLUS v: Rev X.0x serial: <filter> BIOS: American Megatrends v: 2106 date: 11/27/2014 
CPU:       Topology: Quad Core model: Intel Core i5-4590 bits: 64 type: MCP arch: Haswell family: 6 model-id: 3C (60) 
           stepping: 3 microcode: 27 L2 cache: 6144 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 26395 
           Speed: 3572 MHz min/max: 800/3700 MHz Core speeds (MHz): 1: 3577 2: 3533 3: 3525 4: 3532 
           Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled 
           Type: mds mitigation: Clear CPU buffers; SMT disabled 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: disabled, RSB filling 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: NVIDIA GM107 [GeForce GTX 750 Ti] driver: nvidia v: 418.113 bus ID: 01:00.0 chip ID: 10de:1380 
           Display: x11 server: X.Org 1.20.8 driver: nvidia resolution: 1920x1080~60Hz, 1920x1080~60Hz 
           OpenGL: renderer: GeForce GTX 750 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 418.113 direct render: Yes 
Audio:     Device-1: Intel 8 Series/C220 Series High Definition Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           bus ID: 00:1b.0 chip ID: 8086:8c20 
           Device-2: NVIDIA GM107 High Definition Audio [GeForce 940MX] driver: snd_hda_intel v: kernel bus ID: 01:00.1 
           chip ID: 10de:0fbc 
           Sound Server: ALSA v: k5.6.15-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK driver: r8169 v: kernel port: d000 
           bus ID: 03:00.0 chip ID: 10ec:8168 
           IF: enp3s0 state: down mac: <filter> 
           Device-2: Qualcomm Atheros AR9287 Wireless Network Adapter driver: ath9k v: kernel port: d000 bus ID: 04:00.0 
           chip ID: 168c:002e 
           IF: wlp4s0 state: up mac: <filter> 
Drives:    Local Storage: total: 1.82 TiB used: 103.84 GiB (5.6%) 
           ID-1: /dev/sda vendor: Toshiba model: DT01ACA100 size: 931.51 GiB block size: physical: 4096 B logical: 512 B 
           speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> rev: A750 scheme: MBR 
           ID-2: /dev/sdb vendor: Toshiba model: HDWD110 size: 931.51 GiB block size: physical: 4096 B logical: 512 B 
           speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> rev: A8J0 scheme: GPT 
Partition: ID-1: / raw size: 297.07 GiB size: 291.41 GiB (98.09%) used: 103.84 GiB (35.6%) fs: ext4 dev: /dev/sdb3 
Sensors:   System Temperatures: cpu: 50.0 C mobo: 27.8 C gpu: nvidia temp: 42 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 31% 
Info:      Processes: 182 Uptime: 41m Memory: 7.71 GiB used: 3.65 GiB (47.3%) Init: systemd v: 245 Compilers: gcc: 10.1.0 
           Shell: bash v: 5.0.17 running in: urxvtd inxi: 3.0.37

hwinfo --netcard

06: PCI 300.0: 0200 Ethernet controller                         
  [Created at pci.386]
  Unique ID: UOJ9.Jl2lCs4I0S5
  Parent ID: hoOk.Tmd3Ya8ZUkD
  SysFS ID: /devices/pci0000:00/0000:00:1c.2/0000:03:00.0
  SysFS BusID: 0000:03:00.0
  Hardware Class: network
  Model: "Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller"
  Vendor: pci 0x10ec "Realtek Semiconductor Co., Ltd."
  Device: pci 0x8168 "RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller"
  SubVendor: pci 0x1043 "ASUSTeK Computer Inc."
  SubDevice: pci 0x8554 
  Revision: 0x0c
  Driver: "r8169"
  Driver Modules: "r8169"
  Device File: enp3s0
  I/O Ports: 0xd000-0xd0ff (rw)
  Memory Range: 0xf7300000-0xf7300fff (rw,non-prefetchable)
  Memory Range: 0xf2100000-0xf2103fff (ro,non-prefetchable)
  IRQ: 18 (no events)
  HW Address: 08:62:66:49:4b:2b
  Permanent HW Address: 08:62:66:49:4b:2b
  Link detected: no
  Module Alias: "pci:v000010ECd00008168sv00001043sd00008554bc02sc00i00"
  Driver Info #0:
    Driver Status: r8169 is active
    Driver Activation Cmd: "modprobe r8169"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #24 (PCI bridge)

22: PCI 400.0: 0282 WLAN controller
  [Created at pci.386]
  Unique ID: YVtp.Ff+GTzveSKA
  Parent ID: Z7uZ.VbWZVjNzXVE
  SysFS ID: /devices/pci0000:00/0000:00:1c.3/0000:04:00.0
  SysFS BusID: 0000:04:00.0
  Hardware Class: network
  Model: "Qualcomm Atheros AR9287 Wireless Network Adapter (PCI-Express)"
  Vendor: pci 0x168c "Qualcomm Atheros"
  Device: pci 0x002e "AR9287 Wireless Network Adapter (PCI-Express)"
  SubVendor: pci 0x168c "Qualcomm Atheros"
  SubDevice: pci 0x30a4 
  Revision: 0x01
  Driver: "ath9k"
  Driver Modules: "ath9k", "ath9k"
  Device File: wlp4s0
  Features: WLAN
  Memory Range: 0xf7200000-0xf720ffff (rw,non-prefetchable)
  IRQ: 19 (355773 events)
  HW Address: 30:b5:c2:e6:45:61
  Permanent HW Address: 30:b5:c2:e6:45:61
  Link detected: yes
  WLAN channels: 1 2 3 4 5 6 7 8 9 10 11 12 13
  WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462 2.467 2.472
  WLAN encryption modes: WEP40 WEP104 TKIP CCMP
  WLAN authentication modes: open sharedkey wpa-psk wpa-eap
  Module Alias: "pci:v0000168Cd0000002Esv0000168Csd000030A4bc02sc80i00"
  Driver Info #0:
    Driver Status: ath9k is active
    Driver Activation Cmd: "modprobe ath9k"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #14 (PCI bridge)

I tried to update today my hole system with sudo pacman -Syyu but the issue still happened after the update and reboot :frowning:

I hope that you can help me with that, because recently it is hapenning very often and this issue is very annoying :frowning:

It sounds like that adapter may just be prone to that issue.

https://bbs.archlinux.org/viewtopic.php?id=129344

Try the fixes suggested in the above thread.

You could also test out the service I wrote in the link you posted. While that is not a fix it makes the random disconnections more tolerable.

The posts I have read seem to point to an issue with this adapter on newer kernels. I would work backwards installing progressively older kernels until you have tested all kernels that will boot with your computer.

It's a desktop, can't just route an ethernet cable to it?

Or you could use powerline adapters if cabling to that location is problematic.

If that option is too expensive for you a far more modern adapter can be purchased relatively inexpensively that would give you better performance than an adapter of that age.

Thank you for your answers!

I will try the solutions in the post you posted.

Unfortunately, my parents don't want me to have an internet cable which takes the size of the house :frowning:

And sorry, but I don't understand what you meant by "adapter", I tried to translate it in french but what I got is this:

I don't think that what you meant with it.

And also, I forgot to mention, but I am on dual boot with windows on my computer and I never had this issue on windows.

A powerline network uses your homes pre-existing electrical wiring to transmit your network signal. You plug one adapter into an electrical outlet near your router. You plug one adapter into an electrical outlet near your computer, and then you connect both with cat6 Ethernet network cabling. While more expensive to purchase it is extremely fast and reliable (unlike wifi).

An adapter is simply a term that means a network card that can be either Wifi or Ethernet based.

Ha thank you,

I can't place this too in my house :frowning:

I think you are misunderstanding how powerline networking works. It can be used in almost any home unless the wiring is extremely old and unreliable.

Thanks for your details.

In France we call that CPL, I don't know if it is the same in english.

The problem is that my parents don't want to put this device in their home.

And also I am not really willing to pay to solve a problem which comes from the OS...

C'est la vie.

Hello,

I am back for some good news :slight_smile:

I wanted to try one by one every fix proposed there: https://bbs.archlinux.org/viewtopic.php?id=129344

I did this one:

sudo -s

echo "options ath9k nohwcrypt=1" > /etc/modprobe.d/ath9k.conf

Reboot.

And it looks like the issue is no longer happening.

I mean, yesterday I have worked for couple hours and the issue happened only once (maybe we can put that on bad luck). And today I am working for a couple of hours already and I had 0 issue.

I think that have finally fixed the issue ^^ thank you for your answers :slight_smile:

1 Like

Sorry for not suggesting that fix to you as it is a fairly well known option. Every post I read with your issue with your adapter model said that that option made no difference, so I never bothered to suggest it.

That's a good lesson for me, in the future I will disregard posts with negative results if it seems like a possible fix to me.

Good for you for keeping at it and not giving up. Thank you for reporting back with your positive outcome.

So glad this had a happy ending for you, and you're welcome.

Edit: upon looking over my first post I see I did suggest testing that fix as I linked to it from the Arch forum. So I didn't have a large brain fart after all.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by