Atheros ath10k - wifi down after resume

Hello,
Occasionally I have no wifi when returning to my laptop (closing-opening lid).
Experienced it with kernels 5.3(currently running), and previously with 4.19 and 4.14.

Network controller: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter (rev 32)

A possible clue following the resume time below?
sudo dmesg|grep wlp2s0

[    4.038600] ath10k_pci 0000:02:00.0 wlp2s0: renamed from wlan0
[   24.664236] wlp2s0: authenticate with a0:bd:cd:14:10:25
[   24.714862] wlp2s0: send auth to a0:bd:cd:14:10:25 (try 1/3)
[   24.715735] wlp2s0: authenticated
[   24.716736] wlp2s0: associate with a0:bd:cd:14:10:25 (try 1/3)
[   24.727846] wlp2s0: RX AssocResp from a0:bd:cd:14:10:25 (capab=0x1011 status=0 aid=2)
[   24.730835] wlp2s0: associated
[   24.776813] IPv6: ADDRCONF(NETDEV_CHANGE): wlp2s0: link becomes ready
[   24.821231] wlp2s0: Limiting TX power to 23 (23 - 0) dBm as advertised by a0:bd:cd:14:10:25
[ 6509.974271] wlp2s0: deauthenticating from a0:bd:cd:14:10:25 by local choice (Reason: 3=DEAUTH_LEAVING)
[ 6529.251315] p2p-dev-wlp2s0:  Failed check-sdata-in-driver check, flags: 0x0
[ 6529.251455] wlp2s0:  Failed check-sdata-in-driver check, flags: 0x0

In that state i tried the following;
rfkill revealed all unblocked.
sudo modprobe -r ath10k_pci
sudo modprobe -r ath10k_core
sudo modprobe ath10k_pci
sudo modprobe ath10k_core
sudo systemctl restart NetworkManager

A reboot resolves it, but i wonder if there are some commands i can try to recover it first?

Thankyou.

Please, search the forum next time before posting, you might save some of us a bit of aggravation.
The 5.3 kernel is causing issues with networking, among other things, downgrade the kernel back to 4.19. You could possibly try the 5.4 kernel, but that's experimental, and would probably be worse.

To be fair i said 5.3,4.19,4.14? and i searched.
The problem is intermittent.

@AJSlye is fully correct, the biggist factor in wifi suspend failures is the kernel you are using.

However, sometimes switching kernels will not resolve the issue. Sometimes there is no easy fix for wifi suspend failures. In those cases you can write a suspend service to unload all your network components prior to suspend and reload them upon resume. While technically not a "fix" per se, it is an effective workaround that can be used until a kernel or driver revision properly corrects the issue.

Here is an example of an ath10k suspend service I have written for this issue:

My service can be used if you find no other solution to your issue.

Good luck.

3 Likes

Thanks for your solution.:slightly_smiling_face:

1 Like

You're very welcome, and I'm so glad that worked for you. It always makes me very happy when one of my services makes someone's system usable again. Congrats.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by