Atheros E220x Ethernet Card will not connect to internet after last update

As the title says, my ethernet card (Qualcomm Atheros Killer E220x) will not connect to the internet after the last update.

I have tried a couple of things to see if they would help. First, I used the System Settings Connections dialog to create a new connection, so I could fiddle with the parameters without risk of borking things worse. This went nowhere, so I clicked to delete it, but somehow my original connection got deleted. Next, I switched kernels from 5.4.13-3 back to 4.19.97-1. This also went nowhere, but I am still running the older kernel.

So, apparently a driver or something was "updated," or otherwise changed from something that worked perfectly fine to something that isn't working at all for me. This is currently the only OS on the only PC I am currently running, and I just need it to work. I have found and read some posts from this forum which addressed similar issues in the past, but I don't know which package, etc., may have caused the problem, and I have limited time to screw with this thing to get it online again. Tethering through my phone is not a viable option for more than another day or two. Please advise. Thank you.

inxi -Fxxxz
System:    Host: user-pc Kernel: 4.19.97-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0 Desktop: KDE Plasma 5.17.5 
           tk: Qt 5.14.0 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: ASRock model: 990FX Killer serial: <filter> UEFI [Legacy]: American Megatrends v: P1.60 
           date: 01/06/2016 
CPU:       Topology: 6-Core model: AMD FX-6350 bits: 64 type: MCP arch: Bulldozer L2 cache: 2048 KiB 
           flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 46702 
           Speed: 3886 MHz min/max: N/A Core speeds (MHz): 1: 3886 2: 3887 3: 3884 4: 3892 5: 3883 6: 3873 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] vendor: XFX Pine 
           driver: amdgpu v: kernel bus ID: 01:00.0 chip ID: 1002:67df 
           Display: x11 server: X.Org 1.20.7 driver: amdgpu FAILED: ati unloaded: modesetting,radeon alternate: fbdev,vesa 
           compositor: kwin_x11 tty: N/A 
           OpenGL: renderer: AMD Radeon RX 480 Graphics (POLARIS10 DRM 3.27.0 4.19.97-1-MANJARO LLVM 9.0.1) v: 4.5 Mesa 19.3.2 
           direct render: Yes 
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] SBx00 Azalia vendor: ASRock driver: snd_hda_intel v: kernel 
           bus ID: 00:14.2 chip ID: 1002:4383 
           Device-2: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] vendor: XFX Pine driver: snd_hda_intel 
           v: kernel bus ID: 01:00.1 chip ID: 1002:aaf0 
           Sound Server: ALSA v: k4.19.97-1-MANJARO 
Network:   Device-1: Qualcomm Atheros Killer E220x Gigabit Ethernet vendor: ASRock driver: alx v: kernel port: d000 
           bus ID: 03:00.0 chip ID: 1969:e091 
           IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           IF-ID-1: enp2s0u1 state: unknown speed: N/A duplex: N/A mac: <filter> 
Drives:    Local Storage: total: 1.96 TiB used: 495.63 GiB (24.6%) 
           ID-1: /dev/sda vendor: Western Digital model: WD1003FZEX-00MK2A0 size: 931.51 GiB speed: <unknown> 
           rotation: 7200 rpm serial: <filter> rev: 1A01 scheme: GPT 
           ID-2: /dev/sdb vendor: Maxtor model: 6L160M0 L30FWRBH size: 149.01 GiB speed: 1.5 Gb/s serial: <filter> rev: 1G10 
           scheme: GPT 
           ID-3: /dev/sdc vendor: Hitachi model: HUA721010KLA330 size: 931.51 GiB speed: 3.0 Gb/s serial: <filter> rev: AB0A 
           scheme: GPT 
Partition: ID-1: / size: 425.46 GiB used: 378.34 GiB (88.9%) fs: ext4 dev: /dev/sdc1 
           ID-2: swap-1 size: 32.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sdc4 
Sensors:   System Temperatures: cpu: 22.2 C mobo: N/A gpu: amdgpu temp: 33 C 
           Fan Speeds (RPM): N/A gpu: amdgpu fan: 1003 
Info:      Processes: 204 Uptime: 57m Memory: 15.64 GiB used: 1.77 GiB (11.3%) Init: systemd v: 242 Compilers: gcc: 9.2.0 
           clang: 9.0.1 Shell: bash v: 5.0.11 running in: yakuake inxi: 3.0.37 

cat /var/log/pacman.log | grep -i "ed linux\|mware\|twork\|dkms ins\|a-nm\|nm-c\|ufw\|wpa" | grep -v "head\|nvidia"  | tail -n 30
[2019-11-27T14:43:00-0800] [ALPM] upgraded linux414 (4.14.154-1 -> 4.14.155-1)
[2019-11-27T14:43:05-0800] [ALPM] upgraded linux419 (4.19.84-1 -> 4.19.85-1)
[2019-12-14T14:52:04-0800] [ALPM] upgraded alsa-firmware (1.0.29-2 -> 1.2.1-1)
[2019-12-14T14:54:26-0800] [ALPM] upgraded linux-firmware (20191022.2b016af-1 -> 20191118.e8a0f4c-2)
[2019-12-14T14:54:31-0800] [ALPM] upgraded linux414 (4.14.155-1 -> 4.14.158-1)
[2019-12-14T14:54:37-0800] [ALPM] upgraded linux419 (4.19.85-1 -> 4.19.88-1)
[2019-12-14T14:55:02-0800] [ALPM] upgraded wpa_supplicant (2:2.9-1 -> 2:2.9-2)
[2019-12-14T14:55:02-0800] [ALPM] upgraded networkmanager (1.20.6-1 -> 1.20.8-1)
[2019-12-14T14:55:09-0800] [ALPM] upgraded plasma-nm (5.17.3-1 -> 5.17.4-1)
[2019-12-27T18:28:47-0800] [ALPM] installed linux54 (5.4.2-1)
[2019-12-31T11:39:03-0800] [ALPM] upgraded glib-networking (2.62.1-1 -> 2.62.2-1)
[2019-12-31T11:40:29-0800] [ALPM] upgraded kdenetwork-filesharing (19.08.3-1 -> 19.12.0-1)
[2019-12-31T11:40:33-0800] [ALPM] upgraded lib32-glib-networking (2.62.1-1 -> 2.62.2-1)
[2019-12-31T11:41:03-0800] [ALPM] upgraded linux-firmware (20191118.e8a0f4c-2 -> 20191220.6871bff-1)
[2019-12-31T11:41:08-0800] [ALPM] upgraded linux414 (4.14.158-1 -> 4.14.160-1)
[2019-12-31T11:41:15-0800] [ALPM] upgraded linux419 (4.19.88-1 -> 4.19.91-1)
[2019-12-31T11:41:22-0800] [ALPM] upgraded linux54 (5.4.2-1 -> 5.4.6-2)
[2019-12-31T11:41:23-0800] [ALPM] upgraded wpa_supplicant (2:2.9-2 -> 2:2.9-3)
[2019-12-31T11:41:23-0800] [ALPM] upgraded networkmanager (1.20.8-1 -> 1.20.9dev+19+gcbb1ad1ba-1)
[2019-12-31T11:41:23-0800] [ALPM] upgraded networkmanager-qt (5.64.0-1 -> 5.65.0-2)
[2020-01-21T02:21:08-0800] [ALPM] upgraded glib-networking (2.62.2-1 -> 2.62.3-1)
[2020-01-21T02:21:32-0800] [ALPM] upgraded kdenetwork-filesharing (19.12.0-1 -> 19.12.1-1)
[2020-01-21T02:21:56-0800] [ALPM] upgraded lib32-glib-networking (2.62.2-1 -> 2.62.3-1)
[2020-01-21T02:22:26-0800] [ALPM] upgraded linux-firmware (20191220.6871bff-1 -> 20200114.9c340bd-1)
[2020-01-21T02:22:32-0800] [ALPM] upgraded linux414 (4.14.160-1 -> 4.14.166-1)
[2020-01-21T02:22:38-0800] [ALPM] upgraded linux419 (4.19.91-1 -> 4.19.97-1)
[2020-01-21T02:22:40-0800] [ALPM] upgraded linux54 (5.4.6-2 -> 5.4.13-3)
[2020-01-21T02:22:47-0800] [ALPM] upgraded networkmanager (1.20.9dev+19+gcbb1ad1ba-1 -> 1.22.4-1)
[2020-01-21T02:23:04-0800] [ALPM] upgraded plasma-nm (5.17.4-1 -> 5.17.5-1)
[2020-01-21T11:14:48-0800] [ALPM] removed linux54 (5.4.13-3)

  • The first step in troubleshooting any LAN issue should always be rebooting the router and computer.
  • If power cycling your router did not improve your connectivity then a full reset of your router may be required, see link below:
    https://www.online-tech-tips.com/computer-tips/reset-wireless-router-default-settings/
  • Have you tested other Manjaro live boot disks, or boot disks from other distros for comparison.
  • Have you tested different ports on the switch/router.
  • Have you tested different network cables. Cabling is often a source of connectivity and speed problems.
  • Do you have another router, or can you borrow a router to test for comparison.
  • Ensure there is no MAC address or IP filtering enabled in the router (and all new devices are allowed).
  • Resetting your computer bios to the factory default settings can be also be very helpful.
  • Install a bios update (if there is one available).

Have you made any modifications to the standard network configuration?

1 Like

If none of those suggestions improve things we can modify your network configuration.

Change the DHCP client backend to dhclient:

Mask the dhcpcd.service.

sudo systemctl mask dhcpcd.service           

Ensure dhclient is installed:

sudo pacman -S dhclient --needed

Change the DHCP client backend to dhclient by creating a configuration file in /etc/NetworkManager/conf.d/.

Run the following command to auto-generate the required conf file:

echo -e "[main]\ndhcp=dhclient" | sudo tee /etc/NetworkManager/conf.d/dhcp-client.conf

Install networkmanager-iwd from the AUR.

https://aur.archlinux.org/packages/networkmanager-iwd

This is a modified package configured to get NetworkManager working exclusively with iwd. Main difference with upstream version is that iwd is required and wpa_supplicant is not needed (so you can uninstall it); iwd seems more reliable on certain wireless cards, so someone could prefer it in place of wpa_supplicant.

Enable systemd iwd.service at boot:

systemctl enable iwd.service

Note that wpa_supplicant is still needed to build the package, but you can uninstall it after the building stage.

Reboot.

3 Likes

Thank you for your prompt and thorough responses, tbg.

I neglected to mention that I have confirmed internet connectivity through the router. First, using my phone's wifi, and next using my PC's UEFI online update feature (FWIW no updates were available).

The only thing that has been altered between my keyboard and the internet fiber is my manjaro install. I will proceed by following the steps you've prescribed in your second reply.

I ran the first two commands. Took a little longer because I did a little research on the mask command--I'd never used it. Also, is "dhcpclient" a typo? pacman didn't know what I was talking about, and neither did google.

[user@user-pc ~]$ sudo systemctl mask dhcpcd.service
[sudo] password for user: 
Created symlink /etc/systemd/system/dhcpcd.service ā†’ /dev/null.
[user@user-pc ~]$ sudo pacman -S dhcpclient --needed
error: target not found: dhcpclient

Yes, it was a typo that should be

sudo pacman -S dhclient --needed
1 Like

Well, that was fast! Thanks!

1 Like

Alright, so I am using yaourt to install networkmanager-iwd, and it has come up with a conflict while building the package:

==> Building and installing package
==> Install or build missing dependencies for networkmanager-iwd:
resolving dependencies...
looking for conflicting packages...
:: systemd-resolvconf and openresolv are in conflict. Remove openresolv? [y/N] 

So how to proceed, please?

Full output below:

 Which packages do you want search and install? 
networkmanager-iwd         
==> COMMAND: yaourt networkmanager-iwd 
1 aur/networkmanager-iwd 1.22.0-1 (Out of Date) (6) (1.44)
    NM modified package to use exclusively iwd backend getting rid of wpa_supplicant dependency
==> Enter nĀ° of packages to be installed (e.g., 1 2 3 or 1-3)
==> ---------------------------------------------------------
==> 1


==> Downloading networkmanager-iwd PKGBUILD from AUR...
x .SRCINFO
x PKGBUILD
x networkmanager-iwd.install
ilikenwf commented on <a href="#comment-714384" class="date">2019-10-31 16:29</a>                        

digitalone commented on <a href="#comment-714386" class="date">2019-10-31 16:45</a>                      

rpodgorny commented on <a href="#comment-714424" class="date">2019-11-01 00:43</a>                       

digitalone commented on <a href="#comment-719785" class="date">2019-12-08 08:14</a>                      

digitalone commented on <a href="#comment-721141" class="date">2019-12-17 19:11</a>                      

networkmanager-iwd 1.22.0-1  (2019-12-20 12:53)
( Unsupported package: Potentially dangerous ! )
==> Edit PKGBUILD ? [Y/n] ("A" to abort)
==> ------------------------------------
==> n

==> WARNING: This PKGBUILD describes a split package.
==> Specific package options are unknown
==> networkmanager-iwd dependencies:
 - dhclient (already installed) [makedepend]
 - iptables (already installed) [makedepend]
 - ppp=2.4.7 (already installed) [makedepend]
 - modemmanager (already installed) [makedepend]
 - iproute2 (already installed) [makedepend]
 - nss (already installed) [makedepend]
 - polkit (already installed) [makedepend]
 - wpa_supplicant (already installed) [makedepend]
 - curl (already installed) [makedepend]
 - systemd (already installed) [makedepend]
 - libmm-glib (already installed) [makedepend]
 - libnewt (already installed) [makedepend]
 - libndp (already installed) [makedepend]
 - libteam (already installed) [makedepend]
 - python-gobject (already installed) [makedepend]
 - git (already installed) [makedepend]
 - jansson (already installed) [makedepend]
 - bluez-libs (already installed) [makedepend]
 - dhcpcd (already installed) [makedepend]
 - dnsmasq (already installed) [makedepend]
 - libpsl (already installed) [makedepend]
 - audit (already installed) [makedepend]
 - libx11 (already installed)
 - python-dbus (already installed)
 - intltool (package found) [makedepend]
 - gobject-introspection (package found) [makedepend]
 - gtk-doc (package found) [makedepend]
 - vala (package found) [makedepend]
 - perl-yaml (package found) [makedepend]
 - glib2-docs (package found) [makedepend]
 - iwd (package found) [makedepend]
 - systemd-resolvconf (package found) [makedepend]
 - meson (package found) [makedepend]


==> Continue building networkmanager-iwd ? [Y/n]
==> --------------------------------------------
==> y

==> Building and installing package
==> Install or build missing dependencies for networkmanager-iwd:
resolving dependencies...
looking for conflicting packages...
:: systemd-resolvconf and openresolv are in conflict. Remove openresolv? [y/N] 

I'm going to go ahead and remove openresolv. Would rather bork the new package than the rest of the system.

Well, it took awhile, and there were a ton of warnings and several package conflicts, but networkmanager-iwd finally got installed.

I rebooted, and shut off my phone tethering. Viola, I had internet through my ethernet card. Then I realized I had forgotten to run

systemctl enable iwd.service

Yet, my internet was already working. I don't know just what this might indicate, but someone like tbg might. I ran the command, rebooted again, and my internet works.

Thank you very much for your help, tbg. You have saved Manjaro for me!

Switch to another AUR helper, yaourt has been discontinued.

2 Likes

This is likely a result of a bug in Network Manager and its dhcp client.

The AUR version of Network Manager is slightly older so it might be free of any new bugs introduced. I would wait for a couple of Manjaro updates then switch back to the regular version of Network Manager. Do not update networkmaager-iwd in the meantime.

You could probably have accomplished the same thing by downgrading the network manger package, but I thought this might be a good alternative to test out.

As @freggel.doe already mentioned please do not use yaourt, as it is deprecated. Use yay, trizen, or pacaur for a supported AUR helper.

Glad that fixed things for you.

Sounds like a plan, tbg. I will go with that. Thanks again for your help.

I will also look into the new AUR helper. Thanks for the heads-up on that, guys.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by